Вход | Регистрация

1С:Предприятие ::

Метки:

Как получить расшифровку отчета по конкретной позиции таблицы

Я
   Tech
28.04.04 - 02:41
Всем привет!
Помогите пожалуйста советом:
    Существует отчет, в котором отображается список сотрудников и выработка продукции по каждому из них за определенный период. Требуется, чтобы при выборе в этой таблице любой из фамилий выводилась новая, в которой отражена выработка по датам данного сотрудника. Если можно, то поподробнее, потому как опыт в 1С маленький...
Тему про расшифровку читал, но сколько не бился, никак не могу прикрутить туда новую таблицу.
 
 
   Tech
3 - 28.04.04 - 03:01
Процедура ПриОткрытии()
    КонПериода=ТекущаяДата();
    НачПериода=НачМесяца(ТекущаяДата());
КонецПроцедуры

Процедура Выработка()
    Перем Запрос, ТекстЗапроса, Таб;
        Запрос=СоздатьОбъект("Запрос");
        ТекстЗапроса="
        |Период с НачПериода по КонПериода;
        |Дата=Регистр.Выработка.Дата;
        |Фамилия=Регистр.Выработка.Фамилия;
        |ХрВыработка=Регистр.Выработка.ХрВыработка;
        |Функция ХрВыработкаФун=Сумма(ХрВыработка);
        |Группировка Фамилия;
        |";
        Запрос.Выполнить(ТекстЗапроса);
        Таб=СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("ПоГлобальному");
        Таб.ВывестиСекцию("Заголовок");
        Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
        Пока Запрос.Группировка("ПоГлобальному")=1 цикл
            Таб.ВывестиСекцию("ПоГлобальному");
        КонецЦикла;
        Таб.ВывестиСекцию("Итого");
        Таб.ТолькоПросмотр(1);
        Таб.Показать("ПоГлобальному");

КонецПроцедуры

А как в Расшифровке прикрутить вывод таблицы я не знаю ;(
   skunk
 
4 - 28.04.04 - 03:05
смотри ТиС к примеру Отчет.СостояниеЗаявки
   skunk
 
6 - 28.04.04 - 12:20
посмотри любой стандарты конфа... всяко разно должны быть... в ЗиКе есть сто пудово


Список тем форума
  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует