Вход | Регистрация


1С:Предприятие ::

Метки:

Глюки или что???

Я
   DElo
 
26.04.04 - 00:10
А вопрос такой: понамечали на удаление 45 объектов.
При попытке их удалить сообщается, что из 45 невозможно удалить 45.
Поскольку это в основном - контрагенты, то ссылки на удаляемый объект - договора (по основному договору на брата).
Эти договора, естественно, помечены на удаление тоже, как подчинённые элементы.
Почему не удаляется это всё??? Так глаза они режут в справочнике - достали уже. Как всё-таки от них избавиться???
 
 
   Поп Гапон
1 - 26.04.04 - 05:00
+(0) То же самое было несколько лет назад. Тогда приходилось удалять из dbf с помощью небольшой программки, написанной на Clarion, через конвертор (Clipper Summer работал слишком медленно). Да и база потом слетела...
Присоединяюсь к вопросу, что делать?
   skunk
 
2 - 26.04.04 - 05:13
поиск ссылок на объект...
   Поп Гапон
3 - 26.04.04 - 05:23
(0) А конфигурация какая, и релиз, пожалуйста?
Еще бы ТТХ компьютера узнать.
   Поп Гапон
4 - 26.04.04 - 05:24
(2) Запустил удаление, у меня кнопка Удалить вообще недоступна.
Хотя зашел монопольно.
   skunk
 
5 - 26.04.04 - 05:27
(4)сперва контроль
   skunk
 
6 - 26.04.04 - 05:28
+2 в окошке снизу он кажет ссылки... если они есть...
   Поп Гапон
7 - 26.04.04 - 05:29
(5) А, точно!!! Спасибо.

Но с (0) так и не разобрались,
DElo молчит(наверно на модеме).
Вопрос животрепещущий, однако.
   skunk
 
8 - 26.04.04 - 05:36
(7)угу... на модеме...

там сто пудово по докам проходят... по этому низя удалить... сперва из доков надо их повыкидывать...
   Поп Гапон
9 - 26.04.04 - 05:47
(8) Так это, ну, блин,
если кнопка буквой Х стоит, то понятно как, а если ее нет, то как контр-а с договором прибить?
   skunk
 
10 - 26.04.04 - 05:55
искаешь ссылки через поиск сылок на объекты... и оттуда... делаешь что бы не было ссылок...

то есть либо удаляешь то на что есть ссылка... либо туда толкаешь чего нить другого...

по идеи не то не другое не есть гуд... поскольку... там уже зависит, что за компонента...
 
  Рекламное место пустует
   DElo
 
11 - 26.04.04 - 22:32
(2)солнышко, ты ж меня знаешь, и вродь знаешь, что я не настолько полная идиотка, чтоб ссылки на объект не просмотреть. Абижаиш, да? Ссылкой на контрагента явл. "Осн. договор", а на "Осн. договор" - сам контрагент. Всё помечено на удаление, а не удаляется ни сразу, ни поодиночке(((
   DElo
 
12 - 26.04.04 - 22:33
(3)457 Бух. Компы - разные в сети, пробовала с разных машин
   DElo
 
13 - 26.04.04 - 22:36
(2,5,6,7,10)КОСТЯ!!! В доках их НЕТ!!! Стопудово!!! Какие и были "задвоенные" - я их капсами прописала, теперь у меня только "окапсённые" к докам привязаны, а эти... ну никак... что делать-то???
   Поп Гапон
14 - 27.04.04 - 02:01
(12-13) А чего такая горячка? Скинь лишних контров (их всего-то 45) в папочку "Мусор", и не будут они никому глаза мозолить.
А базу возьми себе на комп, спокойненько посмотри.

А skunkа не слушай, он мне такого в (10) посте насоветовал... А вдруг бы ЭТО услышал невинный ребенок, и сотворил ТАКОЕ над рабочей базой без бакапов???

П.С. Малость подслушал про какие-то капсы? А шо это?
   skunk
 
15 - 27.04.04 - 03:58
(14)и чего я там тебе на советовал...
   skunk
 
16 - 27.04.04 - 04:01
(13)тогда делай тестирование и исправление иб... и че она скажет в студию...

ps: для святого отца... 1с здесь говорит сделай бэк...
а вообще делать бэки... должно быть в настройках по умолчанию... когда чего-то делаешь с базой... особено если удаляешь
   AVP
17 - 27.04.04 - 10:30
В форме элемента справочника Контрагенты (для помеченных на удаление) РУЧКАМИ очистить поле ОсновнойДоговор. И все...
   Valery
 
18 - 27.04.04 - 10:50
Я делал таким чудом:
первым заходом выбираю только договора,а потом Контрагенты.
   AVP
19 - 27.04.04 - 11:12
(18) Не получится, ибо ОсновнойДоговор -это реквизит Справочника Контрагенты.
   Robinz
20 - 27.04.04 - 13:44
А может обработку:

//*******************************************

Процедура Сформировать()
    НачатьТранзакцию();
    Спр = СоздатьОбъект("Справочник.Контрагенты");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
        Если Спр.ПометкаУдаления()=1 Тогда
            Спр2 = СоздатьОбъект("Справочник.Основание");
            Спр2.ИспользоватьВладельца(Спр.ТекущийЭлемент());
            Спр2.ВыбратьЭлементы();
            Пока Спр2.ПолучитьЭлемент()=1 Цикл
                Спр2.Удалить(1);
            КонецЦикла;
            Спр.Удалить(1);
        КонецЕсли;
    КонецЦикла;
    ЗафиксироватьТранзакцию();
КонецПроцедуры
   skunk
 
21 - 27.04.04 - 14:32
(20)ну тогда их можно сразу бухать... без обработок...
   Поп Гапон
22 - 28.04.04 - 02:13
+(21) На рабочей базе без бэкапов. А потом застрелиться.
Хотя это грех, но Бог поймет.
   skunk
 
23 - 28.04.04 - 02:21
(22)смотри (16) специально для Вас... но в лом мне каждый раз писать... делай бэк... слома... сковородка... деволтом это все должно быть...

изголяешься в копии... как результат поимел... делай в рабочей...
   Поп Гапон
24 - 28.04.04 - 02:41
(23) Да просвещенный я поп. Начитаный, интиллигентный, грамотный. Не один год около 1С трусь, даже с сертификатами. Просто провакационные вопросы я люблю задавать.
   skunk
 
25 - 28.04.04 - 02:55
везет... а у меня образования три класса(сельско-приходской), да и те в коридорах... а дальше... дальше по стопам мудрого и великого вождя революции... по ссылкам да каторгам ;)
   Поп Гапон
26 - 28.04.04 - 03:26
(25) Зато у тебя три звездочки по ником. Не грусти.



Список тем форума
Рекламное место пустует  
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует