Вход | Регистрация

1С:Предприятие ::

Метки:Запросы и построители

помогите вытянуть шахматку из запроса плз

Я
   var
22.04.04 - 15:45
такой вот код а ругается что :

Значение не представляет агрегатный объект (ЗначениеУпорядочивания)
Пока Запрос.Группировка("День") = 1 Цикл
{F:\COMMON\LAST_MD77\EXTFORMS\1_ОТЧПЕРИОДТАБ1.ERT(6)}: Значение не представляет агрегатный объект (Группировка)

Перем Запрос;
//*******************************************

//Конструкции <<...>> необходимо заменить на реальные логические условия и значения переменных
Процедура Сформировать_Колонки(Таб, Стр)
    Таб.ВывестиСекцию(Стр+"|Начало");
    Пока Запрос.Группировка(2) = 1 Цикл
        Таб.ПрисоединитьСекцию(Стр+"|Колонка_1");
    КонецЦикла;
    Таб.ПрисоединитьСекцию(Стр+"|Конец");
КонецПроцедуры

//*******************************************

// Процедура генерации запроса Сформировать.
//

Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
   //|Без итогов;

    |Точка = Регистр.Торговля.Точка;
    |Сумма = Регистр.Торговля.Сумма;
    |Функция СуммаНачОст = НачОст(Сумма);
    |Группировка Точка все ВошедшиеВЗапрос;
    |Группировка День все;
    |//}}ЗАПРОС

    ;

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    Запрос.Выгрузить(ТЗ);


    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица1");

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
   //Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

    Пока Запрос.Группировка(1) = 1 Цикл
        Сформировать_Колонки(Таб, "Строка_1");
    КонецЦикла;

    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
 
 
   Valery
 
1 - 22.04.04 - 15:54
Убери в процедуре "Сформировать_Колонки" объявление переменной Запрос
и внеси ее в список параметров
   Valery
 
2 - 22.04.04 - 15:56
Ошибся, в процедуре "Сформировать"


Список тем форума
  Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует