Вход | Регистрация

1С:Предприятие ::

Метки:

Галочка в форме

Я
   VitZa
22.04.04 - 12:04
Туплю,
есть форма, в ней галочка, при её активации в печатной форме должно появлятся словосочетание "Оплата по факту"
у галочки индентификатор ОплатаПоФакту, формула соответсвенно Контроль(),
покажите мне неразумному где я туплю!!!!
ПОЖАЛУЙСТА!!!!!

Функция Контроль()
    Если ОплатаПоФакту =  0 Тогда  
        Возврат "";  
    иначе 
        Возврат "Оплата по факту";
    КонецЕсли;
 КонецФункции
 
  Рекламное место пустует
   Gavrila
 
1 - 22.04.04 - 12:12
А куда ты возвращаешь "Оплата по факту"...?
если напишешь так:
Функция Контроль() 
   Если ОплатаПоФакту =  0 Тогда   
       Возврат "";   
   иначе 
       Предупреждение("Оплата по факту");
       Возврат "Оплата по факту"; 
   КонецЕсли; 
КонецФункции
то при нажатии на "галочку" увидишь предупреждение...
и при чем тут печатная форма, если надо показать эту строку на печатной форме так проверяй значение флажка при формировании печатной формы
   VitZa
2 - 22.04.04 - 12:17
А возвращать "Оплата по факту" хочу в печатную форму, в строку где прописано выражение Контроль()
   Gavrila
 
3 - 22.04.04 - 12:20
> у галочки индентификатор ОплатаПоФакту, формула соответсвенно Контроль()
убираешь у галочки формулу.
У ячейки печ. формы где должна выводится строка, ставишь тип="Выражение", а значение=Контроль()
   VitZa
4 - 22.04.04 - 12:27
Не работает!8-(
   Gavrila
 
5 - 22.04.04 - 12:27
Что именно, и где, и как делаешь? :)
   VitZa
6 - 22.04.04 - 12:32
Внешняя печатная форма Товарной накладной,
В форме есть галочка,
в модуле есть функция Контроль()
в печатной форме есть выражение Контроль()
если есть галочка в печатной форме появляется фраза "Оплата по факту" и когда нет этой галочки все равно появляется эта фраза, а мне надо чтобы её не было когда нет галочки!
   12345
 
7 - 22.04.04 - 12:34
Уважаемые! 0 - это очень, очень похоже на Число. Если ОплатаПоФакту - строка,
то проверка типа ОплатаПоФакту=0 смысла не имеет. И работать не будет.
   VitZa
8 - 22.04.04 - 12:36
А как же мне тогда сказать 1с чтобы фразу выводила когда есть галочка и невыводила, когда этой галочки нет???
   Gavrila
 
9 - 22.04.04 - 12:39
(7) флажок- ето не "строка"
(6) проверь нет ли переменной "ОплатаПоФакту" в модуле, проверь по отладчику...
   VitZa
10 - 22.04.04 - 12:47
Спасибо!!!
Раступило!!!
Там была переменая!!!!
ААААААААААААААААААААААА
Я БУДУ ЖИТЬ!!!!!!!!!
 
  Рекламное место пустует
   Gavrila
 
11 - 22.04.04 - 12:49
Маладэц


Список тем форума
Рекламное место пустует   Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует