Вход | Регистрация

1С:Предприятие ::

Метки:

Таблица значений

Я
   ViCon
 
21.04.04 - 15:44
Создал таблицу значений, и определил в ней поля
    ТбЗн.НоваяКолонка("Водитель", "Строка", 50);
    ТбЗн.НоваяКолонка("ГСМ", "Строка", 25);
    ТбЗн.НоваяКолонка("ЕдИзм", "Строка", 25);
    ТбЗн.НоваяКолонка("ТбСтр", "ТаблицаЗначений");
возможно ли определить поле в таблице, у которого будет тип поля Таблица значений? И подскажите а как затем заносить данные в это поле?
Дело в том что мне надо выбрать данные в ТЗ, из главной и подчиненого справочника... может есть другой способ?
 
 
   Композитор
 
1 - 21.04.04 - 15:52
Простой пример
//*******************************************

Процедура Сформировать()
    Табл.УдалитьСтроки();
    Для Инд=1 По Метаданные.Справочник() Цикл
        ВидСправочника = Метаданные.Справочник(Инд).ПолныйИдентификатор();
        Табл.НоваяСтрока();
        Табл.Владелец = Метаданные.Справочник(Инд).Владелец;
        Табл.Справочник =ВидСправочника;
        Табл.ТаблРеквизиты = СоздатьОбъект("ТаблицаЗначений");
        Табл.ТаблРеквизиты.НоваяКолонка("Реквизит");
        Табл.ТаблРеквизиты.НоваяКолонка("ТипРеквизита");
        Для К = 1 По Метаданные.Справочник(Инд).Реквизит() Цикл
            Табл.ТаблРеквизиты.НоваяСтрока();
            Табл.ТаблРеквизиты.Реквизит = Метаданные.Справочник(Инд).Реквизит(К).Идентификатор;
            Табл.ТаблРеквизиты.ТипРеквизита = Метаданные.Справочник(Инд).Реквизит(К).Тип;     
        КонецЦикла;    
    КонецЦикла;

КонецПроцедуры

Процедура ПриОткрытии()
    Табл.НоваяКолонка("Владелец");
    Табл.НоваяКолонка("Справочник");
    Табл.НоваяКолонка("ТаблРеквизиты");
КонецПроцедуры
   Gavrila
 
2 - 21.04.04 - 15:52
НоваяТЗ = СоздатьОбъект("ТаблицаЗначений");
<...заполняешь НоваяТЗ данными, колонками ит.д. ...>
ТбЗн.ТбСтр.Загрузить(НоваяТЗ);
   ViCon
 
3 - 21.04.04 - 16:08
спасибо :)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует