Вход | Регистрация


1С:Предприятие ::

Метки:

Опять справочник номенклатуры:(((

Я
   Kisss
 
15.04.04 - 14:56
Господа, подскажите есть ли в 1С:Предприятии возможность не показывать в форме справочника номенклатуры те элементы, у которых нулевой остаток на складе??? При открытии формы естессенно видны все элементы, а надо - чтобы были видны токо те, которые есть в наличии.
Кто-то сталкивался с подобным?
Заранее благодарна:)
 
 
   Gavrila
 
1 - 15.04.04 - 15:12
В типовой "Торговля и склад для Украины" есть такой вот справочник, называется "Прайс-лист", так вот там ето реализовано. Не знаю правда есть ли ето в российской...
   Kisss
 
2 - 15.04.04 - 15:13
Ну что же вы молчите??? У меня бухгалтера из-за этого хотят "забастовку" объявить!
 Можно ЭТО сделать в форме справочника? Или только список создавать?
   Kisss
 
3 - 15.04.04 - 15:16
Я знаю, что это реализовано в ТиС. А в Бухгалтерии кто-нибудь делал подобное?
   Gavrila
 
4 - 15.04.04 - 15:16
(2) Используй функцию "ИспользоватьСписокЭлементов"
   Gavrila
 
5 - 15.04.04 - 15:18
(3) а какая разница? а разница только в том, как ты будешь проверять остатки
   Kisss
 
6 - 15.04.04 - 16:01
Спасибки!:) Пойду пробовать - может что и получится!
   Kisss
 
7 - 20.04.04 - 09:29
Сделала следующим образом:

СписокКПоказу=СоздатьОбъект("СписокЗначений");
Спр=СоздатьОбъект("Справочник.Номенклатура");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл  
    ТекЗнач = Спр.ТекущийЭлемент();
    Если БухИт.СКД(Сч41_2, "К",,ТекЗнач)>0 Тогда
       СписокКПоказу.ДобавитьЗначение(Спр.ТекущийЭлемент());
       Иначе
          Продолжить
    КонецЕсли;
КонецЦикла; 
Если СписокКПоказу.РазмерСписка()>0 Тогда
    ИспользоватьСписокЭлементов(СписокКПоказу);
КонецЕсли;

 В итоге - при подборе показывает элементы с ненулевыми остатками на складе. НО! Появляются пустые строки... слева значок синяя папка со знаком вопроса. Что это может быть и как с этим бороться?
   Marinka
 
8 - 20.04.04 - 09:44
Хм... а по-моему в типовой бухгалтерии есть кнопка подбор... когда на неё нажимешь - открывается справочник и при переходе от элемента к элементу внизу пишеться сколько материала/товара и т.п. осталось на складе... так не устраивает бухгалтеров?
   Kisss
 
9 - 20.04.04 - 09:58
Канешна есть эта волшебная кнопочка:) Но моим бухам надоть чтобы кол-во было видно не только в информационной строке (я там им еще и разными цветами показываю - есть в наличии или нет), но и в отдельной колонке. И при подборе чтобы были видны только те, которые есть в наличии (а то очень большой список получается - неудобно). Вот как...
   Marinka
 
10 - 20.04.04 - 10:04
Извращенцы какие-то... :)
 
  Рекламное место пустует
   Kisss
 
11 - 20.04.04 - 10:28
Уж не знаю...Возможно это все лишь очередная попытка отложить работу с 1С, уж больно они к своей "Фолио" привыкли:(
 Но всё-таки по существу может кто-нибудь помочь???
   V_K
 
12 - 20.04.04 - 11:09
Сделай новую форму списка, в ней ты можешь писать всё что угодно, это покрайней мере быстрее, чем переписать стандартную форму подбора. А вот туда ты можешь вставить свой список значений при выводе.
   GrayT
 
13 - 20.04.04 - 11:44
(9)Отключи иерархический просммотр
   GrayT
 
14 - 20.04.04 - 11:46
+ Т.е. (7) - Это по поводу пустых строк
   Kisss
 
15 - 20.04.04 - 11:52
Иерархия отключена, иначе при включенном отборе метод не работает. Там наверное что-то не так при задании условия...ведь в справочнике могут быть и услуги (=> кол-ва у них не может быть по определению), может из-за них эти пустые строки и вылетают? У строк пиктограмма со знаком "?"...
   GrayT
 
16 - 20.04.04 - 12:07
Не отбор, а иерархия
УстановитьОтбор("",);          
ИерархическийСписок(0);
ИспользоватьСписокЭлементов(СЗ);
   vch
17 - 20.04.04 - 12:27
(0) См. http://www.sinor.ru/~my1c/knowhow/ise_spr.html
Единственная тонкость - надо немного переделать фрагмент при количестве уровней в справочнике большем 3.
   Gavrila
 
18 - 20.04.04 - 12:53
В (17) правильно сказано, попробовал, все получилось...
Если не получится пиши, поможем
   Kisss
 
19 - 20.04.04 - 14:49
СПАСИБА!!!! Получилось!
Можно потом еще вопросик? ;) Опять же по номенклатуре....
   SiMazx
 
20 - 20.04.04 - 14:51
Ты когда первый вопрос задавал - интересовался, а можно ли?
Нет? Непорядок!!! ;))
   Kisss
 
21 - 20.04.04 - 14:54
Не "задавал", а "задавалА"... Всё равно - спасибо! :))) Еще вернусь - понравилось мне у вас!
   Kisss
 
22 - 20.04.04 - 15:47
Вопрос возник достаточно быстро. В "Перемещении товаров" по "Подбору" открывается вышеописанная форма справочника. Если элемент выбран, то он должен быть каким-либо образом отмечен. Для этого сделала в форме спр-ка поле с пиктограммкой (без идентификатора). Но обработка подбора осуществляется в форме документа... Может быть спр-ку добавить новый реквизит (поле, где выводится пиктограмма) и потом при выборе элемента присваивать ему значение???
   Gavrila
 
23 - 20.04.04 - 16:03
Если поле без идентификатора.
Вот нашел где-то(не помню где) было сделано так:
-В модуле формы подбора:
Перем Список;
Процедура ПриОткрытии()
  Список=Форма.Параметр;
  Форма.ОбработкаВыбораСтроки(1);
КонецПроцедуры

Функция ТестОтметки()
  Если Выбран()=0 Тогда
    Возврат 3;
  ИначеЕсли ЭтоГруппа()=1 Тогда
   //Возврат 3;

    Возврат ?(Список.НайтиЗначение(ТекущийЭлемент())=0,1,2);
  Иначе
    Возврат ?(Список.НайтиЗначение(ТекущийЭлемент())=0,1,2);
  КонецЕсли;
КонецФункции

Процедура ПриВыбореСтроки()
  Инд=Список.НайтиЗначение(ТекущийЭлемент());
  Если Инд=0 Тогда
    Список.ДобавитьЗначение(ТекущийЭлемент());
  Иначе
    Список.УдалитьЗначение(Инд);
  КонецЕсли;
  СтатусВозврата(0);
КонецПроцедуры

ВыборГруппы(1);
- в форме списка в поле с заголовком "отметка" в функции вызывется ТестОтметки()
   Kisss
 
24 - 20.04.04 - 16:29
Что-то не совсем понятно... Ведь к модулю формы подбора справочника (в которой и должна описываться функция с пиктограммами) обращение происходит ТОЛЬКО при нажатии кнопки "Подбор", а дальше обработка подбора происходит в модуле формы дока... и как обращаться к функции справочника???
ЗЫ. Бухи и правда - ИЗВРАЩЕНЦЫ!
ЗЫ.ЗЫ. А что делать? (грустно вздыхая)....
   Gavrila
 
25 - 20.04.04 - 16:40
Сорри, добавляешь еще это

Процедура ПриЗакрытии()
  Форма.ВыполнитьВыбор(Список);
КонецПроцедуры
   Gavrila
 
26 - 20.04.04 - 16:43
(+25) Таким образом у тебя в подборе заполняется список выбранных позиций, при закрытии ты этот список передаешь документу для обработки
   Kisss
 
27 - 21.04.04 - 11:02
Теперь у меня проблема с отбором....форма для подбора открывается достаточно быстро...но вот поиск по наименованию:((( Можно выпить чашечку кофе и выкурить сигаретку пока ищется какой-нить "гематоген"....што делать???
   Kisss
 
28 - 21.04.04 - 11:50
Кто-нибудь из присутствующих знает в чем может быть проблема: поиск по наименованию в основной форме справочника происходит быстро, а в форме для подбора жутко тормозит???
   SnarkHunter
 
29 - 21.04.04 - 11:54
Вычисляемые поля...
   Kisss
 
30 - 21.04.04 - 11:56
Вычисляемые поля - остатки товаров. Но они ОДИНАКОВЫЕ для основной и для подбора... может я неправильно формулирую? Становлюсь на поле "Наименование" и начинаю набирать название товара. В основной форме - всё ОК, а для подбора - тормоза.
   SnarkHunter
 
31 - 21.04.04 - 11:58
Чудес не бывает...
   GrayT
 
32 - 21.04.04 - 12:24
А как считаются вычисляемые поля? Может тут тормоза
   GrayT
 
33 - 21.04.04 - 12:27
+32. Сорри, невнимательно прочитал предыдущие посты
 
 
   427
 
34 - 21.04.04 - 12:39
Ё..... Убери УстановитьПоборы - взлетит ....



Список тем форума
Рекламное место пустует  
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует