Вход | Регистрация

1С:Предприятие ::

Метки:

Использовать СписокЭлементов глючит?

Я
   Василий
15.04.04 - 14:35
база на SQL2000 движок 20
В форме списка справочника пытаюсь отфильтровать часть элементов
вот так:

Процедура ПриОткрытии()
Если глПоДоговору=1 Тогда     
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса ="
    |Врачи = Справочник.Врачи.ТекущийЭлемент;
    |ПоДоговору = Справочник.Врачи.ММУ.ПоДоговору;
    |Группировка Врачи упорядочить по Врачи.Фамилия, Врачи.Имя;
    |Условие(ПоДоговору = 1);";
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

      с=СоздатьОбъект("СписокЗначений");
    Пока Запрос.Группировка(1) = 1 Цикл
        с.ДобавитьЗначение(Запрос.Врачи);
    КонецЦикла;    
    ИспользоватьСписокЭлементов(с);

КонецЕсли;
Сортировка("Фамилия",0);
КонецПроцедуры

оно фильтрует но проблема в том что если используется метод ИспользоватьСписокЭлементов(), то  на форме перестает нормально работать поиск по первым буквам фамилий. Некоторых ищет, некоторых нет... Английских букв в фамилиях нет, проверял... Число элементов в справочнике около 2500

в МДшнике по полю "Фамилия" стоят галочки Отбор и Сортировка.

Если создавать свою обработку, на неё ТЗ и туда кидать элементы, всё ищется прекрасно. Но это "танцы с бубном". хочется докопаться до причины.

какие мысли, почему может не работать поиск на форме?
 
  Рекламное место пустует
   Gavrila
 
1 - 15.04.04 - 18:31
Попробуй разные релизы платформы. :)
   Василий
2 - 15.04.04 - 22:27
Пробовал ДБФный движок. Не помогает.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует