Вход | Регистрация

Информационные технологии ::

Метки:

Как определить документ??

Я
   Silver
08.12.03 - 10:11
Уважаемые знатоки!!
Подскажите плиз, как определить из какого документа вызван справочник??
 
  Рекламное место пустует
   skunk
 
1 - 08.12.03 - 10:13
а где хочешь определить
   Silver
2 - 08.12.03 - 10:16
1С Предприятие 7
   Silver
3 - 08.12.03 - 10:21
Нужно в зависимости от вида, документа в справочнике, ну допустим "материалы", включать разные фильтры.
   skunk
 
4 - 08.12.03 - 10:25
Ладно понятно!
Тогда используй форма.параметр
   skunk
 
5 - 08.12.03 - 10:52
В Документах создаешь процедуру

Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога, ФлагСтандОбр)
Если ИдентЭлемДиалога = "Проект" Тогда
       ФлагСтандОбр = 0;
       ОткрытьПодбор("Проекты", "ФормаСписка", Вид());
   КонецЕсли;
КонецПроцедуры

А в справочнике

Процедура ПриОткрытии()
   Парам = Форма.Параметр;
КонецПроцедуры

В Парам получаешь текстовое представление документа как он задан в конфигураторе;

P.S. Обе процедуры предопределенные и могут уже встречаться, будь бдителен.
   Silver
6 - 08.12.03 - 11:30
Большое спасибо.
Помогло.
   skunk
 
7 - 08.12.03 - 11:38
всегда пожалуйста


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует