Вход | Регистрация


1С:Предприятие ::

Метки:

Подскажите где неправильно?

Я
   tonic
 
13.04.04 - 12:48
В модуле справичника пишу процедуру:
Процедура Резервы()
    товар1=ТекущийЭлемент();
    Склад1=Склад;
    Запрос=СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Тов=Регистр.РезервыТоваров.Товар;
    |Скл=Регистр.РезервыТоваров.Склад;
    |Сч=Регистр.РезервыТоваров.ПоСчету;
    |РезТовара=Регистр.РезервыТоваров.РезервТОвара;
    |Функция КоличествоКонОст=КонОст(РезТовара);
    |Группировка Сч;
    |Условие (Тов=ТекущийЭлемент());
    |Условие (Скл=Склад);
    |";  
 Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Сообщить("Немогу выполнить");
    Возврат;
 КонецЕсли;
   
ТабРезерв = СоздатьОбъект("ТаблицаЗначений");
Запрос.Выгрузить(ТабРезерв,0,1);
ТабРезерв.ВыбратьСтроки();

Пока ТабРезерв.ПолучитьСтроку()=1 Цикл
Сообщить("Есть строки");
КонецЦикла;
КонецПроцедуры

Вроде все правильно, но когда я просматриваю в Отладчике, поля тов и скл пустые и соответственно Запрс не чего не возвращает, ГДЕ ОШИБКА:(((
Спасибо.
P.S. Конфа не стандартная.
 
  Рекламное место пустует
   427
 
1 - 13.04.04 - 12:59
где даты?
что есть склад в \"Склад1=Склад\" ? Ссылка на элемент или название склада?
   tonic
 
2 - 13.04.04 - 13:06
(1) Даты нет, она не обязательна, Склад1=Склад ссылка на поле в форме справочника где выбираються склады, впринцепе ее можно опустить тогда в Условии пишем Скл=Склад, Я как понимаю это не принципиально, так:)
   Z1
3 - 13.04.04 - 13:07
Условия в запросе следущие :

   |Условие (Тов=Товар1); 
   |Условие (Скл=Склад1); 
   |";   

Считает резерв наверное на ТА. Зачем тебе остаток по счету незнаю?
   tonic
 
4 - 13.04.04 - 13:19
(3) Правильно, Остаток по счету не мне нушен а нашим манагерам:))
Когда я это делел для отчета все радотало все правильно выводилось, а вот теперь они захотели чтобы такаяже фигня у них в справочнике выводилась по нажатию на кнопку, вот тут я и застрял:((
По поводу Условий Вы все правильно написали, я просто когда печатал непоставил 1:))
   Z1
5 - 13.04.04 - 13:34
(4) Обычно текст запроса переносяь через clipboard.
А так еще и гадать что у тебя в конфигураторе и что ты набил здесь ну очень сложно - супертелепатия.
Я кажеться понял ( если запрос правильный ) то скорее всего запрос выполняется в формуле. Тогда времено убери запрос с формулы на кнопку, нажми на кнопку и будешь удивлен.
   tonic
 
6 - 13.04.04 - 13:38
(5) Прости я чтото непонял, как это убрать "запрос с формулы на кнопку", какже тогда программа поймет что при нажатии на кнопку должна запуститься именно это процедура?
   Gavrila
 
7 - 13.04.04 - 13:39
Ты уже разобрался? или нет...
Скопировал твой код, убрал условие по складу (нет у меня в резервах измерения "склад") и все работает.
   tonic
 
8 - 13.04.04 - 13:39
(5) Запрос 100 пудов правильный, так как он без изменений прекрасно работает в Отчете, А вот в справочнике не хочет:(
   tonic
 
9 - 13.04.04 - 13:41
(7) А куда ты мой код скопировал в справочник али в отчет?
   Gavrila
 
10 - 13.04.04 - 13:41
А ты уверен, что есть резерв по "текущийэлемент()" и "Склад"?:)
 
  Рекламное место пустует
   Gavrila
 
11 - 13.04.04 - 13:41
В форму списка "Формасписка" и "для подбора"
   tonic
 
12 - 13.04.04 - 13:42
(10) Уверен:) Я на такие фичи наступил когда писал этот запрос в отчете, долго не мог понять почему он не работает, а потом выяснилось что у товара который я выбирал не содоржит резерва:) Так что я теперь более внимателен:)
   Gavrila
 
13 - 13.04.04 - 13:43
"Конфа" - типовая торговля для украины
   Z1
14 - 13.04.04 - 13:45
(6) Создать на форме новуюкнопку.
В ее формуле поставить  Резервы(). Во всех других местах вызов резервы убери.
Входишь в предприятие и нажимаешь новую кнопку.
   Gavrila
 
15 - 13.04.04 - 13:45
Блин... становится интересно 8:)
   tonic
 
16 - 13.04.04 - 13:48
(14) У меня так оно и есть:))
(15) Не говори:))) Мне аж жуть берет:)))
   Favorit
 
17 - 13.04.04 - 13:50
А вообще в регистрв товар и склад данные попадают? может они пустые?
   427
 
18 - 13.04.04 - 13:52
да.... насчет формулы я не сообразил .....
   Gavrila
 
19 - 13.04.04 - 13:55
(16) Попробуй все же убрать условия!
а вместо 
       ТабРезерв.ВыбратьСтроки(); 
       Пока ТабРезерв.ПолучитьСтроку()=1 Цикл 
         Сообщить("Есть строки"); 
       КонецЦикла; 
напиши
       ТабРезерв.ВыбратьСтроку();

и посмотри что тама есть такого интересного.
какой релиз платформы?
   SnarkHunter
 
20 - 13.04.04 - 14:00
Регистр.РезервыТоваров.ПоСчету - ПоСчету это измерение?
   tonic
 
21 - 13.04.04 - 14:04
(19) Убрал, выдает содержание регистра
Повидимому ошибка в Условии, но я не могу понять где:(((
   tonic
 
22 - 13.04.04 - 14:05
(20) ДА это измерение
   Gavrila
 
23 - 13.04.04 - 14:07
Попробуй
Склад1=Склад.ТекущийЭлемент;
   Gavrila
 
24 - 13.04.04 - 14:07
Извини
Склад1=Склад.ТекущийЭлемент();
   SnarkHunter
 
25 - 13.04.04 - 14:12
Или "в" вместо "="...
   tonic
 
26 - 13.04.04 - 14:16
УФФФ ну славо богу, заработало, только еще надо было указать что товар1=Товар.ТекущийЭлемент()
:)))))))
Спасибо Gavrila:))))))))))))
   Gavrila
 
27 - 13.04.04 - 14:22
Поздравляю, только в условии можно было сразу указывать
|Условие (Тов=ТекущийЭлемент());
как написано в (1)
   tonic
 
28 - 13.04.04 - 14:26
(27) А ну да:)))



Список тем форума
  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует