Вход | Регистрация

1С:Предприятие ::

Метки:

Как определить автора документа?

Я
   Сергей
12.04.04 - 11:08
Скажите пожалуйста, можно ли определить автора документа не заглядывая в Монитор пользователей и без добавления в документ нового реквизита? Что-то в ЖКК я такого не нашел или я плохо смотрел?
 
 
   NastyFrog
 
1 - 12.04.04 - 11:12
Реквизит Автор по умолчанию вроде, или для самописной конфы?
   GrayT
 
2 - 12.04.04 - 11:34
Проще с новым реквизитом (общим). А если без, то можно через анализ журнал регистрации
   Сергей
3 - 12.04.04 - 11:43
(1) Нет конфа не самописная но некоторые документы переделаны на много раз. Но реквизита Автор нет.

(2) Если даже я добавлю новый реквизит, то как открывая документ прошлого года получить его автора?
   GrayT
 
4 - 12.04.04 - 11:45
Не самописная? Какая? Вроде во всех конфах есть общий реквизит Автор.
   Dionisious
 
5 - 12.04.04 - 11:51
(4) В бухгалтерии нету.
   Dionisious
 
6 - 12.04.04 - 11:55
Во встроенном языке нету функций для работы с журналом регистрации. Единственный вариант писать самому процедуры по обработке файла журнала регистрации.
   Львенок
 
7 - 12.04.04 - 11:55
(3) Ну, знаешь ли... Как говорится, поздно пить боржоми, когда печень отлетела... Хотя, пожалуй сделать-то можно, но оно нужно? Добавляй общий реквизит, коли нет (хотя я действительно не могу припомнить типовой конфы, в которой его нет) и с этого момента заполняй его и будет тебе счастье.
___
Искренне Ваш, Львенок.
   SiMazx
 
8 - 12.04.04 - 11:56
(3) Пиши обработку по анализу млг...  И заполни поле Автор...
   GrayT
 
9 - 12.04.04 - 11:57
(5)Упс, и вправду нету :(
Давно прикрутил и забыл :)))
   Сергей
10 - 12.04.04 - 12:30
(8) Что значит "по анализу млг...  "?
 
  Рекламное место пустует
   Лена
11 - 12.04.04 - 12:55
Перем создан;
Перем перепроведен;
//*******************************************

Процедура Выполнить()   
   // делается копия текстового файла 1cv7.mlg 

    Таб=СоздатьОбъект("Таблица"); 
    Таб.ВывестиСекцию("Шапка");
    Текст=создатьОбъект("Текст");
    Текст.Открыть("D:\(твоя база)\SYSLOG\Копия 1cv7.mlg");  
    КолСтр=Текст.КоличествоСтрок(); 
    Запрос = СоздатьОбъект("Запрос"); 
   //дата проведения первого документа в базе

    Дата1="01.03.04"; 
   //дата проведения последнего документа в базе

    Дата2="12.04.04"; 
   //создается запрос для выборки документов

    ТекстЗап =  
    "//{{ЗАПРОС(Сформировать)

    |с Дата1 по Дата2;
    |Док=Регистр.Взаиморасчеты.Документ;   
    |Сумма = Регистр.Взаиморасчеты.СуммаОбщая;
    |Функция Приход = Приход(Сумма);   
    |Группировка Док;
    |//}}ЗАПРОС         

    ;   
    Если Запрос.Выполнить(ТекстЗап)=0 Тогда
        Возврат; 
    Конецесли;
    Пока Запрос.Группировка("Док")=1 Цикл    
        Док=Запрос.Док;
        НомДок=Док.НомерДок;  
        сообщить(НомДок);
        Для й=1 по КолСтр цикл  
            ф1=0; ф2=0;
            Строчка=Текст.ПолучитьСтроку(й);  
           //записан первый раз

            Если (Найти(Строчка,"DocWriteNew")<>0) и 
                 (Найти(Строчка,НомДок)=1) тогда
                ДлинаСтр=СтрДлина(Строчка);  
                Для к=19 по ДлинаСтр цикл
                    если (Сред(Строчка,к,1)<>";") и (ф1=0) тогда 
                        создан=Сред(Строчка,19,к-19); 
                    иначе
                        ф1=1;
                    Конецесли;
                КонецЦикла;     
            КонецЕсли;     
           //перепроведён

            Если (Найти(Строчка,"DocBackPassed")<>0) и 
                 (Найти(Строчка,НомДок)=1) тогда
                ДлинаСтр=СтрДлина(Строчка);
                Для к=19 по ДлинаСтр цикл
                    если (Сред(Строчка,к,1)<>";") и (ф2=0) тогда 
                        перепроведен=Сред(Строчка,19,к-19); 
                    иначе    
                        ф2=1;
                    Конецесли;
                КонецЦикла;    
            КонецЕсли;    
        КонецЦикла;
        Таб.ВывестиСекцию("Строка");
    КонецЦикла;      
    Таб.Показать();
КонецПроцедуры
P.S. Милый, это то что тебе нужно, у меня работает,только попробуй на копии :)
    А если совместить получение данных с присвоением их в реквизит
    Автор, то прокрутив это один раз все документы будут иметь своего
    автора и последнего перепроводившего
   Лена
12 - 12.04.04 - 13:00
Да, с тебя причетается :))
   SnarkHunter
 
13 - 12.04.04 - 13:06
Вот я встречал полуторагигабайтный файл журанала регистрации... Как ты думаешь, сколько времени будет этот запрос работать?
   Лена
14 - 12.04.04 - 13:14
Работать будет не очень долго, так как файл в базе не большой,
я это точно знаю, к тому же не торговля, как у меня.
А вообще не слишком рационально конечно, но если кто то может
предложить лучше милости прошу :))


Список тем форума
Рекламное место пустует   Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует