Вход | Регистрация

1С:Предприятие ::

Метки:

КорСчета в запросе

Я
   Term2
 
12.04.04 - 10:45
СписокСчетов = "Н01, Н02, Н03, Н04, 50, 51, 76, 76.1, 62.1";
БухИт.ВыполнитьЗапрос(Дата1, Дата2, СписокСчетов,,,, "Проводка",);

Как сделать так, чтобы не отбирались итоги по КоррСчетам?
 
  Рекламное место пустует
   SiMazx
 
1 - 12.04.04 - 11:42
То есть? Ты объясни, тебе чего конкретно надо-то?
Желательно с примером твоего кода...
   Term2
 
2 - 12.04.04 - 11:56
Это код из упрощенной системы налогообложения, Книга учета доходов и расходов.
В список счетов я добавил еще счета и он стал формировать книгу не правильно. В одну строку выводит и доходы и расходы. Например у документа расходный кассовый ордер выводит и расход и доход, хотя по идее доходов здесь быть не должно.

БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
    БухИт.ВключатьСубсчета(-1, 0);
    БухИт.Опции(1,0);
    Если ОбъектНалогообложения = ДоходыМинусРасходы Тогда
        СписокСчетов = "Н01, Н02, Н03, Н04, 50, 51, 76, 76.1, 62.1";
    Иначе
        СписокСчетов = "Н01, Н03";
    КонецЕсли;
    
    БухИт.ВыполнитьЗапрос(Дата1, Дата2, СписокСчетов,,,, "Проводка",);
    БухИт.ВыбратьПериоды(,,,);
    Пока БухИт.ПолучитьПериод(,) = 1 Цикл
        
        Доходы = 0;
        Расходы = 0; 
        ДоходыБУ = 0;
        РасходыБУ = 0;                                  
                
        БухИт.ВыбратьСчета(,,,);
        Пока БухИт.ПолучитьСчет(,) = 1 Цикл
            Если (БухИт.КО()<>0) Тогда
                ДоходыБУ = БухИт.КО();
                РасходыБУ = 0;
            ИначеЕсли (БухИт.ДО()<>0) Тогда
                РасходыБУ = БухИт.ДО();
                ДоходыБУ = 0;
            КонецЕсли;
        КонецЦикла;
        
        ПолучитьАтрибутыПроводки(БухИт.Операция, НомерСтрокиДок, ДатаНомерДок, СодержОперации, Описание, НДС);
        
        ТаблУчета.НоваяСтрока();
        ТаблУчета.Документ = БухИт.Операция.Документ;
        ТаблУчета.НомерСтрокиДок = НомерСтрокиДок;
        ТаблУчета.ДатаНомерДок   = ДатаНомерДок;
        ТаблУчета.СодержОперации = (СокрЛП(СодержОперации));
        ТаблУчета.Описание = (СокрЛП(Описание));
        ТаблУчета.Доходы  = Доходы;
        ТаблУчета.Расходы = Расходы;
        ТаблУчета.ДоходыБУ  = ДоходыБУ;//Вот здесь должны быть либо 

        ТаблУчета.РасходыБУ = РасходыБУ;//доходы либо расходы

        ТаблУчета.НомерКвартала = НомерКвартала(БухИт.Операция.ДатаОперации);
        ТаблУчета.НДС = НДС; 
        ТаблУчета.Счетчик = Счетчик;
        Счетчик = Счетчик + 1;
        
    КонецЦикла;


Список тем форума
  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует