Вход | Регистрация

1С:Предприятие ::

Метки:Запросы и построители

Обход группировок запроса

Я
   Василий
10.04.04 - 15:48
у меня 2 группировки в запросе

Пока Запрос.Группировка(1) = 1 Цикл
    Пока Запрос.Группировка(2) = 1 Цикл
                        // ХХХХ

    КонецЦикла;
КонецЦикла;

Могу ли я из места ХХХ прервать цикл и начать обрабатывать следующее значение первой группировки?

Если делать так :

    Пока Запрос.Группировка(1) = 1 Цикл
                Все=0;
        Пока (Запрос.Группировка(2) = 1) и (всё=0) Цикл
                       Если YYYYY тогда
                           всё=1
                       конецЕсли;
        КонецЦикла;
    КонецЦикла;

то оно выдаёт вообще какую-то фигню в строках запроса.
что делать?
 
  Рекламное место пустует
   Композитор
 
1 - 10.04.04 - 16:50
На всякий случай. всЕ <> всЁ.
   SnarkHunter
 
2 - 10.04.04 - 17:01
ЖКК, часть2, гл.33 стр.781
- при просмотре временного набора данных, вложенность циклов про­смотра должна точно повторять порядок группировок запроса (нельзя входить во вложенную группировку, не войдя в предыдущую);
- допускается просматривать временный набор данных, опуская с некото­рого уровня все вложенные (внутренние) группировки;
- не следует прерывать последовательность просмотра временного набора данных (например, оператором Прервать;), если вы собираетесь ис­пользовать временный набор дальше или еще раз, т. к. в таком случае те­ряется точка позиционирования во временном наборе и продолжать про­смотр невозможно;
   Василий
3 - 10.04.04 - 18:27
Значит таким образом как я пытаюсь, сделать невозможно?
а как тогда быть если я не хочу перебирать все элементы запроса?
   skunk
 
4 - 10.04.04 - 18:31
выгрузить в таблицу...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует