Вход | Регистрация

  1  2   
О жизни... ::

Метки:

OFF: Набирается экспедиция на Марс. Требования: знание 1С ...

Я
   mszsuz
 
09.04.04 - 16:18
Дело в том, что бортовой компьютер будет управляться операционной системой 1С.
Процедура ПриНачалеРаботыСистемы()
   НаборУчастников();
   // ...
КонецПроцедуры
Взлетит? ;)
 
  Рекламное место пустует
   Рупор абсурда
 
1 - 09.04.04 - 16:20
Спирит искать?
   PilotBrian
 
2 - 09.04.04 - 16:23
Если PilotBrian<>0 тогда
 Участники.Добавить(PilotBrian);
КонецЕсли;
   mszsuz
 
3 - 09.04.04 - 16:23
(1) Спирту мы и здесь найдем ;)
   mszsuz
 
4 - 09.04.04 - 16:26
(2)
Если PilotBrian<<?>><>0 тогда
{(1)}: Переменная не определена (PilotBrian)
Участники<<?>>.Добавить(PilotBrian);
{(2)}: Переменная не определена (Участники)
При проверке модуля обнаружены синтаксические ошибки!
   Рупор абсурда
 
5 - 09.04.04 - 16:26
- Слыхал? 1С-ники на Марс полетели ...
- Шо, все?
   Рупор абсурда
 
6 - 09.04.04 - 16:34
(4) 1. Чайник! Добавь в начале процедуры: Перем PilotBrian;
2. RTFM!
   mszsuz
 
7 - 09.04.04 - 16:35
(2) Надо было переменную объявить или заранее присвоить какое-нить значение. Или на крайняк в Попытку..Исключение вставить.
В принципе, можно и интерпретатор переделать.
...
Все. Переделал.
Сообщить(Участники.РазмерСписка());
>> 1
   mszsuz
 
8 - 09.04.04 - 16:38
Как думаете, может Рупора вручную - ч/з ВводОстатков занести?
   PilotBrian
 
9 - 09.04.04 - 16:43
Перем PilotBrian;

Процедура НаборУчастников()
   Участники=СоздатьОбъект("ТаблицаЗначений");
   Участники.НоваяКолонка("Ник","Строка",,,"ФИО",30);
   Участники.НоваяКолонка("ДатаРег","Дата",,,"Дата поступления");
   
   PilotBrian=1;
   Если PilotBrian<>0 тогда
       Участники.НоваяСтрока();
       Участники.Ник="PilotBrian";
       Участники.ДатаРег=ТекущаяДата();
   КонецЕсли;
   Сообщить("ОО  "+PilotBrian);
КонецПроцедуры

Так пойдет? =)
   Рупор абсурда
 
10 - 09.04.04 - 16:43
(8) Меня и здесь неплохо кормят (с) Бекас вроде ...
Да и опоздал ты ..., они уж с полгода назад все на Ламерию улетели ...
 
 
   mszsuz
 
11 - 09.04.04 - 16:48
(9) Принят! Твое имя выгравировали на корпусе корабля.
...
Спирту уже нашел.
...
Рупора занес. Провел. Проверил отчетом - уже двое.
...
Попросил у Волшебника базу "Посетители форума".
Всем разослал повестки.
Проверьте вложения - у кого-то должен быть счастливый билетик. Описание "счастья" в самораспаковывающемся архиве.
   mszsuz
 
12 - 09.04.04 - 16:51
Связался по аське с Ламерией. Обещали всех одеть, накормить и вернуть.
   Рупор абсурда
 
13 - 09.04.04 - 17:00
(11) Ура! Мне пришла повестка с вложением!
Только вот архив не сразу распаковался ...
Пришлось Касперского снести, а то он ругался, говорил там вирус I-Worm.Happiness.q ...
Ох и глючный он, этот Касперский ...
   mszsuz
 
14 - 09.04.04 - 17:08
(13) С Касперским разберемся. Они на пару с Доктором Вебом усиленно в 1С вирусы ищут. А по тяпницам вообще глючат. У себя тоже снес, на всякий случай ...
   Рупор абсурда
 
15 - 09.04.04 - 17:19
Блин, Пилот слинял куда-то ...
Вдвоём чтоль летим? У тебя права то хоть на ракету есть?
   mszsuz
 
16 - 09.04.04 - 17:25
Пилот уже в кубрике спит.
...
Сертификат покатит? Ещё "БЦ" есть ...
Мы проще поступим - "продавцов полосатых палочек" брать с собой не будем, значит можно и без прав.
   Рупор абсурда
 
17 - 09.04.04 - 17:28
(16) А порулить дашь?
   mszsuz
 
18 - 09.04.04 - 17:31
Порули, пока не взлетели ...
   ally
 
19 - 09.04.04 - 18:11
И я хочуПроцедура НаборУчастников()
  Участники=СоздатьОбъект("ТаблицаЗначений");
  Участники.НоваяКолонка("Ник","Строка",,,"ФИО",30);
  Участники.НоваяКолонка("ДатаРег","Дата",,,"Дата поступления");
   
     Летуны= СоздатьОбъект("Справочник.ЖелающиеЛететьНаМарс");
   Летуны.ПорядокНаименований();
   Летуны.ВыбратьЭлементы(0);
   Пока Летуны.ПолучитьЭлемент()=1 Цикл
       Если Летуны.ЭтоГруппа() = 1 Тогда
           Продолжить;
       КонецЕсли;
       
       Если глЗарегистрированНаМисте(Летуны.ТекущийЭлемент()) = 0 Тогда
           Продолжить;
       Иначе
           Сообщить("А ты полетишь в сад,"+Летуны.ТекущийЭлемент());
       КонецЕсли;
       Если Летуны.ТекущийЭлемент().Пол="Ж" Тогда
           Если Летуны.ТекущийЭлемент().Наименование="ally" Тогда
               Участники.НоваяСтрока();
                 Участники.Ник="ally";
                 Участники.ДатаРег=ТекущаяДата();
             КонецЕсли;
         Иначе        
           Участники.НоваяСтрока();
             Участники.Ник=Летуны.ТекущийЭлемент().Наименование;
             Участники.ДатаРег=ТекущаяДата();
       КонецЕсли;
       
   КонецЦикла;
   
   //Спешали для пилота
   
  PilotBrian=1;
  Если PilotBrian<>0 тогда
      Участники.НоваяСтрока();
      Участники.Ник="PilotBrian";
      Участники.ДатаРег=ТекущаяДата();
  КонецЕсли;
  Сообщить("ОО  "+PilotBrian);
КонецПроцедуры
   skunk
 
20 - 09.04.04 - 18:16
дяди тоже в космос летать стали?
   Рупор абсурда
 
21 - 09.04.04 - 18:20
(19) Ты одна не выдержишь таких перегрузок ...
   mszsuz
 
22 - 09.04.04 - 18:23
(19) Ну что можно сказать - сразу видно опытного астронавта ;)
Сообщить(Участники.РазмерСписка());
>> 3
...
(20) А сколько по твоему ещё нужно над собачками измываться?
   skunk
 
23 - 09.04.04 - 18:27
(22)собачки летали на марс... незнал... отсал от жизни...
   ally
 
24 - 09.04.04 - 18:27
(21)Сфигали, это еще посмотрим кто не выдержит ;-)
   Рупор абсурда
 
25 - 09.04.04 - 18:28
(23) Щенки летали на Ламерию :))
   skunk
 
26 - 09.04.04 - 18:31
(25)намек ясен...
   fellow
 
27 - 09.04.04 - 18:32
Алё, зайцы, на Марсе уже перенаселение. Двигайте лучше на Сникерс, там недобор персонала.
   Рупор абсурда
 
28 - 09.04.04 - 18:35
Сори, тест: А не в баньке ли я уже?
   fellow
 
29 - 09.04.04 - 18:36
Боишься?
   mszsuz
 
30 - 09.04.04 - 18:37
(27) Какое-там перенаселение - сегодня целый день играл в GTA на марсоходе, смог задавить только двух разноцветных придурков. По показаниям приборов больше жизни на Марсе нет ...
   fellow
 
31 - 09.04.04 - 18:39
У тебя симулятор крякнутый, глюкавит по-чёрному.
   mszsuz
 
32 - 09.04.04 - 18:39
(28) Дык, вчера надо было - в баньку-то...
   fellow
 
33 - 09.04.04 - 18:41
(32) А что, он вчерась немытый был?
 
  Рекламное место пустует
   Рупор абсурда
 
34 - 09.04.04 - 18:43
(29) Не очень ..., вы ж меня вытащите через час ...
(30) Что???? Там уже нет шоколада?
(33) Я всегда стерилен, а вчера я просто плохо себя вёл ...
   skunk
 
35 - 09.04.04 - 18:45
час на час не приходиться... пока Волшебник не появиться... даже если захотим не вытащим...
   fellow
 
36 - 09.04.04 - 18:45
(34) Когда стерилизовали?
   GrayT
 
37 - 09.04.04 - 18:48
(21) +  ;)
Ally, а тебе не скучно будет в чисто мужской компании?
   Рупор абсурда
 
38 - 09.04.04 - 18:49
(35) Да ладно! Если я счас скажу: "Волшебник - дурак", тут же прибежит ...
ЗЫ: Это я ещё не сказал ...
   mszsuz
 
39 - 09.04.04 - 18:51
Так, не толпиться у трапа, по очереди, господа, по очереди.
Все взлетим, места ещё навалом ...
   ally
 
40 - 09.04.04 - 18:52
(37) Нет. Я умных мужчинов люблю, уже говорила неоднократно гдето ранее и даже объясняла почему. :-)
   Рупор абсурда
 
41 - 09.04.04 - 18:52
(36) Тьфу на тебя ...
   mszsuz
 
42 - 09.04.04 - 18:53
(38) Доиграешься! Рейс закроют или ещё чего доброго корабль утопят ...
   fellow
 
43 - 09.04.04 - 18:54
(41) А я тебя за язык не тянул, сам признался :)
   mszsuz
 
44 - 09.04.04 - 18:57
fellow, skunk, пора уже карты раскрыть. Вы с нами или будете по телевизору смотреть?
   skunk
 
45 - 09.04.04 - 18:58
(42)в космосе уже топят... или это как в "Планета Сокровищ"
   fellow
 
46 - 09.04.04 - 19:00
(44) Что там у вас по телевизору? Не видно ни зги. Летите-ка к нам, не занимайтесь самодеятельностью. :)
   fellow
 
47 - 09.04.04 - 19:01
(45) Да, такой вот у нас здесь космос, местами по ноздри, недолго и утонуть :)
   fellow
 
48 - 09.04.04 - 19:03
Народ отвалил ДеБе смотреть.
   mszsuz
 
49 - 09.04.04 - 19:07
(46) Куда к вам??? Давай, тащи свои дубовые опилки. А тут уже вместе покумекаем над формулой. Я даже знаю куда их надо засыпать ...
 
  Рекламное место пустует
   ally
 
50 - 09.04.04 - 19:07
А я слетаю на марс пока пишется следующая глава.... у меня корыстная цель... буду "засланцем" в штаб противников ;-)
   fellow
 
51 - 09.04.04 - 19:09
(49) К нам, на Ламерию :о) У нас Гере - великий знаток чинного пойла! Ему даже дубовые опилки не страшны!
   fellow
 
52 - 09.04.04 - 19:10
(50) Давай, Элия, разведай там, что к чему, и доложи по форме.
   skunk
 
53 - 09.04.04 - 19:10
skunk - 2. v. amer. sl. напарник карточного шуллера отвлекающий внимание игроков при сдаче карт.

как после этого мне открывать карты... только при розыгрыше... сорри...
   skunk
 
54 - 09.04.04 - 19:12
(50)"засланцы" в цвет не паляться... ((
   ally
 
55 - 09.04.04 - 19:12
(52)Ага, только Гере не говорите.... :-)
   Рупор абсурда
 
56 - 09.04.04 - 19:12
Скунки, Фел, я ни разу не нагадил в вашей ракете ...
А ТЕПЕРЬ БУДУ!
   ally
 
57 - 09.04.04 - 19:13
(54)А ни кто и не видел, ща прикроем сообщения ;-)))
   GrayT
 
58 - 09.04.04 - 19:14
(56) Ее еще догнать надо
Перем ОбратныйОтсчет Экспорт;

Процедура ОбратныйОтсчет()
   ОбратныйОтсчет = ОбратныйОтсчет -1;
   Если ОбратныйОтсчет = 0 Тогда
       ОбработкаОжидания();
       Старт();
   Иначе
       Сообщить("До старта осталось " + СокрЛП(ОбратныйОтсчет) + "сек");
   КонецЕсли;
КонецПроцедуры //ОбработкаОжидания

Процедура ПриНачалеРаботыСистемы()
//................
   ОбработкаОжидания("ОбратныйОтсчет", 60);
//................
КонецПроцедуры //ПриНачалеРаботыСистемы

ОбратныйОтсчет = ХХХХ //?????
   fellow
 
59 - 09.04.04 - 19:14
(56) Да полно, голубчик РА, не собираемся мы в вашей ракете гадить. Это пошло!
   mszsuz
 
60 - 09.04.04 - 19:17
GrayT, я так понимаю, у нас ещё один член экипажа добавился?
   GrayT
 
61 - 09.04.04 - 19:19
"Я полезных преспектив ни когда не супротив" :)
   skunk
 
62 - 09.04.04 - 19:20
(56)а где я гадил?
   fellow
 
63 - 09.04.04 - 19:22
Ура, леди анд джентльмены, на подмогу "Первой Эсии" отправляется дружественный (надеюсь) экипаж, ведомый славным... Постойте-ка, а кто у вас командир?
   mszsuz
 
64 - 09.04.04 - 19:24
Самозванцев нам не надо.
Командиром буду я.
   Рупор абсурда
 
65 - 09.04.04 - 19:25
Кстати, как мы назовём нашу ракету?
И надо обязательно Композитора подождать, он нам гимн сочинит ...
   Рупор абсурда
 
66 - 09.04.04 - 19:26
(65)+ И СнаркХантера в стрелки ...
   fellow
 
67 - 09.04.04 - 19:27
(64) Кадровые вопросы постепенно проясняются...
   ally
 
68 - 09.04.04 - 19:27
Рупор и скунки, давайте не будем выяснять где вы гадите....
   GrayT
 
69 - 09.04.04 - 19:29
(65) Все-таки решился лететь?
   Рупор абсурда
 
70 - 09.04.04 - 19:29
(68) Нет! Пусть он сознается! А потом уже ..., мы его великодушно простим ...
   GrayT
 
71 - 09.04.04 - 19:30
(65) Строго по военному "Борт 3358"
   Рупор абсурда
 
72 - 09.04.04 - 19:31
(69) Не бросать же вас одних ... Заблудитесь ...
   skunk
 
73 - 09.04.04 - 19:31
для того что бы сознаться... надо быть уличенным... вопрос, где и чего я сделал(не сделал)
   Рупор абсурда
 
74 - 09.04.04 - 19:33
(71) Неее ... Так нельзя! Надо чё-нить героическое, мужественное, суровое ..., предлагаю: "Бородатая Женщина" ...
   fellow
 
75 - 09.04.04 - 19:34
(74) С яй....э-э-э-э. Э-э-э?
   GrayT
 
76 - 09.04.04 - 19:35
(72) С таким-то штурманом? У него практика была еще на "Первой..", без атласов летала.
   GrayT
 
77 - 09.04.04 - 19:36
(74) "Как вы лодку назовете так она и поплывет" (с)
   ally
 
78 - 09.04.04 - 19:37
(73)Рупор, не флудил в наших ветках про Катастрофу на Ламерию
   fellow
 
80 - 09.04.04 - 19:38
(78) Ну, что ж, придётся отправляться восвояси.
   ally
 
81 - 09.04.04 - 19:44
Фел, я просто объяснила что он имел в виду
   fellow
 
82 - 09.04.04 - 19:57
Так, стоило ненадолго отлучиться, как  тут уже порубленные посты завелись и дискуссия затихла.
   Рупор абсурда
 
83 - 09.04.04 - 20:06
(82) Да, теперь до старта лучше не высовываться ... Пристрелить могут ...
   fellow
 
84 - 09.04.04 - 20:08
Скунки - человек мирной профессии, он не стреляет куда ни попадя. А я так и вообще не любитель пальбы.
   Рупор абсурда
 
85 - 09.04.04 - 20:11
(84) Это ваша шпионка постреливает ...
   fellow
 
86 - 09.04.04 - 20:12
А не нарывайся :о)
   GrayT
 
87 - 09.04.04 - 20:13
Обиделась, а зря. Ее предупреждали
   skunk
 
88 - 09.04.04 - 20:14
(86)Фелл, зря... я уже привык... ноль эмоций...
   Рупор абсурда
 
89 - 09.04.04 - 20:16
Давайте не будем её осуждать ..., это она от возбуждения несдержалась ...
   GrayT
 
90 - 09.04.04 - 20:19
Ох, не лезь на рожон. У нее винтовка с оптическим прицелом :)
   skunk
 
91 - 09.04.04 - 20:19
дома инет появился
   skunk
 
92 - 09.04.04 - 20:20
(90)СВД-19?
   GrayT
 
93 - 09.04.04 - 20:24
Кхм. (84) мирный говоришь. Ему б еще звезду (эксперт в области вооружения).
В яндексе только 6 строкой стояла - http://www.okhotnik.ru/Products/12013.html
   skunk
 
94 - 09.04.04 - 20:31
   skunk
 
95 - 09.04.04 - 20:33
но больше нравиться так:
http://www.yandex.ru/yandsearch?rpt=rad&text=%F1%E2%E4+19

кооператив "Свой Дом"
   GrayT
 
96 - 09.04.04 - 20:38
Не много не в тему. Меня однажды прокатили "под прицелом" Сайги. Я тогда ее от АКМ-а отличить не смог, с тех пор недолюбливаю...
   Рупор абсурда
 
97 - 09.04.04 - 20:47
(96) Значит ты меня должен понимать ...
Я тут всегда под прицелом ... и не одним ...
   SnarkHunter
 
98 - 09.04.04 - 20:53
Круто... Карабин от автомата не отличить... Это ж сколько выпить надо...
   Волшебник
 
99 - 09.04.04 - 21:10
Процедура Полет()

Пока ПроверкаСистем()=Норма И Состояние(Экипажа)=КтоНибудьЖив Цикл

    Если ТекущаяСкорость() < Константа.ЗаданнаяСкорость Тогда
          ПоддатьСпиртуВДюзы(1000, литры);
    КонецЕсли;
       
   Если ПолучитьРасстояние(Корабль,Земля) = ПолучитьРасстояние(Корабль,Марс) Тогда
          Синтезировать(МногоЕды+Алкоголь);
          Разморозить(Экипаж);
          ОтпраздноватьСобытие(Экватор);
          Заморозить(Экипаж);
    КонецЕсли;

    Если Расстояние(Корабль,Марс) < Константа.Подлетное Тогда
          Разморозить(Экипаж);
          Прервать; //подлетаем
    КонецЕсли;
КонецЦикла;

УстановитьМонопольныйРежим(Посадка);

КонецПроцедуры //полет
   SnarkHunter
 
100 - 09.04.04 - 21:12
100

  1  2   

Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует