Вход | Регистрация

1С:Предприятие ::

Метки:

Некорректное проведение документа

Я
   god3
 
08.04.04 - 18:18
Не понимаю, в чём проблема. Вот код:
// ********************

//
Процедура ОбработкаПроведения()
    Если (Константа.ПорядокСписанияТовара <> Перечисление.ПорядокСписания.Вручную) Тогда
       // Порядок списания = FIFO или LIFO

        
        Рег = СоздатьОбъект ("Регистр.ТоварыНаСкладе");
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл 
            
            Док = СоздатьОбъект ("Документ.ПрихНакл");
            Если (Константа.ПорядокСписанияТовара = Перечисление.ПорядокСписания.LIFO) Тогда 
                Док.ОбратныйПорядок (1);
            Иначе
                Док.ОбратныйПорядок (0);
            КонецЕсли;
            
            Док.ВыбратьДокументы();
            Пока Док.ПолучитьДокумент() = 1 Цикл
                Ост = Рег.Остаток (Док, Товар, "Количество");
                Если Ост > 0 Тогда
                    Регистр.ТоварыНаСкладе.Товар = Товар;
                    Регистр.ТоварыНаСкладе.Партия = Док.ТекущийДокумент();
                    Если Количество <= Ост Тогда
                        Регистр.ТоварыНаСкладе.Количество = Количество;
                        Регистр.ТоварыНаСкладе.ДвижениеРасходВыполнить();
                        Прервать;
                    Иначе
                        Регистр.ТоварыНаСкладе.Количество = Ост;
                        Регистр.ТоварыНаСкладе.ДвижениеРасходВыполнить();
                        Количество = Количество - Ост;
                    КонецЕсли;                    
                КонецЕсли;
            КонецЦикла;
            
        КонецЦикла;        
    Иначе 
       // Списание вручную

        Предупреждение ("Списание пока не поддерживается");
    КонецЕсли;

КонецПроцедуры

Беда в том, что какое бы значение не было установлено в константе (тип - Перечисление), всё равно все условия в конструкциях Если...Иначе...КонецЕсли выполняются по сценарию ЛОЖЬ (0).
Помогите!!!
 
 
   psk21office
 
1 - 08.04.04 - 18:21
Значение константы периодическое или нет
   god3
 
2 - 08.04.04 - 18:22
Блин, точно. Сразу не догнал. СПАСИБО!!!


Список тем форума
Рекламное место пустует   Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует