Вход | Регистрация

1С:Предприятие ::

Метки:

1с. Выбор из обработки

Я
   PilotBrian
 
07.04.04 - 15:44
Существует обработка. В ней находится таблица значений, которая заполняется при открытии. Мне надо вставить значение из этой таблицы в форму справочника. Я пишу:

ОткрытьПодбор("Обработка.ВыборСклад",,,0);

Но как сделать так, что бы при выборе значения в обработке оно (значение) вставлялось в справочник?
Когда пишу:

ОткрытьПодбор("Справочник.Склад","ДляВыбора",,0);

Проблем не возникает, открывается справочник для выбора, выбирается значение, и оно благополучно устанавливается.

Вопрос в том, как сделать тоже самое, но выбирая не из справочника, а из обработки.
 
  Рекламное место пустует
   Рупор абсурда
 
1 - 07.04.04 - 15:46
ВыполнитьВыбор()
   PilotBrian
 
2 - 07.04.04 - 15:57
(1) Пишу в обработке Форма.ВыполнитьВыбор() и ничего не происходит :(  Как с ним пользоваться?
   Рупор абсурда
 
3 - 07.04.04 - 15:58
(2) А значение выбора?
   Композитор
 
4 - 07.04.04 - 16:01
ОбработкаПодбора()
   PilotBrian
 
5 - 07.04.04 - 16:01
т.е. объявляю глабальную переменную пишу:
Форма.ВыполнитьВыбор(гл_пер)
и потом присваивать куда надо?
   Рупор абсурда
 
6 - 07.04.04 - 16:13
(5) Не надо глобальных переменных ...
   PilotBrian
 
7 - 07.04.04 - 16:17
(6) А кого надо?
   Рупор абсурда
 
8 - 07.04.04 - 16:23
(7) В параметре ВыполнитьВыбор() указываешь значение выбора, в обработке подбора имеешь его ...
   PilotBrian
 
9 - 07.04.04 - 16:32
Может я дурак?

Пишу в обработке (для проверки):

Процедура Выполнить()
    Форма.ВыполнитьВыбор(ТБ.Наимен);
КонецПроцедуры
Процедура ОбработкаПодбора(с1,с2)
    Сообщить(с1+" _ "+с2);
КонецПроцедуры

Выполнить() сидит на кнопке.
Нажимаю кнопку, обработка закрывается, а сообщение вообще не появляется
   Рупор абсурда
 
10 - 07.04.04 - 16:40
(9) Может и дурак ... счас выясним ...
Обе эти процедуры у тебя в одной обработке?
 
  Рекламное место пустует
   PilotBrian
 
11 - 07.04.04 - 16:46
(10) Да, но я вторую процедуру вешал и в справочник - откуда выбирается. С тем же результатом :(
   Рупор абсурда
 
12 - 07.04.04 - 16:49
(11) Покажи, как открываешь подбор ...
   PilotBrian
 
13 - 07.04.04 - 16:50
(12)
Процедура ПриНачалеВыбораЗначения(ИЭД, ФСО)
    ФСО=0;
    ОткрытьПодбор("Обработка.ВыборСклад",,,0);
КонецПроцедуры
   Рупор абсурда
 
14 - 07.04.04 - 16:59
Тогда ОбработкаВыбораЗначения()
   PilotBrian
 
15 - 07.04.04 - 17:14
(14) Хорошо. Я теперь знаю выбранное значение и кто его вызвал. А вот почему кто его вызвал не становиться равным выбранному значению?
   Рупор абсурда
 
16 - 07.04.04 - 17:21
(15) Присвоить его надо в ОбработкаВыбораЗначения()
   PilotBrian
 
17 - 07.04.04 - 17:23
уф Спасибо.
С меня пиво :)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует