Вход | Регистрация

1С:Предприятие ::

Метки:

Проблема с БИ. Как раз мистика, то есть по теме сайта.

Я
   Filippych
 
07.04.04 - 15:37
делаю так

...    
Контр = СоздатьОбъект("Справочник.Контрагенты");
Дог = СоздатьОбъект("Справочник.Договоры");
Таб = СоздатьОбъект("Таблица");
БИ = СоздатьОбъект("БухгалтерскиеИтоги");

БИ.Рассчитать(НачДата,КонДата,"60.2, 62.1, 76",0,,);

Остаток = 0;
Таб.ВывестиСекцию("Шапка");

Контр.ВыбратьЭлементы();
    Если _60_2 = 1 Тогда
    Счёт = СчетПоКоду("60.2");
    Таб.ВывестиСекцию("СтрокаСчёта");
    Пока Контр.ПолучитьЭлемент() = 1 Цикл
        Если Контр.ЭтоГруппа() = 1 Тогда 
            Продолжить;
        КонецЕсли;
        Таб.ВывестиСекцию("СтрокаКонтрагента");
        Дог.ВыбратьЭлементы();
        Дог.ИспользоватьВладельца(Контр.ТекущийЭлемент());
        Пока Дог.ПолучитьЭлемент() = 1 Цикл
            Остаток = БИ.СКД("60.2"",1,,Контр,Дог););
            Таб.ВывестиСекцию("Строка");
        КонецЦикла;
    КонецЦикла;
...
Контрагент и договор выбраны и не пустые значения.
Почему остаток = 0?
Мистика да и только.
 
  Рекламное место пустует
   Filippych
 
1 - 07.04.04 - 15:47
+(0) ОСВ по счёту выдаёт всё как надо.
   Filippych
 
2 - 07.04.04 - 15:53
А ведь срочно надо, очень срочно...
   press
3 - 07.04.04 - 15:57
Попробуй поменять местами
Дог.ВыбратьЭлементы();
Дог.ИспользоватьВладельца(Контр.ТекущийЭлемент());
   Filippych
 
4 - 07.04.04 - 16:02
Сейчас посмотрим.
   Filippych
 
5 - 07.04.04 - 16:13
Безрезультатно
   Rider
 
6 - 07.04.04 - 16:35
У нас в Украине 602 счет пассивный. Попробуй СКК
   Filippych
 
7 - 07.04.04 - 16:40
Дело в том что СКД("60.2") даёт результат отличный от нуля, но как только добавляешь субконто, всё метод выдаёт 0.
   Rider
 
8 - 07.04.04 - 16:44
Так может в операциях что-то не прописанно, например, договор. Построй анализ счета по субконто
   Zombi
9 - 07.04.04 - 18:33
Попробуй
Остаток = БИ.СКД("60.2"",1,,Контр.ТекущийЭлемент(),Дог.ТекущийЭлемент())
   Filippych
 
10 - 08.04.04 - 16:53
Не работает. И уже не смешно. Причём совсем.
 
 
   Filippych
 
11 - 08.04.04 - 16:54
:(
   mszsuz
 
12 - 08.04.04 - 17:01
Неверное обращение к результатам запроса.
Посмотри в типовой какой-нить отчет, например "Анализ счета по субконто"
   Filippych
 
13 - 08.04.04 - 17:04
Там нет запроса.
   mszsuz
 
14 - 08.04.04 - 17:04
Блин, а это ведь не и запрос вовсе ...
   Filippych
 
15 - 08.04.04 - 17:19
Вот вполне работоспособный код:
      ...
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
   //Проверяем СНК на нач месяца

    Ит.Рассчитать(НачМесяца(ДатаДок), КонМесяца(ДатаДок),сч66_3,,,);
    УдалитьСтроки();
    Остаток = Ит.СНК(сч66_3,"С",,Договор.Владелец,Договор);
      ...
   mszsuz
 
16 - 08.04.04 - 17:19
Попробуй:
    Контр = СоздатьОбъект("Справочник.Контрагенты"); 
    Дог = СоздатьОбъект("Справочник.Договоры"); 
        БИ = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ.Рассчитать(НачДата,КонДата,"60.2, 62.1, 76"); 
    Сч_602 = СчетПоКоду("60.2"); 
    Контр.ВыбратьЭлементы(); 
    Пока Контр.ПолучитьЭлемент() = 1 Цикл 
        Если Контр.ЭтоГруппа() = 1 Тогда 
            Продолжить; 
        КонецЕсли; 
        Дог.ИспользоватьВладельца(Контр.ТекущийЭлемент());         
        Дог.ВыбратьЭлементы(); 
        Пока Дог.ПолучитьЭлемент() = 1 Цикл 
            Остаток = БИ.СКД(Сч_602,1,,Контр.ТекущийЭлемент(),Дог.ТекущийЭлемент()); 
            Если Остаток<>0 Тогда
                Сообщить(""+Контр.ТекущийЭлемент()+" "+Остаток);
            КонецЕсли;
        КонецЦикла; 
    КонецЦикла;
   Filippych
 
17 - 08.04.04 - 17:44
Это надо ж так было глупо попасться с методом ПолучитьЭлементы()


Список тем форума
Рекламное место пустует   Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует