Вход | Регистрация

1С:Предприятие ::

Метки:

Схема данных в 1С

Я
   gol
 
06.04.04 - 15:28
Можно ли просмотреть связи между справочниками так, как это сделано в Access
 
  Рекламное место пустует
   Рупор абсурда
 
1 - 06.04.04 - 15:49
А как это сделано в Акцесс?
   SiMazx
 
2 - 06.04.04 - 15:50
Штатными методами - нет... Нештатными   - не видел...
   spock
 
3 - 06.04.04 - 16:30
2(2)Я плакал :))
   SiMazx
 
4 - 06.04.04 - 17:09
(3)Экий ты братец впечатлительный... ;)
   Рупор абсурда
 
5 - 06.04.04 - 17:29
(4) А как это сделано в Акцесс?
   SiMazx
 
6 - 06.04.04 - 17:31
В Акцесс? Не знаю такой программы... ;)
   SiMazx
 
7 - 06.04.04 - 17:31
Диаграмма связей таблиц там есть...
   Рупор абсурда
 
8 - 06.04.04 - 17:32
(7) Почему тогда нельзя штатно?
   SiMazx
 
9 - 06.04.04 - 17:36
Готового струмента нету... Тока самому ваять...
   Inside
 
10 - 06.04.04 - 17:54
Это почему штатными нельзя?
Можно, только писать долго :)
 
  Рекламное место пустует
   Композитор
 
11 - 06.04.04 - 18:17
//*******************************************

Процедура Сформировать()
    Табл.УдалитьСтроки();
    Для Инд=1 По Метаданные.Справочник() Цикл
        ВидСправочника = Метаданные.Справочник(Инд).ПолныйИдентификатор();
        Табл.НоваяСтрока();
        Табл.Владелец = Метаданные.Справочник(Инд).Владелец;
        Табл.Справочник =ВидСправочника;
        Табл.ТаблРеквизиты = СоздатьОбъект("ТаблицаЗначений");
        Табл.ТаблРеквизиты.НоваяКолонка("Реквизит");
        Табл.ТаблРеквизиты.НоваяКолонка("ТипРеквизита");
        Для К = 1 По Метаданные.Справочник(Инд).Реквизит() Цикл
            Табл.ТаблРеквизиты.НоваяСтрока();
            Табл.ТаблРеквизиты.Реквизит = Метаданные.Справочник(Инд).Реквизит(К).Идентификатор;
            Табл.ТаблРеквизиты.ТипРеквизита = Метаданные.Справочник(Инд).Реквизит(К).Тип;     
        КонецЦикла;    
    КонецЦикла;

КонецПроцедуры

Процедура ПриОткрытии()
    Табл.НоваяКолонка("Владелец");
    Табл.НоваяКолонка("Справочник");
    Табл.НоваяКолонка("ТаблРеквизиты");
КонецПроцедуры
   SiMazx
 
12 - 06.04.04 - 18:19
(11) От я ж и говорю, что написать-то можно... Только кто ж возьмется...
   SiMazx
 
13 - 06.04.04 - 18:21
Очень похоже на Акцессную диаграмму... Прям с первого взгляда и не отличишь...
;))
   Композитор
 
14 - 06.04.04 - 18:22
(13) На базе 11 стройте свои диаграммы.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует