Вход | Регистрация

1С:Предприятие ::

Метки:ЗиК

v7: ЗиК: Как принять на работу внутреннего совместителя?

Я
   avyub
 
03.02.08 - 19:23
Пробую со сброшенным флажком На Основное Место Работы уже принятого сотрудника, выдает ошибку: Сотрудник уже принят на работу (Прием на работу 000039 (17.11.97)). Проведение документа невозможно
PS Конфигурация Зарплата+Кадры, редакция 2.3 (7.70.277)
 
 
   Flika
 
1 - 03.02.08 - 21:19
При выборе сотрудника в приказе о приеме на работу ЗиК говорит: "этот сотрудник уже принят, Вы хотите принять его по совместительству?" На данный вопрос ответьте утвердительно и никакой галочки убирать не прийдется
2
   avyub
 
2 - 04.02.08 - 08:37
(1)В том-то и дело, что он не спрашивает: "этот сотрудник уже принят, Вы хотите принять его по совместительству?"
А только пишет, что Сотрудник уже принят на работу (Прием на работу 000039 (17.11.97)). Проведение документа невозможно
   avyub
 
3 - 04.02.08 - 09:51
Сейчас в модуле документа следующий код:

Если Сотрудник.ОсновнойЭлемент<>Сотрудник Тогда
    // если принимаем на работу внутреннего совместителя 
    Если ПустоеЗначение(Сотрудник.ОсновнойЭлемент.СостояниеФизлица.Получить(ДатаПриема))=1 Тогда
    МожноПроводить = 0;
    глДобавитьСообщение(ОбработчикСообщений, НазваниеДока+"сотрудник "+Сотрудник.Наименование+" не работает по основному месту работы! Его нельзя принять по внутреннему совместительству!",ТекущийДокумент(),,"ДатаПриема")
    КонецЕсли;
            Если глВоеннослужащий(Сотрудник.ОсновнойЭлемент, ДатаПриема) = 1 Тогда
                МожноПроводить = 0;
                глДобавитьСообщение(ОбработчикСообщений, НазваниеДока+"военнослужащий не может быть дополнительно принят по совместительству.",ТекущийДокумент(),,"Сотрудник")
            КонецЕсли;
        КонецЕсли;
        
        Приказ = глРаботалСотрудник(Сотрудник,ДатаПриема,Окончание);
        Если (ПустоеЗначение(Приказ)=0)и(Приказ<>ТекущийДокумент()) Тогда
            МожноПроводить = 0;
            глДобавитьСообщение(ОбработчикСообщений, НазваниеДока+"сотрудник уже принят на работу ("+Приказ+").",Приказ)
        КонецЕсли;

В нем не вижу предложение принять по совместительству
   avyub
 
4 - 04.02.08 - 09:54
Не понял выражение:
Если Сотрудник.ОсновнойЭлемент<>Сотрудник
   de Bug
 
5 - 04.02.08 - 10:22
Если Сотрудник.ОсновнойЭлемент<>Сотрудник
=
Если ЭтоВнутреннийСовместитель = 1
   avyub
 
6 - 04.02.08 - 10:54
И все же как принимать внутреннего совместителя.У меня (что бы я не делал)он попадает под условие:

        Приказ = глРаботалСотрудник(Сотрудник,ДатаПриема,Окончание);
        Если (ПустоеЗначение(Приказ)=0)и(Приказ<>ТекущийДокумент()) Тогда
            МожноПроводить = 0;
            глДобавитьСообщение(ОбработчикСообщений, НазваниеДока+"сотрудник уже принят на работу ("+Приказ+").",Приказ)
        КонецЕсли;
7
   de Bug
 
7 - 04.02.08 - 11:32
(6) По порядку.
В справочнике Сотрудники какая запись? Штатный сотрудник с 17.11.97?
Открываем новый Приказ о приеме. Выбираем сотрудника. Что говорит?
8
   avyub
 
8 - 04.02.08 - 12:34
(7)В справочнике Сотрудники: Штатный сотрудник с 17.11.97
Открываем новый Приказ о приеме. Выбираем сотрудника. Выходит форма Кем, в какой отдел и пр.
9
   de Bug
 
9 - 04.02.08 - 13:02
(8) Так, стоп. Это через Помощник? Отключи его пока.
Помощник приема на работу - снять галку Использовать при создании документов.
Приказ о приеме - выбрать сотрудника. Что говорит?
   PHelen
 
10 - 04.02.08 - 13:08
А наш ОК утверждает, что и военнослужащий может быть принят по внутр.совм. Издали приказ и что теперь с ним делать никто не знает. Кто-нить с этим встречался ?
11
 
 
   PrinceCorum
 
11 - 04.02.08 - 14:09
(10)ЗиКа не дает принять военнослужащего по внутреннему совместительству. Была такая проблема года два назад. Сделали его внешним. Заморочка только с налогами, отследить НДФЛ и собрать отчет в конце года.

 
Список тем форума

 
У меня не было своей комнаты, я спал на полу у друзей, сдавал бутылки из-под колы за 5 центов, чтобы купить еды, и каждое воскресенье шел 7 миль пешком, чтобы раз в неделю хорошо поужинать в храме кришнаитов. Это было прекрасно! Стив Джобс
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.