Вход | Регистрация

  1  2   
1С:Предприятие ::

Метки:

Многострочная часть

Ø [skunk, 06.04.04 - 19:44]
Я
   Wow__cooL
05.04.04 - 15:22
Как обратиться к многострочной части открытого документа с помощью компоненты FormEx? Необходимо выполнить действия для каждой строчки...
 
 
   Рупор абсурда
 
1 - 05.04.04 - 15:24
Какие действия? Зачем для этого ФормЭкс?
   Wow__cooL
2 - 05.04.04 - 15:28
(1) мне необходимо выполнить процедуру согласно формуле в одной колонке, но для каждой строчки. Атрибут получаю методом ФормаРасш.ПолучитьАтрибут(Инд)
   SiMazx
 
3 - 05.04.04 - 15:30
А можно ситуацию подробнее... Формекс возможно действительно причем... Много сегодня телептических веток...
Но по описанию ни шиша не понятно...
   SiMazx
 
4 - 05.04.04 - 15:32
О! Увидел...
   Wow__cooL
5 - 05.04.04 - 15:34
Есть такой код:

ОткрытьФорму(Док.ТекущийДокумент(),,); 
Конт="";
ФормаРасш = СоздатьОбъект("РасширениеФормы"); 
Если ОткрытьФорму(Док.ТекущийДокумент(),Конт)=1 Тогда
    ФормаРасш.УстановитьФорму("МногострочнаяЧасть");    
КонецЕсли;
    
Док.ВыбратьСтроки();
Сервис = СоздатьОбъект("Сервис"); 
АтрФормы=СоздатьОбъект("АтрибутФормы"); 
    
Для Х = 0 По ФормаРасш.КоличествоАтрибутов() - 1 Цикл
    Если СокрЛП(ФормаРасш.ПолучитьАтрибут(Х).Идентификатор)=СокрЛП(НаимКод) Тогда
        Сообщить(Строка(ФормаРасш.ПолучитьАтрибут(Х).Формула));    
        Если ПустоеЗначение(ФормаРасш.ПолучитьАтрибут(Х).Формула)<>1 Тогда    
            Сервис.ВыполнитьПроцедуру(Конт,ФормаРасш.ПолучитьАтрибут(Х).Формула,СокрЛП(НаимКод));
        КонецЕсли;    
    КонецЕсли; 
КонецЦикла;
        
Пока Док.ПолучитьСтроку()=1 Цикл     
    Если ФормаРасш.НайтиАтрибут(1,Строка(СпрТовар)+"."+СТрока(ВидТовар))=1 Тогда
        Сообщить(ФормаРасш.ТекущийАтрибут().Заголовок);
    Иначе
        Сообщить("0");
    КонецЕсли;
КонецЦикла; 

Но он обращается к колонке с именем, равным НаимКод, только один раз, но это многострочная часть, => должно происходить обращение несколько раз.
   Рупор абсурда
 
6 - 05.04.04 - 15:41
Следы чтоль путаешь?
   Wow__cooL
7 - 05.04.04 - 21:00
Ладно, поставлю вопрос по-другому...
Кто-нибудь вообще работал посредством FormEx с многострочной частью документа?
   Wow__cooL
8 - 05.04.04 - 21:00
Ладно, поставлю вопрос по-другому...
Кто-нибудь вообще работал посредством FormEx с многострочной частью документа?
   Рупор абсурда
 
9 - 05.04.04 - 21:16
(7,8) Ты мне, конечно, не поверишь (увы, репутация у меня подмочена), но для этого не нужна FormEx ...
   Wow__cooL
10 - 05.04.04 - 21:25
(9) я тебе, конечно, верю, разве могут быть сомненья...
 
  Рекламное место пустует
   Wow__cooL
11 - 05.04.04 - 21:25
(9) а если серьезно, почему не нужна?
   SnarkHunter
 
12 - 05.04.04 - 21:31
(11)Может быть начать с чего-нибудь попроще?
   Wow__cooL
13 - 05.04.04 - 21:34
(11) с чего? Ваши варианты?
   Wow__cooL
14 - 05.04.04 - 21:35
то есть, конечно, не (11) а (12)...

______________
тихо сам с собою я веду беседу...
   SnarkHunter
 
15 - 05.04.04 - 21:44
Например, с учебника на mista.ru
Без обид, но у меня сложилось впечатление за последние два дня, что у Вас проблемы и с постановкой и с реализацией задачи...
   Wow__cooL
16 - 05.04.04 - 21:53
(15) да ладно, без обид.
Да, пожалуй, объясняю я неправильно. А по поводу реализации - уже было много вариантов решения этой задачи. Один из этих вариантов - использование FormEx, потому как штатными средствами не получается (к этому выводу пришли здесь же, на этом форуме).
МОжете меня ругать по поводу неправильности постановки и реализации, но мне это не поможет...
А учебник у меня есть, и по мере необходимости я к нему обращаюсь. Если не нахожу (не только по причине, что этого нет, но и я просто-напросто не могу найти), я спрашиваю здесь. Но по поводу FormEx там ведь ничего? А вот с этой компонентой и связана моя ветка. Впервые сталкиваюсь с ней. И кроме как в интернете, спросить мне больше нигде.

Соглашаюсь с вами, потому что 1С я действительно знаю плохо, но я же не волшебник, я только учусь... И мне нужна ваша помощь :)
   Рупор абсурда
 
17 - 06.04.04 - 11:37
(16) Не обижайся ..., а объясняй, как можно подробнее, желаемую цель начинания ...
   Wow__cooL
18 - 06.04.04 - 13:08
(16) хорошо...
Так получается, что никто никогда не работал с табличной частью документа посредством FormEx?
   Wow__cooL
19 - 06.04.04 - 13:08
(17) хорошо...
Так получается, что никто никогда не работал с табличной частью документа посредством FormEx?
   Wow__cooL
20 - 06.04.04 - 13:08
опять что-то страницы не грузятся...
   Рупор абсурда
 
21 - 06.04.04 - 13:13
ДЛЯ РАБОТЫ С ТАБЛИЧНОЙ ЧАСТЬЮ ДОКУМЕНТА НЕ НУЖНА FORMEX!!!
   Wow__cooL
22 - 06.04.04 - 13:27
(21) а кричать не надо...
Хорошо, если не нужна, то каким образом ты предлагаешь определить формулу, которая записана в колонке, и выполнить эту процедуру, если она не является глобальной?
   SiMazx
 
23 - 06.04.04 - 13:27
Вот ведь заладил... Клином на Формексе сошлось...
Будь добр расскажи человеческим языком чего ты хочешь от этой многострадальной.. тьфу... многострочной части...
   Рупор абсурда
 
24 - 06.04.04 - 13:29
(23) Она девочка ...
(22) У тебя что в каждой строке тч своя формула для этой колонки?
   SiMazx
 
25 - 06.04.04 - 13:45
Ты открываешь форму документа, и хочешь, чтобы пересчитывались колонки?
А просто в ПриОткрытии это сделать?
   SiMazx
 
26 - 06.04.04 - 13:46
Хочешь чтобы пересчитывалось только при программном открытии? Передавай параметр в форму... Или я чего-то не понимаю?
   SnarkHunter
 
27 - 06.04.04 - 13:49
(26)Ты не одинок...
   SiMazx
 
28 - 06.04.04 - 13:52
Ну, если уж так загорелось через формекс, тогда засунь строку с Сервис.ВыполнитьПроцедуру в цикл по строкам документа...
   427
 
29 - 06.04.04 - 13:56
Да (0) уже запарил(а).... (25) было предложено сразу ....

Нормальной постановки здесь приведено не было ...
   Wow__cooL
30 - 06.04.04 - 14:19
(25) я загружаю в открываемый программно документ ТЗ (только 2 колонки), надо выполнить процедуры, соответствующие формулам этих документов.
(26) каким образом это сделать?

(28) в том-то и дело, что по строкам не идет!!! находит только 1 строку, (т.е. по идее бы ВыбратьСТроки(), потом Пока ПОлучитьСТроку()=1 , но не получается, там еще в СП написано следующее
ПолучитьАтрибут(<?>)
Синтаксис:
ПолучитьАтрибут(<Номер>)
Назначение:
Возвращает объект объект АтрибутФормы.
Параметры:
<Номер> - номер или строка с идентификатором атрибута формы, проинициализированной методом УстановитьФорму(). !!!! Для получение доступа к многострочной части формы необходимо в этот метод передать строку "МногострочнаяЧасть". !!!!!

Когда у вас что-то спрашивают, вы требуете код, сами же вы, когда отвечаете, просто говорите: сделай так или так. В СП тоже написано "необходимо в этот метод передать строку "МногострочнаяЧасть"", но как это сделать?? Объясните, пожалуйста. Самостоятельно разобраться не могу...
   Рупор абсурда
 
31 - 06.04.04 - 14:29
Секретная разработка какая-то, наверно ...
   Wow__cooL
32 - 06.04.04 - 14:30
(31) что еще надо, чтобы это была не "секретная разработка"?
   SiMazx
 
33 - 06.04.04 - 14:39
Ладно, я в formexe не рублю...
Но... "я загружаю в открываемый программно документ ТЗ (только 2 колонки), надо выполнить процедуры, соответствующие формулам этих документов."
Еще раз... А как в (25) почему не катит?
 
  Рекламное место пустует
   Рупор абсурда
 
34 - 06.04.04 - 14:40
(32) Зачем нужно выполнять эту секретную формулу?
   skunk
 
35 - 06.04.04 - 14:43
(31)ничего секретного нет...
разрабатывается универсальная выгрузка/загрузка любых документов из одной конфигурации в любой другой документ, любой другой конфигурации...
   SnarkHunter
 
36 - 06.04.04 - 14:45
(35)Например, расходной накладной в приходный кассовый ордер?
   skunk
 
37 - 06.04.04 - 14:49
(36)наверное... я понял, что так... ну или приблизительно так... Вы же эту ветку видали... еще писали "Гусары, молчать!"... ну или в таком духе
   Wow__cooL
38 - 06.04.04 - 14:51
(35) похоже, но не совсем: разрабатывается загрузка данных из файла в любой (как ты правильно заметил) документ любой конфигурации.
(33) напишите, пожалуйста как это будет выглядеть. Я не понимаю.
(34) формула не секретная - просто неизвестно какая формула стоит в каком документе (документ-то любой может быть)
   skunk
 
39 - 06.04.04 - 14:52
+37 я поэтому там так написал... а вдруг кто то засунет приходную(к примеру) в начислениие больничного... или наоборот СЗВ в расходную...
   Рупор абсурда
 
40 - 06.04.04 - 14:53
(38) Зачем нужно выполнять эту не секретную формулу?
   Wow__cooL
41 - 06.04.04 - 14:54
(39) нет, документ используется только для загрузки в него данных, и все. такого там не будет (берут из одного дока, загружают в другой)
   Wow__cooL
42 - 06.04.04 - 15:00
(40) смотри, когда мы формируем документ ручками (например, Поступление товаров), для начала выбираем любой товар из спр Номенклатура (сразу заносится в документ цена, если она была у товара), затем указываем количество - все, остальное (НДС, сумма, Всего) сразу рассчитывается.
у меня: загружается в эту табличную часть дока только ДВЕ колонки, а остальные НДС, цена, сумма, Всего - пустые. если после этого щелкнуть на колонке Товар (как будто изменяем ее и, соответственно, выполняется формула этой колонки) сразу происходит пересчет остальных колонок, и все колонки заполняются в данной строчке. Но мне надо, чтобы это происходило программно, а не пользователь щелкал по каждой строчке, чтобы ему посчиталась сумма документа.

ПОнятно? или опять не так объясняю?
   Рупор абсурда
 
43 - 06.04.04 - 15:05
(42) Хочешь, я, для начала, научу тебя расчитывать сумму, имея количество и цену?
   Wow__cooL
44 - 06.04.04 - 15:07
(42)Сумма=Количество*Цена
и не говори, что неправильно...
   Wow__cooL
45 - 06.04.04 - 15:07
опять-таки (43) а не (42)
что-то все время не те номера ставлю...
   skunk
 
46 - 06.04.04 - 15:08
ну а дальше что мешает...
   Рупор абсурда
 
47 - 06.04.04 - 15:10
(44) Молодец! Теперь скунк тебе про НДС расскажет ...
   Wow__cooL
48 - 06.04.04 - 15:17
(47) вы предлагаете все поля пересчитать самостоятельно,так?
   Рупор абсурда
 
49 - 06.04.04 - 15:17
(48) Трудно?
 
  Рекламное место пустует
   SnarkHunter
 
50 - 06.04.04 - 15:19
(50)Вера в большую зеленю кнопку не позволяет...
   SnarkHunter
 
51 - 06.04.04 - 15:20
(50) адресовано для (49)
   Wow__cooL
52 - 06.04.04 - 15:24
(49) а ты можешь сказать, что во всех табличных частях всех документов любой конфигурации есть именно эти колонки (Цена, Сумма, НДС) и больше никаких других? а если есть какие-то другие, то они не рассчитываются, так?
   SiMazx
 
53 - 06.04.04 - 15:26
Ну чё вы как дети....
У тебя при выборе товара какая функция запускается?
Пусть Пересчет().

Тогда в твое обработке делаешь ТвойПараметр = 99999;ОткрытьФорму(,ТвойПараметр)
А в документе в процедуре ПриОткрытии пишешь
Если Форма.Параметр = 99999 Тогда
    Пересчет();
КонецЕсли;
   427
 
54 - 06.04.04 - 15:27
Самое прикольное.... в том, что (0) совершенно зря парит себе мозги...

Он делает обработку переноса... Ну флаг в руки... его проблемы ...

По если подходить нормально, то загружать документ в другую базу надо так же, как он выгружен... т.е. с теми же значениями колонок...

к примеру, если это расходная накладная, то надо загрузить ТУ ЖЕ ЦЕНУ, КОЛИЧЕСТВО, НДС, СУММУ и ВСЕГО....

Ибо надо помнить - сделанный в базе 1 документ РАСПЕЧАТАН и ВЫДАН ПОКУПАТЕЛЮ... И В НЕМ НИЧЕГО ИЗМЕНИТЬ УЖЕ НЕЛЬЗЯ.... ДАЖЕ НОМЕРА ДОКУМЕНТА...  Документ УЖЕ УШЕЛ....

ИНАЧЕ придет встречная проверка и СРАЗУ ВСТАВИТ КЛИЗМУ.... по самое нехочу.... Просто сравнит документы .... А это первое, что делается при встречной проверке ... сравниваются доки покупателя и продавца.... затем их количество ... и т.д.

А вот проводки/движения этот же самый документ может порождать другие ... Т.е. проводки/движения по правилам базы получателя... НО ИСХОДНАЯ ИНФА В ДОКЕ МЕНЯТЬСЯ УЖЕ не должна....
   Wow__cooL
55 - 06.04.04 - 15:30
(54) ну я же говорю, что это формирование документа на основе информации из *.txt файла! это не выгрузка/загрузка документов из одной базы в другую, нет! это не обработка переноса!!!
   Wow__cooL
56 - 06.04.04 - 15:32
(53) документ будет неизвестно какой... Эта обработка будет использоваться не одним пользователем. Пользователь самостоятельно будет устанавливать у себя эту программу и эту обработку.
   Рупор абсурда
 
57 - 06.04.04 - 15:37
Жаль пользователя ...
   SiMazx
 
58 - 06.04.04 - 15:42
(56) Партизан... Только к 56 посту выдавили, что конфигу саму править нельзя...
E[[[? %^*((&^^(((*&^(*^^^(*^^^(*&##%@%^&$*)(*_)(_)*?  мля...
   Рупор абсурда
 
59 - 06.04.04 - 15:48
(58) Для тех, кто в танке, повторюсь: Она девочка ...
Не ругайся ...
Помоги лучше, если можешь ...
   SiMazx
 
60 - 06.04.04 - 15:57
Пардон муа, партизанка...
   SiMazx
 
61 - 06.04.04 - 16:12
Пока Док.ПолучитьСтроку()=1 Цикл
  Для Х = 0 По ФормаРасш.КоличествоАтрибутов() - 1 Цикл 
     Если СокрЛП(ФормаРасш.ПолучитьАтрибут(Х).Идентификатор)=СокрЛП(НаимКод)          Тогда 
       Сообщить(Строка(ФормаРасш.ПолучитьАтрибут(Х).Формула));     
       Если ПустоеЗначение(ФормаРасш.ПолучитьАтрибут(Х).Формула)<>1 Тогда     
           Сервис.ВыполнитьПроцедуру(Конт,ФормаРасш.ПолучитьАтрибут(Х).Формула,                     СокрЛП(НаимКод)); 
       КонецЕсли;     
   КонецЕсли; 
  КонецЦикла;
КонецЦикла;
   SiMazx
 
62 - 06.04.04 - 16:12
Так пробуй...
   Wow__cooL
63 - 06.04.04 - 16:29
(62) нет, это тоже не работает...
   skunk
 
64 - 06.04.04 - 17:21
(47)а я про него ни чего незнаю (( .... а энто что такое "НДС"
   Рупор абсурда
 
65 - 06.04.04 - 17:28
Wow__cooL, извини, но либо ты что-то круто не договариваешь, либо идея у тебя изначально утопическая ...
   Wow__cooL
66 - 06.04.04 - 18:00
(65) я уже не знаю, что еще договорить, а насчет идеи - изначально она была реализуемая...

А что такое 1С++?
   Inside
 
67 - 06.04.04 - 18:03
(66) Последний гвоздь в крышку гроба переносимости разработок на 1С :)
   Wow__cooL
68 - 06.04.04 - 18:05
(66) :)
а что позволяет делать, где про это можно почитать?
   Wow__cooL
69 - 06.04.04 - 18:05
(67) :)
а что позволяет делать, где про это можно почитать?
   Рупор абсурда
 
70 - 06.04.04 - 18:07
(67)+ FormEx - предпоследний ...
   Inside
 
71 - 06.04.04 - 18:08
Да ето расширение убогой объектной модели 1С...
Штука крнечно полезная, но боюсь не для каждого :)
Почитать - где-то на www.hare.ru
   Inside
 
72 - 06.04.04 - 18:09
(70) Affirmative! :)
   skunk
 
73 - 06.04.04 - 18:17
(66)она и реализуема... только... представь ситуацию
есть товар
Кабель АВВГ 4х16 у него есть две ед. измерения
1 метр - основная
1 бобина - дополнительная (Коф = 200)

Одним документом продают это кабель метрами
Товар/Ед.из/Коф/Кол-во/ЦенаЗаЕдинц/Сумма/

Кабель АВВГ 4х16/м/1/50/84/4200/

Другим этот же кабель но бобинами
Кабель АВВГ 4х16/боб/1/1/16800/16800/

Ты их выгружаешь:
Товар/Кол-во/
Кабель АВВГ 4х16/50
Кабель АВВГ 4х16/1

При загрузке, что получаешь ?????

Ну и куча других мелких какашек, про которых говорил тебе pit еще в (54)

Выгружать надо все... и загружать надо все...


+ а еще в расходной есть скидки, которые из меняют цену товара... а в приходной их нет...

Так что-то даже если и доберешься до волшебной формулы... толку мало...
   Wow__cooL
74 - 06.04.04 - 18:20
(73) но я же не загружаю данные из одного документа в другой документ!
   Inside
 
75 - 06.04.04 - 18:23
Уж не загрузка ли это из терминала сбора данных?
Две колонки в таблице - товар+количество? :)
или штрихкод+количество :)
   SiMazx
 
76 - 06.04.04 - 18:24
(74) Бьемся-бьемся... Как об стену...
Можно общую концепцию услышать? Чего сделать-то пытаемся?
   SiMazx
 
77 - 06.04.04 - 18:25
(75) Кто еще какие варианты предложит в игре в угадайку?
   Рупор абсурда
 
78 - 06.04.04 - 18:27
(77) Вариант:
Это - развод кроликов ...
Цель развода - 100 постов в ветке ...
   skunk
 
79 - 06.04.04 - 18:30
вау... как говриться про Ивана... нет мне надо про Федю...
при чем тут разный док... ед.из бывают у товара разные... и куча еще всего может быть разное....
трудно выгрузить все и загрузить все... объясни как фих разница
Выгрузить(Товар, Количество) и Выгрузить(Товар,Количество,ЕдИз,Коф,.... и чего там надо)
   427
 
80 - 06.04.04 - 18:32
Мне надоело напрягать свою телепат.dll.....
   427
 
81 - 06.04.04 - 18:53
Рупор... Да просьба то примитивна - надо заполнить 3 параметра строки и вызвать формулу... из колонки... для расчета остальных... тогда в принципе можно не париться с формулами в каждом доке....

Навскидку были предложены 3 варианта...

Ни один до конца не доведен ....
   Wow__cooL
82 - 06.04.04 - 18:55
(79) из файла берутся данные Товар и Количество и ВСЕ.


Представьте себе, у вас есть программа, которая формирует *.txt файлы вида:
12508  |  34,8
23994  |  20,5
15301  |  10
24165  |  40
814  |  50

соответственно:
Код     | Количество


В 1С вы выбираете любой документ и этот самый файл указываете. Потом читаете файл, заносите его значения в ТЗ, и выгружаете эти данные в выбранный док. Это понятно?
   SiMazx
 
83 - 06.04.04 - 18:56
Это способ поднятия рейтинга!!!
И все дружными усилиями, выдавливая по крупицам информацию, мучаются в этой ветке, поднимая рейтинг Вау_куль...
Это была шутка...
   SiMazx
 
84 - 06.04.04 - 18:57
А данные файла откуда берутся?
   afk
85 - 06.04.04 - 18:58
(82) чисто из любопытства - как/откуда/чем формируется файл?
   SiMazx
 
86 - 06.04.04 - 19:01
Любопытно... Оказывается файл загружается в любой(!) документ...
Действительно интересно, что эт мы вообще такое делаем...
   Wow__cooL
87 - 06.04.04 - 19:03
(83) в любом случае до Рупора, Волшебника,  skunk'а и остальных мне еще далеко, и эта ветка не сильно поможет.
(85) есть программа, которая формирует этот файл (прога написана на Delphi)
честно говоря, боюсь начинать говорить об этой проге...

ладно, в ней пользователь загружает таблицу DBF, которая содержит все данные, затем делается заказ (то есть пишется количество необходимого товара), а потом те строки, которые имеют Заказ<>0 сохраняются в этом самом файле. Понятно?
   SnarkHunter
 
88 - 06.04.04 - 19:07
Я еще в (36) любопытствовал как это хозяйство в ПКО занести... Или в банковскую выписку...
   Wow__cooL
89 - 06.04.04 - 19:07
(86)любопытно... о том, что это может любой документ, я говорю (по крайней мере, в этой ветке) начиная с 38 поста (skunk сказал это еще в 35)...
если ты его не читал, то вопрос: а остальные читал?
   Wow__cooL
90 - 06.04.04 - 19:09
внешняя программа, считайте, есть прайс-лист. а текстовый файлик - собственно файл заказа.
   Рупор абсурда
 
91 - 06.04.04 - 19:11
У меня в конфе есть док "МочитьВСортире" ...
   SiMazx
 
92 - 06.04.04 - 19:11
То есть ты заранее не знаешь в своей проге в Дельфи, в какой документ попадет созданная таблица? То есть как юзеру бог на душу положит, туда и загрузит...
Ты оперируешь понятиями товар, заказ, а пользователь захочет и грузанет твою таблицу в ПКО...
У меня психика слабая, не надо меня так пугать!!!!
   afk
93 - 06.04.04 - 19:11
хе-хе-хе ну мне то понятно... вот чего тебе стало понятно из этой темы? чего не было понятно из первой??!
   afk
94 - 06.04.04 - 19:13
(91) в одной конфе есть док "ИнтересныйДокумент"...
   Wow__cooL
95 - 06.04.04 - 19:14
(92) в Delphi это и не важно. Я оперирую понятиями Товар и Заказ для удобства. Пользователь может туда и грузанет, но первоначально он поставит в соответствие этим двум полям из файла два реквизита табличной части выбранного документа.
   Wow__cooL
96 - 06.04.04 - 19:15
(93) "чего не было понятно из первой??! " - в смысле?
   skunk
 
97 - 06.04.04 - 19:18
+92 мало документа... пользователь захочет в ТиС заказ положит, а захочет в Бухию, но это не самое страшное... а если этот заказ попадет кадравику он его в ЗиК грузить будет...
   SnarkHunter
 
98 - 06.04.04 - 19:19
(95)Доки бывают без ТЧ...
   skunk
 
99 - 06.04.04 - 19:19
(95)Заказ он и в африке заказ... на фига велосипед...
   Wow__cooL
100 - 06.04.04 - 19:19
(97) сомневаюсь, что кадровик будет пользоваться прогой прайс-листа...

  1  2   

Список тем форума
Рекламное место пустует  
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует