Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

ЗиК.031 Помогите - уже день долбаюсь..

Ø
Я
  
29.06.01 - 15:25
Изменился алгоритм расчета Доплаты за вредность и теперь надо пересчитать эту вредность еще и за апрель, май. Получается следующее: запись из прошлого периода вместо того, чтоб просто "сминусоваться", пересчиталась полностью "с плюсом" с учетом нового алгоритма расчета, да еще и возникла запись-перерасчет с этим же результатом. Даже не знаю уже что предпринять, посоветуйте что-нить...
 
  Рекламное место пустует
   Searcher
1 - 29.06.01 - 15:33
Поставь проверку в модуле расчета
   Silver9
2 - 29.06.01 - 15:38
2(1) мдаа.. Если б поподробнее - о чем ты?
   Searcher
3 - 29.06.01 - 15:42
Если Начало<Дата("01.05.01") Тогда
 Если Перерасчет=1 Тогда
   // новый алгоритм
 Иначе
   // старый алгоритм
 КонецЕсли;
Иначе//новый алгоритм
КонецЕсли;
или что-то в этом-роде...
   Алекс Шарафан
4 - 29.06.01 - 15:47
наиболее простой способ справиться с этим такой:
Сделай корректировки расчетов в прошлых месяцах документом корректировка, а в текущем пересчитай по новому алгоритму.
И перестань мучиться!
   Silver9
5 - 29.06.01 - 16:28
2(4) А если у меня 350 челов и 200 из них получает вредные? Каждому ручками лепить док? неее. В текущем и так по-новому считает.
2(3) Сделал. Почему-то рожает еще одну запись с нулевым результатом, а та которая должна быть отрицательной - положительна :-(( Неужели автоматом не определяется сторно это или нет? Всего получается 4 записи по вредности: 1-я нулевая, потом - с правильной доплатой за май, потом копия майской "НЕнулевая", потом правильная июньская..Ищу ошибки..
   Searcher
6 - 29.06.01 - 16:43
(5) в ЖЗ есть атрибут Сторно.
Да и вообще, залежь в отладчик и посмотри, при расчете каждой из этих записей какие атрибуты стоят, и соответственно пиши алгоритм...
   Silver9
7 - 29.06.01 - 17:08
2(6) Про Сторно знаю - не помогает, с ним все нормально, само выставляется когда надо. Хоть убей - не могу понять, почему вставляется еще одна запись. В отладчике живу уже давно:-). При расчете сторно-записи получается отриц.результат - в ЖЗ выводится положительный (!!) Может посмотришь код?
   Searcher
8 - 29.06.01 - 17:09
кидай сюда
   Silver9
9 - 29.06.01 - 17:40
Ччерт! инет немножко умер..
Процедура ПровестиРасчет()
        //определяем Коэф...
ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");
ЖрнЗарплата.ВыбратьЗаписиПоОбъекту(Объект,ДатаНачала,ДатаОкончания);
БазаНач = 0;
	...
Оклад = ОкладПоРазряду(Объект,ДатаОкончания)*Объект.Ставка.Получить(ДатаОкончания);
	БазаНач = Оклад;
	
Если  ДатаНачала < Дата("01.06.01") Тогда//твой кусок
 Если Перерасчет = 1 Тогда  // Новый алгоритм начисления
 	Начисл = ?(Сторно=1,-БазаНач,БазаНач)*Коэф;
	Результат = Округление(Начисл,ДатаОкончания);
 Иначе    //старый алгоритм начисления
          //определяем Часов...
	Костик = Константа.СрЧасовПри40чРабНеделе.Получить(ДатаОкончания);
	Начисл = ?(Сторно=1,-БазаНач,БазаНач)*Коэф*Часов/Костик;
	Результат = Округление(Начисл,ДатаОкончания);
	Часы = Часов;
  КонецЕсли;
Иначе     //опять новый
	Начисл = ?(Сторно=1,-БазаНач,БазаНач)*Коэф;
	Результат = Округление(Начисл,ДатаОкончания);
КонецЕсли;	
КонецПроцедуры
Еще. Перед проведением дока-корректировки у чела уже была одна запись "Доплата за вредность", введена "нач.мес."
   Searcher
10 - 29.06.01 - 17:43
а зачем у тебя куски ?(Сторно=1,-БазаНач,БазаНач) везде стоят?
Всегда думал, что сторно и без этого минусы ставит ;)
 
  Рекламное место пустует
   Silver9
11 - 29.06.01 - 17:45
ты знаешь.. (чешет репу).. это из стандартного модуля все было сделано.. я оставил когда-то.. щас попробую убрать..
   Silver9
12 - 29.06.01 - 17:51
Блиииин! там где надо - запись-сторно - появился "минус" !!!!!
теперь надо будет запись-перерасчет исправить, чтоб правильно считала...
но ОТКУДА берется еще одна, пустая запись ???
   Searcher
13 - 29.06.01 - 17:54
Пустая - не знаю откуда, по идее не должна, а перерасчет разве теперь не по новому считается?
   Silver9
14 - 29.06.01 - 17:54
... отладчик при расчете "пустой" лезет в старую ветку.. соответственно не находит там часов и результ - нулевой.. ничего не пойму..
   Silver9
15 - 29.06.01 - 18:02
Перерасчет. смотрю отладчиком: Перерасчет=1, заходит в первую же ветку, начисляет 7262*0.02 = 145.24 ... выходит из процедуры ... получаем в ЖЗ 98.52 (!!) Сторно = -52.26 (отчаянно трет глаза и монитор) :(((
   Searcher
16 - 29.06.01 - 18:08
(15) а старый результат какой был ?
   Silver9
17 - 29.06.01 - 18:14
52.26 - тут все правильно. Перепроверил всё - и пустой вроде неоткуда браться..
   Searcher
18 - 29.06.01 - 18:17
Ну тогда откуда 98.52 берется? Чудес не бывает...



Список тем форума

Форум Территория 1С

 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует