Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Регистр

Ø
Я
  
04.07.01 - 10:47
Процедура ОбработкаПроведения()
ВыбратьСтроки();
Регистр.Табель.День=День;
Пока ПолучитьСтроку()>0 Цикл
	Регистр.Табель.Сотрудник=Сотрудник;
	Регистр.Табель.Часы=Часы;
	Регистр.Табель.ДвижениеВыполнить();
КонецЦикла;
КонецПроцедуры
Выскакивает с ошибкой -
Регистр.Табель.ДвижениеВыполнить();
{Документ.Табель.Модуль Документа(10)}: Движения регистров не могут выполняться у данного объекта.
Почему?
 
 
   Opanki
1 - 04.07.01 - 10:51
а регистр оборотный?
   А
2 - 04.07.01 - 10:51
Регистр у тебя какой остатков или оборотный?
   Alex N
3 - 04.07.01 - 10:52
У тебя регистр Табель точно оборотный?
   Для
4 - 04.07.01 - 10:52
регистров остатков надо выполнять ДвижениеПриходВыполнить()или ДвижениеРасходВыполнить()
   Alex N
5 - 04.07.01 - 10:53
Оперативненько так...
   OLe
6 - 04.07.01 - 10:55
В том то и дело что оборотный
   Opanki
7 - 04.07.01 - 10:56
Тогда попробуй так
Процедура ОбработкаПроведения()
ВыбратьСтроки();
Пока ПолучитьСтроку()>0 Цикл
Регистр.Табель.День=День;
Регистр.Табель.Сотрудник=Сотрудник;
Регистр.Табель.Часы=Часы;
Регистр.Табель.ДвижениеВыполнить();
КонецЦикла;
КонецПроцедуры
   Alex N
8 - 04.07.01 - 10:57
Регистр.Табель.День=День; в цикл засунь
   Deidre
9 - 04.07.01 - 10:59
А Оперативный учет в документе установлен?
   2(9)
10 - 04.07.01 - 11:01
в точку:-))
 
  Рекламное место пустует
   Olga_A
11 - 04.07.01 - 11:12
(9) Эть, не успела ;)
   OLe
12 - 04.07.01 - 11:41
(9,10,11)А как его установить?
   megatrend
13 - 04.07.01 - 11:44
(12)
Дважды кликнуть на документ и поставить галку "Оперативный учет"
   Opanki
14 - 04.07.01 - 11:44
так он не стоит?????:-)))) поставь крыжик Оперативный учет (есно при наличии компоненты Опер. учет он станет виден)
   megatrend
15 - 04.07.01 - 11:46
(14) Ить как :)
.
Кто не успел - тот опоздал!
   .
16 - 04.07.01 - 11:48
2(14) есно регистры создаются тоже только при наличии компоненты Опер.учет :))
   OLe
17 - 04.07.01 - 12:16
спасибо - ошибок нету. Однако пишет что период не открыт
   SAnn
18 - 04.07.01 - 12:18
Операции, управление оперативными итогами...
   Opanki
19 - 04.07.01 - 12:21
ох оле оле. это только слезы.......так открой период.
Операции - Управление оперативными итогами - и меняй



Список тем форума

Форум Территория 1С

Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует