Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

ЗиК 028. Глюк ИНН Адыгеи.

Ø
Я
  
14.02.01 - 15:09
При создании отчета о доходах сотрудников - заявляет что ИНН начинающийся на 01 - неверный.
чето делать?
 
  Рекламное место пустует
   VitaliyS
1 - 14.02.01 - 15:13
В конфигуруторе убери проверку наличия в начале строки ИНН - нуля.
   UF
2 - 14.02.01 - 15:13
В отчете о доходах найти проверку (все)
Если ИНН<>Число(ИНН) - приблизительно. Искать лучше по Строке ИНН.
Внутри условия будет сообщение и что-то вроде
Плохо=1.
Сообщение оставь (вдруг еще что вылезет), вот оплошание закомметарь.
Вроде так.
   Рыжая Рысь
3 - 14.02.01 - 15:18
ЕстьИНН=0;
		Если ПустаяСтрока(Кадр.ИНН)=0  Тогда
			Если (Строка(Число(Кадр.ИНН))<>Кадр.ИНН) Тогда
				Сообщить(Сотрудник.Наименование+": "+"Неверно задан ИНН физического лица "+Кадр.ИНН);
				Хорошо = -1;
			Иначе
				Текст.ДобавитьСтроку(ВРег("ИННФЛ:"+Кадр.ИНН));
				ЕстьИНН=ЕстьИНН+1;
			КонецЕсли;
   Рыжая Рысь
4 - 14.02.01 - 15:21
И где исправить?
   UF
5 - 14.02.01 - 15:29
ЕстьИНН=0;
Если ПустаяСтрока(Кадр.ИНН)=0 Тогда
Если (Строка(Число(Кадр.ИНН))<>Кадр.ИНН) Тогда
Сообщить(Сотрудник.Наименование+": "+"Неверно задан ИНН физического лица "+Кадр.ИНН);//Хорошо = -1;
//Иначе
КонецЕсли;
Текст.ДобавитьСтроку(ВРег("ИННФЛ:"+Кадр.ИНН));
ЕстьИНН=ЕстьИНН+1;
.
Ниже - еще один КонецЕсли (для Если ПустаяСтрока(Кадр.ИНН)=0 Тогда
Его не было у тебя, я тоже непоказываю. Просто замени код на приведенный.
   АЛМ
6 - 14.02.01 - 17:58
Это не самое страшное, бывает и хуже.



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует