Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

??? Не могу получить развернутое сальдо по счету в Б7.7

Ø
Я
  
11.02.01 - 00:00
По счету есть развернутое сальдо. Пишу отчетик используя и СКДРС и СКДР (аналогично и по кредиту), а в результате СКДР показывает свернутое сальдо, СКДРС ничего не показывает. Что не так?
 
  Рекламное место пустует
   Журавлик
1 - 11.02.01 - 02:03
Покажи фрагмент кода...
   AU
2 - 11.02.01 - 22:57
Была такая же беда. Использовал новый объект БухИтоги для расчета. По-другому как обойти не знаю, но в коде пришлось выбирать данные то из одник БИ, то из лругих, причем за один и тот же период и с одинаковой выборкой.
   SG
3 - 12.02.01 - 11:58
Журавлик, фрагмент кода выглядит так:
Фрагмент кода// Сама процедура
//-----------------------------------------------
Процедура КорСчета(Т, Ит,СекцияВалюты)
   	Если (Счет.Активный = 3) Тогда// для активно пассивных
   		с1= "*"; с2="";
			    СНДап1 = Ит1.СНДРС(Счет,,,,с1,,с2);
			    СНКап1 = Ит1.СНКРС(Счет,,,,с1,,с2);
			    СКДап1 = Ит1.СКДРС(Счет,,,,с1,,с2);
			    СККап1 = Ит1.СККРС(Счет,,,,с1,,с2);
   		с2= "*"; с1="";
			    СНДап2 = Ит1.СНДРС(Счет,,,,с1,,с2);
			    СНКап2 = Ит1.СНКРС(Счет,,,,с1,,с2);
			    СКДап2 = Ит1.СКДРС(Счет,,,,с1,,с2);
			    СККап2 = Ит1.СККРС(Счет,,,,с1,,с2);// В этой секции должны печататься развернутые сальдо
//
		Т.ВывестиСекцию("Секция_ап"+"|основная");
	КонецЕсли;
КонецПроцедуры
Процедура Сформировать
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    	Ит.ИспользоватьРазделительУчета(РазделительУчета);
    Ит.ВключатьСубсчета(0, ДанныеПоСубсчетам);
  	Если Ит.ВыполнитьЗапрос(Дата1, Дата2, Счет,,, 3) = 0 Тогда
  		Возврат;
  	КонецЕсли;// вызываем	
        КорСчета(Т, Ит,Ит1, 0);
КонецПроцедуры
   Maxon
4 - 12.02.01 - 13:18
Вот и у меня такая же беда. Только со стандартными отчетами. Если кто заметил, не рассчитываются развернутые сальдо если делается выборка менее чем по 2-ум субконто. Видимо у тебя та же беда (по 1-му отбираешь, 2-ое не учитываешь) Hotline думает.
   Maxon
5 - 12.02.01 - 13:21
Кстати, в приведенном примере что то не то ! У тебя количество параметров не сходится ! И потом делаешь запрос, а потом в процедуре обращаешься как будто никакого запроса и не было (т.е. в режиме бухгалтерских итогов),- нехорошо получается. Или это опечатка ?
   SG
6 - 12.02.01 - 13:35
to Maxon:
Да, при обращении конечно опечатка. На самом деле КорСчета(Т, Ит,0);
   Maxon
7 - 12.02.01 - 13:43
Но все равно ! Почему переведя бухгалтерскиеИтоги в режим запроса ты обращаешься к ним как в режиме бухгалтерских итогов ? Для режима запроса предусмотрен режим без параметров, т.е. СКДРС(), т.к. все уже задано в запросе.
   ???
8 - 12.02.01 - 13:49
Какой релиз 7.7? Попробуй 15-й
   Maxon
9 - 12.02.01 - 14:02
В том то и дело что при 15 такая фигня
   SG
10 - 12.02.01 - 14:46
to Maxon
Так написано от безнадеги. Втаблице отчета стоит
Ит.СКДРС()#Ч015.2., (ну и т.д.)
Удевляет другое. В оборотно-сальдовой по счету развернутое сальдо показывается. ???
 
  Рекламное место пустует
   Maxon
11 - 12.02.01 - 15:46
В смысле не показывается ??? Или все таки показывается. У меня нет. Я и подумал что проблемы то одинаковые по видимому..
   SG
12 - 12.02.01 - 15:54
В оборотке все в порядке - показывается.
Т.е., похоже, я что-то не то написал.
   Maxon
13 - 12.02.01 - 16:04
Странно... Просто там применяется точно такой же алгоритм как в примере. А в предложениях ВыбратьСубконто()и ВыбратьСчет() устанавливаешь флажок "рассчитывать разв. сальдо" ?
ЗЫ извини, если слишком простой вариант, не хотел обидеть, а вдруг ?
   Журавлик
14 - 12.02.01 - 16:16
Во-первых, согласен с (7).
Во-вторых, формальные параметры процедуры Корсчета() - Т,Ит,СекцияВалюты
В теле процедуры - обращение к Ит1.
   SG
15 - 12.02.01 - 19:07
to Maxon
Спасибо за подсказку. Просто я за основу взял неподходящий отчет и не проверил, все-ли в нем прописано.
Теперь все в порядке. Еще раз спасибо.



Список тем форума

Форум Территория 1С

Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует