Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Даешь квин-программы на 1С !

Ø
Я
  
10.02.01 - 00:07
Слышали про такие программы? Это самораспечатывающиеся программы, подробно о них написано в последнем номере Компьютерры. Вобщем я решил внести свою лепту на языке 1С:
Процедура Сформировать()
//Автор Юрий Иванов 2001г.	
	Перем Мас[1000];
	Кон1=4;Кон2=14;Стр1="	Мас[";Стр2="]=";Стр3=";";
	Мас[1]="Процедура Сформировать()";
	Мас[2]="//Автор Юрий Иванов 2001г.	";
	Мас[3]="	Перем Мас[1000];";
	Мас[4]="	Кон1=4;Кон2=14;Стр1=_	Мас[_;Стр2=_]=_;Стр3=_;_;";
	Мас[5]="	Для А=1 По Кон1 Цикл";
	Мас[6]="		Сообщить(СтрЗаменить(Мас[А],Симв(95),Симв(34)));";
	Мас[7]="	КонецЦикла;";
	Мас[8]="	Для А=1 По Кон2 Цикл";
	Мас[9]="		Сообщить(Стр1+А+Стр2+Симв(34)+Мас[А]+Симв(34)+Стр3);";
	Мас[10]="	КонецЦикла;";
	Мас[11]="	Для А=Кон1+1 По Кон2 Цикл";
	Мас[12]="		Сообщить(Мас[А]);";
	Мас[13]="	КонецЦикла;";
	Мас[14]="КонецПроцедуры";
	Для А=1 По Кон1 Цикл
		Сообщить(СтрЗаменить(Мас[А],Симв(95),Симв(34)));
	КонецЦикла;
	Для А=1 По Кон2 Цикл
		Сообщить(Стр1+А+Стр2+Симв(34)+Мас[А]+Симв(34)+Стр3);
	КонецЦикла;
	Для А=Кон1+1 По Кон2 Цикл
		Сообщить(Мас[А]);
	КонецЦикла;
КонецПроцедуры
 
 
   Юрий
1 - 10.02.01 - 02:00
Кажется форматирование удалило табуляцию :-(
В итоге текст будет не ровным, на всякий случай даю ссылку на оригинальную обработку: http://yuridno.narod.ru/ERT/KvinPr.ert
   ?
2 - 10.02.01 - 02:06
А это зачем ?..
   ОЩРТ
3 - 11.02.01 - 16:53
нехитро дело, из той же компьютерры, переписать с паскаля примерчик....
   Гад такой
4 - 11.02.01 - 18:30
ОЩРТ, а ты часом не мимикрировал из ДжонаЗиК после мелких пакостей на хиппо.ру. Не ты ли это часом ?
   ОЩРТ
5 - 11.02.01 - 18:43
2 Гад такой Не понимаю о чем ты.... Прошу объяснить здесь или на мыло.
   ??
6 - 11.02.01 - 20:47
А зачем это??.
   Гад такой
7 - 11.02.01 - 20:54
ОЩРТ как бы john.
   Тот
8 - 11.02.01 - 22:15
Я не знаю зачем это, но вот игрушки на 1С очень классные. И полезные. По крайней мере приучать бухов к интерфкйсу и мышу держать.
   Юрий
9 - 11.02.01 - 22:46
Насчет зачем - да просто так, чтобы было.
А интересно возможно ли сделать код еще меньше? Так к примеру на Си вся прграмма записывается в 2-х строчках.
   SerBabah
10 - 11.02.01 - 23:41
Юра, можно. Убери, например строки 2 и 6. :)))
Не обижаться!
 
  Рекламное место пустует
   gosha
11 - 12.02.01 - 00:04
2(7)... аха... точно... Джон - это Он и есть... только м.б. - не тот маненько... не в смысде - не "Тот", а в смысле - не тотЪ... )))



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует