Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Не выбран элемент справочника-хозяина! Элемент не может быть записан!

Ø
Я
   USer
09.02.01 - 14:37
Есть два справочника, первый "Компьютеры" второй "БроньКом", второй подчинен первому
=====================================================================
Немогу понять почему не выбирается элемент справочника -Хозяина-
уже отупел от дум...
Может Пыва попить?
Спр=СоздатьОбъект("Справочник.БроньКом");
	Спр.ИспользоватьВладельца(Компьютер);
	ВыбратьСтроки();
	Пока ПолучитьСтроку()=1 Цикл
		Повтор=0;
		Спр.ВыбратьЭлементыПоРеквизиту("Папа",ТекущийДокумент(),1,0);
		Пока Спр.ПолучитьЭлемент()=1 Цикл
			Если Спр.Компьютер=Компьютер Тогда
                Спр.клиент = Клиент;
				спр.Состояние = Перечисление.Состояние.Занят;
				Спр.До=ВСекунды(ВремяПо);
				Спр.Записать();
				Повтор=1;
			КонецЕсли;
		КонецЦикла;
		Если Повтор=0 Тогда
			Спр.Новый();
			Спр.Компьютер=Компьютер;
			Спр.клиент = Клиент;
			спр.Состояние = Перечисление.Состояние.Занят;
			Спр.До = вСекунды(ВремяПо);
			Спр.Папа=ТекущийДокумент();
			Спр.Записать();
		КонецЕсли;
	КонецЦикла;
 
 
   ex3S
1 - 09.02.01 - 14:42
Скорее всего вторую строку надо засунуть в тело цикла.
   UF
2 - 09.02.01 - 14:46
Попробуй назначать в лоб.
Спр.Владелец=Компьютер;
Может, выборка по реквизиту сбивает ИспользоватьВладельца.
   USer
3 - 09.02.01 - 14:49
в догонку справочник "БроньКом" -системный нужен- для отчетов и статистики
не нужно чтобы он разросся на безконечное число строк.
   USer
4 - 09.02.01 - 14:53
буду под вечер....
всем заранее спасибо...
   UF
5 - 09.02.01 - 14:58
А вообще нахрена в этом справочнике две ссылки на копмьютер - как на владельца, да еще на реквизит?
Не хочется, чтоб разросся, говоришь...
   USer
6 - 09.02.01 - 16:09
2(5)
а для того чтобы если такой товар есть
мы на его имя меняли реквизиты
а если нет то создали новый
   UF
7 - 09.02.01 - 16:12
Так ты ж вроде выбираешь подчиненный справочник?
У тебя должно бы всегда получаться что Владелец и Компьютер одинаковы...
Кстати, (2) не пробовал?
   USer
8 - 09.02.01 - 16:15
пробовал..
неа...
можно тоже самое сделать в не подчиненном справочнике и все работает что-то с методом "ИспользоватьВладельца"...:(
   UF
9 - 09.02.01 - 16:20
Ну тады...
1) Проверь, выбран ли компьютер
2) Втыкни таки ИспользоватьВладельца() после
Если Повтор=0 Тогда
Это уж должно помочь. Хотя некрасиво...
   Mig
10 - 09.02.01 - 16:32
Мне катся, ссылку на реквизит перепозиционировать надо. Типа
Комп=Справочник.Компьютер
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если Спр.Компьютер=Комп Тогда
                Спр.клиент = Клиент;
 
 
   USer
11 - 09.02.01 - 16:32
2(9)
больше не ругается но и движений дока по реквизитам справочника нет.:(
   UF
12 - 09.02.01 - 16:38
Это отдельный вопрос.
1. Реквезиты должны быть периодические с флажком "Изменяеся дукументами"
2. Менять надо методом УстановитьРеквизитСправочника(<?>,,,,,,)
Вот.
   USer
13 - 09.02.01 - 16:40
а вытаскивать при помощи
получить(ДатаДок);
это понятно
=======================
я так выразился что - бы стало ясно что справочник пуст...
   UF
14 - 09.02.01 - 16:49
В общем, если до вечера не разберешься, кидай базу и воросы поподробней (если не слишком громадная и не секретная:)).
Гляну.



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует