Вход | Регистрация

1С:Предприятие ::

Метки:

ЗапуститьПриложение() в 1С 8.0, почему так?...+

Я
   ALX
 
30.03.04 - 02:07
вот код модуля формы элемента справочника:

//======================================================

Процедура ОткрытьСтраницу()
        ЗапуститьПриложение(ВебАдрес);
КонецПроцедуры

Процедура КнопкаОткрытьВебАдресНажатие(Элемент)
        ОткрытьСтраницу();
КонецПроцедуры

Процедура ПриОткрытии()
        ОткрытьСтраницу();
КонецПроцедуры
//======================================================


Почему приОткрытии() срабатывает и сайт грузится, а клик по кнопке
(КнопкаОткрытьВебАдресНажатие()) нет???
 
  Рекламное место пустует
   Волшебник
 
1 - 30.03.04 - 10:21
В процедуру для кнопки скопируй строку из процедуры ПриОткрытии
ОткрытьСтраницу();

(иногда бывает напишут англ. C вместо русской С)

Убедись, что процедура обработки события назначена в свойствах кнопки.
   Demiurg
 
3 - 31.03.04 - 09:25
(2) ты же в Матрице! "перезагрузись"....
   ALX
 
4 - 31.03.04 - 09:50
Ага, только надо найти главный фашистский рубильник :))
Но если серьезно - ведь глюк какой-то.. :(
   ALX
 
5 - 31.03.04 - 12:38
Работает только так
Попытка
        Shell = Новый COMОбъект(\"Shell.Application\");

       Shell.ShellExecute(\"http://www.erpg.ru\", \"\", \"\", \"open\", 1);
Исключение
КонецПопытки;


Список тем форума
Рекламное место пустует  
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует