Вход | Регистрация


1С:Предприятие ::

Метки:

Создание дока

Я
   m_arhangel
 
28.03.04 - 23:09
Люди добрые! подскавжите пожалуйста, как сделать так, чтобы пользователь мог создать не больше одного Дока (определённого типа) в месяц?
 
  Рекламное место пустует
   rep d
1 - 29.03.04 - 00:26
А ты попробуй в бух. ввести два документа по начислению ЗП за один месяц,
там, глядишь, и разберёсся.
   Demiurg
 
2 - 29.03.04 - 00:29
при создании нового поищи за этот месяц :-)
   m_arhangel
 
3 - 29.03.04 - 01:16
(2) В модуле формы самого дока процедура "ВыбратьДокумент()" ругается.
(1) Чушь
   Demiurg
 
4 - 29.03.04 - 02:14
"запрос" ?
   skunk
 
5 - 29.03.04 - 04:15
не пойдет, тяжело будет в некоторых случиях...
   327
6 - 29.03.04 - 05:52
(3) Вот (3) - это чушь.... Причем полная... Причем обе строки - чушь....

(1) тебе правильно сказал.... Принцип именно такой....
   m_arhangel
 
7 - 29.03.04 - 16:00
(6) А ты поробуй сделать...
И причём тут Зарплата?
   Рупор абсурда
 
8 - 29.03.04 - 16:51
Засекаем время: в 16:00 327 начал пробовать ...
   SnarkHunter
 
9 - 29.03.04 - 17:12
Штирлиц порол чушь... Чушь тихонько повизгивала...
   Композитор
 
10 - 29.03.04 - 18:12
(0) Позволяйте пользователям создавать документы. Не позволяйте эти документы проводить.
 
 
   m_arhangel
 
11 - 29.03.04 - 18:22
(8) Ну и как результат ???
   Рупор абсурда
 
12 - 29.03.04 - 18:23
(11) Не знаю, у меня с ним связь только посредством форума ...
   Впервые Входящий
13 - 29.03.04 - 18:41
0 - чуда не будет, Миша! Кстати а какой следующий уровень после архангела?
   m_arhangel
 
14 - 29.03.04 - 18:43
(13) Ты о чём? Какой уравень?
   327
15 - 29.03.04 - 18:46
(8) ХХХХХХ... полный....

Я что, с печки упал? 327 раз пробовать....
Это же не ХХХХХХХХХ
   Композитор
 
16 - 29.03.04 - 18:46
(13) Господь Бог.
   m_arhangel
 
17 - 29.03.04 - 18:55
Фишка в том что, у фирмы сотрудники робят вахтовым методом, причем в разных местах. Надо сделать док, котрый сменяет одних слтрудников на других. В спр "Сотрудники" есть периодический реквизит "ВидРабот".
   m_arhangel
 
18 - 29.03.04 - 18:57
Фишка в том что, у фирмы сотрудники робят вахтовым методом, причем в разных местах. Надо сделать док, котрый сменяет одних слтрудников на других. В спр "Сотрудники" есть периодический реквизит "ВидРабот".
   Впервые Входящий
19 - 29.03.04 - 19:04
14 - хотя может я ошибся... никакой он не архангел, а просто "сжатый" ангел или ангел архивов... в любом случае явление народу :)
   m_arhangel
 
20 - 29.03.04 - 19:09
(19) Я просто прогер Миха, из города Архангельска :) И не надо ...
   Olga
 
21 - 29.03.04 - 22:09
(7) В некоторых конфигур зарплату можно начислить тллько 1 раз - критерий "Текущий период", если есть компонента "Расчет"
   rep d
22 - 29.03.04 - 22:35
(0)+1 Прогеру Михе
//******************************

// Проверка()
//

// Описание:
//  Проверяет является ли данный документ единственным документом НачислениеЗП

// в течение данного месяца.
//

Процедура Проверка()
Если ДатаДокумента <> ДатаДок Тогда
Дубликат = СоздатьОбъект("Документ.НачислениеЗП");
Если Дубликат.ВыбратьДокументы(НачМесяца(ДатаДок),КонМесяца(ДатаДок))=1 Тогда
Предупреждение("За "+Формат(ДатаДок,"Д ММММГГГГ")+" ЗП уже начислялась.");
КонецЕсли;
ДатаДокумента = ДатаДок;
КонецЕсли;
КонецПроцедуры// Проверка(:-)
   m_arhangel
 
23 - 29.03.04 - 23:43
(22) ОГРОМАДНЕЙШЕЕ СПАСИБЛ !!!
   rep d
24 - 30.03.04 - 00:09
ПЖЛста
Тока интересно
робят = работают или = ребята

(18)< у фирмы сотрудники робят вахтовым методом, причем в разных местах.>

Все ли сотрудники, всех ли "робят" и в каких таких местах(:-))
   m_arhangel
 
25 - 30.03.04 - 00:28
(24) Сотрудник работает месяц через месяц
   327
26 - 30.03.04 - 06:25
Неверный подход к решению проблемы....
Сотрудник может отработать 10 дней, пойти в отгулы... отпуск... уехать на свадьбу .... похороны... и т.д.
И выйти в этом месяце вторично .... в конце месяца...



Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует