Вход | Регистрация

1С:Предприятие ::

Метки:

Несколько товаров с одним штрих-кодом

Я
   Гном
26.03.04 - 11:20
Как такое может быть(см сабж)?? При присвоении одному из товаров штрих-кода, этот штрих-код автоматически присваивается нескольким другим позициям номенклатуры, причем в Спровчник единицы он не записывается, а в карточке товара появляется...   1с77,ТиС 9.0
 
 
   Рупор абсурда
 
1 - 26.03.04 - 11:22
Это товары у тебя с "чужими" единицами ...
   Гном
2 - 26.03.04 - 11:27
И как с ними бороться?
   Рупор абсурда
 
3 - 26.03.04 - 11:28
Поменять на "свои" ...
   Гном
4 - 26.03.04 - 11:32
А можно немного поконкретнее..
   Рупор абсурда
 
5 - 26.03.04 - 13:04
Если я не ошибаюсь в ТиС, ШтрихКод - это реквизит справочника Единицы, а справочник Единицы подчинён справочнику Товары ...
У элемента справочника Товары есть реквизит БазоваяЕдиница типа справочник Единицы ...
Так вот, интерактивно выбрать в БазовуюЕдиницу "чужую" единицу (т.е. элемент справочника Единицы с атрибутом Владелец не равным текущему элементу справочника Товары) ты не сможешь ...
Это было как-то программно сделано ...
Чтобы это исправить, нужно теперь везде заменить эти "чужие" единицы, так чтоб они соответствовали своему товару ...
"Везде" - это я имею ввиду, не только в самом элементе товар, но и во всех доках где этот товар сидит вместе со своей единицей ...
   Рупор абсурда
 
6 - 26.03.04 - 13:07
(5)+ А чтоб жизнь тебе мёдом не казалась, кроме БазовойЕдиницы там кажись ещё и ОсновнаяЕдиница присутствует ... :))
   Гном
7 - 26.03.04 - 15:48
А в чем может быть причина сего явления??
   Рупор абсурда
 
8 - 26.03.04 - 16:09
(7) Программно можно присвоить реквизитам БазоваяЕдиница и ОсновнаяЕдиница значения с любым атрибутом владелец ...
Кто и как это сделал мне не ведомо ...
Сори ...
   Гном
9 - 26.03.04 - 16:17
А исправит ли ситуацию, если я программно для каждого такого товара создам новый элемент справочника единицы и там задам их штрих-коды??
   Кое-кто@где-то.там
10 - 26.03.04 - 16:25
Для начала найди их:
Процедура Сформировать()
    СН=СоздатьОбъект("Справочник.Номенклатура");
    СН.ВыбратьЭлементы();
    Пока СН.ПолучитьЭлемент()=1 Цикл
        Если СН.ЭтоГруппа()=1 Тогда
            Продолжить;
        КонецЕсли;     
        Если (СН.БазоваяЕдиница.Владелец<>СН.ТекущийЭлемент()) тогда
            Сообщить(СН.Наименование+" Владелец баз.ед.изм.:"+СН.БазоваяЕдиница.Владелец);
        ИначеЕсли (СН.ОсновнаяЕдиница.Владелец<>СН.ТекущийЭлемент()) тогда
            Сообщить(СН.Наименование+" Владелец осн.ед.изм.: "+СН.ОсновнаяЕдиница.Владелец);
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
...
даже в типовой демке повылазили:
Молоко "Домик в деревне" 3.2% Владелец баз.ед.изм.:Молоко "Домик в деревне" 1.5%
Молоко "Останкинское" 3.2% Владелец баз.ед.изм.:Молоко "Останкинское" 1.5%
Кто-нить может сие объяснить?
 
  Рекламное место пустует
   Рупор абсурда
 
11 - 26.03.04 - 16:29
(9) Лучше всё исправить, имхо ...
Не знаю я, как там с единицами учёт завязан ...
Ты ж не хочешь, чтоб у тебя эти глюки так и жили в регистрах?
   Гном
12 - 26.03.04 - 16:30
Пасибо, но я примерно так и выявил это дело...
   Гном
13 - 26.03.04 - 16:35
(11) Все исправить нереально, т.к. список корявой номенклатуры довольно приличный, количество доков в день - 30 - 70, а выявил я энто только вчера...
   Рупор абсурда
 
14 - 26.03.04 - 16:41
(13) Я ж не предлагаю тебе это делать "вручную" ...


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует