Вход | Регистрация


1С:Предприятие ::

Метки:

Как в диалоге отчета сделать выбор нескольких элементов справочника

Я
   Сергей
25.03.04 - 10:23
Отчет остатки по складам. Нужно выбрать не один склад из Справочник.Склады, а, например, отметить несколько и для каждого получить данные в одном отчете
 
  Рекламное место пустует
   Сергей
1 - 25.03.04 - 10:29
1С Предприятие 7.7
   Дмитрий
 
2 - 25.03.04 - 10:41
(0) Таблица значений на форме поможет, если выбора группы справочника недостаточно
   Bzzzzz
 
3 - 25.03.04 - 11:02
(2) А список с пометками?
   327
4 - 25.03.04 - 11:29
Самое простое - подбор ....
   Сергей
5 - 25.03.04 - 11:31
А как это - с пометками?
   Сергей
6 - 25.03.04 - 11:33
Как в диалоге подбор сделать?
   Дмитрий
 
7 - 25.03.04 - 11:36
(6) Точно так же, как и в документе. Вешаешь его на кнопку, а выбранные значения складываешь в список - элемент диалога.
   dvk
 
8 - 25.03.04 - 11:44
С пометками это значит, что в таблице значений есть дополнительное поле типа "число". В свойствах таблицы значений указываешь какую картинку использовать.
В процедуре ПриОткрытии() пишешь ТабЗнач..ВыводитьПиктограммы(1,);
В свойствах таблицы значений пишешь процедуру, выполняемую при 2-ном щелчке по таблице.
Содержание этой процедуры примерно выглядит так:
Процедура ВыборТовара()
       Если СписокТовара.ТекущаяКолонка()="Выбран" Тогда
         Если СписокТовара.Выбран=2 тогда
             СписокТовара.Выбран=1;
         Иначе                   
             СписокТовара.Выбран=2;
         КонецЕсли;
    КонецЕсли;
КонецПроцедуры
   dvk
 
9 - 25.03.04 - 11:46
После выбора необходимых складов пишем запрос с условием включать в выборку только эти склады. Ну и т.д...
   Bzzzzz
 
10 - 25.03.04 - 11:50
(6) С пометками:
кидаешь на форму элемент диалога и в свойствах ему выставляешь "С пометками".
При открытии формы заполняешь его.
Гораздо проще, чем с ТЗ.
 
  Рекламное место пустует
   dvk
 
11 - 25.03.04 - 11:55
С "пометками" - это у какого элемента диалога в 7.7 есть такое свойство?
   GrayT
 
12 - 25.03.04 - 11:56
+10 Затем перегружаешь в список только отмеченные и в запросе используешь "в"
   GrayT
 
13 - 25.03.04 - 11:57
(11) У любого списка значений. Если на форме то сразу видно :)
   dvk
 
14 - 25.03.04 - 12:02
(13) Может я слепой, но ничего подобного я не вижу
   GrayT
 
15 - 25.03.04 - 12:03
Кинь на форму "Список" - Свойства-Дополнительно-Список с пометками
   dvk
 
16 - 25.03.04 - 12:03
Ааа.. понял это есть только у элемента "СписокЗначений"
извиняюсь :)
   Сергей
17 - 25.03.04 - 12:12
Как в этот список значений кинуть справочник.склады?
   dvk
 
18 - 25.03.04 - 12:16
Легко.
спСклады=СоздатьОбъект("Справочник.Склады");
спСклады.ВыбраттьСтрорки();
Пока спСклады.ПолучитьЭлемент()=1
Цикл
СписокЗначений.ДобавитьЗначение(спСклады,спСклады.Наименование);
КонецЦикла;
   ilChino
 
19 - 25.03.04 - 12:21
изврат все это,проще прибабахать мультифильтр как в стандартных отчетах,я в свое время три часа убил на то как оно устроено,зато теперь за 10 минут его вставляю где надо в свои...
   GrayT
 
20 - 25.03.04 - 12:22
Это если нет Групп
и
СписокЗначений.ДобавитьЗначение(спСклады.ТекущийЭлемент(),спСклады.Наименование);
   dvk
 
21 - 25.03.04 - 12:24
(20) Согласен, написал по памяти а ее как всегда не хватает :)
   Сергей
22 - 25.03.04 - 13:12
делаю что подсказали со списком, но список пустой и пишет:  спСклады.ВыбратьСтроки();
Поле агрегатного объекта не обнаружено (ВыбратьСтроки)

Что писать в Идентификатор и Формула, может не соответствуют?
   ilChino
 
23 - 25.03.04 - 13:23
ВыбратьЭлементы(),....че выбираем то и получаем.
   Сергей
24 - 25.03.04 - 14:24
Всё это должно быть в процедуре: ПриОткрытии ?
Делаю в ней, но список не выводится - пусто
   Bzzzzz
 
25 - 25.03.04 - 14:44
(24) Прочитай про работу со СпискомЗначений на Миста.ру
   Сергей
26 - 25.03.04 - 14:54
Я уже читал.
Очень красивая картинка с галочками, только как эту картинку в диалоге увидеть?
   Bzzzzz
 
27 - 25.03.04 - 15:19
(27) я те на мыло отправил пример обработки



Список тем форума
Рекламное место пустует  
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует