Вход | Регистрация

1С:Предприятие ::

Метки:

Форма выбора справочника с периодом от - до в 8-ке

Я
   bel_igor
 
24.03.04 - 16:43
В документе есть поля ДатаНачала, ДатаКонца, и поле Некто, Некто - значение выбираемое из справочника.
У Некто есть реквизит ДатаРегистрации. Необходимо открыть форму выбора справочника Некто, где реквизит ДатаРегистрации в периоде ДатаНачала - ДатаКонца.
 
 
   bel_igor
 
1 - 24.03.04 - 16:58
Ну подскажите, как передать два значения в форму выбора справочника из формы документа.
   Евгений
 
2 - 24.03.04 - 17:14
Я бы сделал так: форме списка справочника на вкладке "Реквизиты" завел пару реквизитов датНач и датКон.
К полю "Некто" привязываешь предопределенную процедуру "НачалоВыбора", а в ней отказываешься от стандартной обработки и пишешь свою.
Примерно так:
фор=Документы.ТвойДокумент.ПолучитьФорму();
фор.датНач=ДатаНачала;
фор.датКон=ДатаКонца;
фор.Открыть();

В форме списка при открытии вставляешь установку фильтра по датам по переданным значениям.
   bel_igor
 
3 - 24.03.04 - 17:19
Вроде все логично, если не трудно подскажите как установить фильтр. Пока пробую (2).
   Евгений
 
4 - 24.03.04 - 17:52
Если (датНач<>00010101) И (датКон<>00010101)
  <ТвойСписок>.Отбор.ДатаРегистрации.ВидСравнения.ИнтервалВключаяГраницы;
<ТвойСписок>.Отбор.ДатаРегистрации.ЗначениеС=датНач;
<ТвойСписок>.Отбор.ДатаРегистрации.ЗначениеПо=датКон;
<ТвойСписок>.Отбор.ДатаРегистрации.Использование=Истина;
КонецЕсли;
где <ТвойСписок> - имя списка в форме, на который накладывается отбор.
Где-то так...
   bel_igor
 
5 - 24.03.04 - 18:08
В справочнике добавил два реквизита ДатаНачала ДатаКонца

в документе
Процедура СоискательНачалоВыбора(Элемент, СтандартнаяОбработка)
    форСпр=Справочники.СпрСоискатель.ПолучитьФорму("ФормаСписка"); 
    форСпр.ДатаНачала = ЭлементыФормы.ДатаНачала; 
    форСпр.ДатаКонца = ЭлементыФормы.ДатаКонца; 
    .Открыть(); 
КонецПроцедуры
В ответ
Поле объекта не обнаружено (ДатаНачала)
    форСпр.ДатаНачала = ЭлементыФормы.ДатаНачала;

Пробовал форСпр.СправочникСписок.ДатаНачала - тоже ругается.
   ezh
 
6 - 24.03.04 - 19:18
может сначала книжки немного почитаешь? не в обиду, но ты не понимаешь даже того, что тебе разжевали.
да и делаешь ты немного через Ж...
   bel_igor
 
7 - 24.03.04 - 20:41
Немогу установить отбор Нелр!!! Осталось 20 мин.
В форме справочнника пишу
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Если (ДатаНачала<>00010101) И (ДатаКонца<>00010101) Тогда 
        //СправочникСписок.Отбор.ДатаСобеседования.ВидСравнения.Интервал;

        Сообщить("СДН="+ДатаНачала);
        Сообщить("СДК="+ДатаКонца);     
        СправочникСписок.Отбор.ДатаСобеседования.ЗначениеС = ДатаНачала;
 
        СправочникСписок.Отбор.ДатаСобеседования.ЗначениеПо = ДатаКонца;        

        СправочникСписок.Отбор.ДатаСобеседования.ВидСравнения.ИнтервалВключаяГраницы;
        СправочникСписок.Отбор.ДатаСобеседования.Использование = Истина; 
    КонецЕсли; 
КонецПроцедуры
Получаю
{Справочник.СпрСоискатель.Форма.ФормаСпискаОсн(15,78)}: Неопознанный оператор
        СправочникСписок.Отбор.ДатаСобеседования.ВидСравнения.ИнтервалВключаяГраницы<<?>>;
   SnarkHunter
 
8 - 24.03.04 - 20:48
Что произойдет по прошествии 20 минут?
   bel_igor
 
9 - 24.03.04 - 20:50
Домой пойду с чувством невыполненного долга, Пока буду ехать изойдусь.
   bel_igor
 
10 - 24.03.04 - 20:51
не выполненного конечно, всегда был грамотеем.
 
  Рекламное место пустует
   SnarkHunter
 
11 - 24.03.04 - 20:56
Не повезло тебе... Утешайся тем, что, придя домой, у тебя есть шанс исполнить какой-нибудь другой долг...
   bel_igor
 
12 - 25.03.04 - 09:25
Я так понимаю, что конструкция СправочникаСписка.Отбор.<имя элемента отбора>.ВидСравнения.ИнтервалВключаяГраницы, работать не будет. Т.к. СправочникаСписка.Отбор - только для чтения. А вот это:
СправочникСписок.Отбор.<имя элемента отбора>.Значение = <ЗначениеЭлемента>; Всегда пожалуйсто.
Ок????
   Евгений
 
13 - 25.03.04 - 10:19
(12) Сорри, конечно должно выглядеть:
<ТвойСписок>.Отбор.ДатаРегистрации.ВидСравнения=ВидСравнения.ИнтервалВключаяГраницы;
Обшибся...
(5) Да не в справочник реквизиты надо добавлять, а в его форму. Открываешь форму списка справочника, на ней три вкладки: "Диалог", "Модуль", "Реквизиты". Вот в эту вкладку "Реквизиты" и надо лезть.
   Евгений
 
14 - 25.03.04 - 10:21
(6) По крайней мере ничего более умного я пока не придумал. Если не лень, подскажи какой-нибудь другой способ передаци данных между формами. Если будет более элегантное, обещаю применять.
   ezh
 
15 - 25.03.04 - 10:22
может так написать!?

СправочникСписок.Отбор.ДатаСобеседования.ВидСравнения = ВидСравнения.ИнтервалВключаяГраницы;
   ezh
 
16 - 25.03.04 - 10:24
(14) ты нормально предложил. он сделал через Ж.
а ты ходи сюда: http://itland.ru/forum/index.php?showforum=5
   Евгений
 
17 - 25.03.04 - 12:00
(16) Спасибо. Там, собственно, и живу...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует