Вход | Регистрация

1С:Предприятие ::

Метки:

Загрузка текстового файла,разделенного файла

Я
   Странник
 
16.03.04 - 17:04
Версия 1с 8
Нужно загружать данные из файла к примеру :
ГР,002,Невская косметика,косметика
ТОВ,04345674,Черный Жемчуг,крем,14.15

Как правильно разделить по запятой, если вотроенные механизмы.
Конешно возможен вариант, искать в строке запятую и обрязать до нее, но это получаться джовольно не эффективно
 
  Рекламное место пустует
   skunk
 
1 - 16.03.04 - 17:06
ИзСтрокиСРазделителями(<?>)
FromSeparatedString(<?>)
Синтаксис:
ИзСтрокиСРазделителями(<Строка>)
Назначение:
Заполняет СписокЗначений значениями из переданной в качестве параметра строки, содержащей разделенные запятыми значения: числа и строки в двойных кавычках.
Параметры:
<Строка> - символьная строка, в которой значения разделены запятыми. В качестве значений могут быть числа и строковые значения - они записываются в двойных кавычках.
   IAm
 
2 - 16.03.04 - 17:12
1 В 8ке есть такая функция?
Тогда сначала текст нужно форматировать так, чтобы значение были в двойных кавычках.
То есть НужнТекст = СтрЗаменить("""" + НужнТекст + """", ",", "",""")
   Рупор абсурда
 
3 - 16.03.04 - 17:13
Стр=СтрЗаменить(Стр,",",РазделительСтрок);
Для Х=1 По СтрКоличествоСтрок(Стр) Цикл
  Сообщить(СтрПолучитьСтроку(Стр,Х)
КонецЦикла;
   IAm
 
4 - 16.03.04 - 17:18
3 При условии что Стр не имеет разделителей строк
   Рупор абсурда
 
5 - 16.03.04 - 17:23
(4)
Стр=СтрЗаменить(Стр,РазделительСтрок,"!@#$%^&*()"); 

Стр=СтрЗаменить(Стр,",",РазделительСтрок); 
Для Х=1 По СтрКоличествоСтрок(Стр) Цикл 
 Сообщить(СтрЗаменить(СтрПолучитьСтроку(Стр,Х),,"!@#$%^&*()",РазделительСтрок)) 

КонецЦикла;
   IАm
6 - 16.03.04 - 17:35
5 При условии что Стр не имеет "!@#$%^&*()"
   IAm
 
7 - 16.03.04 - 17:39
5 я не писал. Кто-то вместо меня пишет.
   IAm
 
8 - 16.03.04 - 17:40
То есть 6 я не писал. Хотя кто теперь может знать кто я а кто не я.
   Рупор абсурда
 
9 - 16.03.04 - 17:40
(6)
Флуд=,"!@#$%^&*()";
Пока Найти(Стр,Флуд)>0 Цикл Флуд=Флуд+Флуд КонецЦикла;
Стр=СтрЗаменить(Стр,РазделительСтрок,Флуд); 
Стр=СтрЗаменить(Стр,",",РазделительСтрок); 
Для Х=1 По СтрКоличествоСтрок(Стр) Цикл 
Сообщить(СтрЗаменить(СтрПолучитьСтроку(Стр,Х),Флуд,РазделительСтрок)) 
КонецЦикла;
   Странник
 
10 - 17.03.04 - 06:01
ТО: Рупор абсурда
Что подразумеваеться под: РазделительСтрок
Это СиволыПс ? Или что ?
пытаюсь сделать присланные варианты, но у меня всегда подучесться только одна строка :(
 
  Рекламное место пустует


Список тем форума
 
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует