Вход | Регистрация

1С:Предприятие ::

Метки:

Обьединение таблиц значений

Я
   lobanov
14.01.05 - 09:08
Есть две Таблицы значений ТЗ и ТЗ1 у них одинаковая колонка контрагенты
Нало обьединить ТЗ и ТЗ.СуммаОст с одинаковыми контрагентами
    Перем ТЗ; 

        ТЗ3 = СоздатьОбъект("ТаблицаЗначений"); 
        ТЗ3.НоваяКолонка("Контрагент", );
        ТЗ3.НоваяКолонка("Сч76Н1", "Число");
        ТЗ3.НоваяКолонка("Сч621", "Число");
        ТЗ3.НоваяКолонка("Оборот", "Число"); 
                                 ТЗ3.НоваяКолонка("СуммаОст", "Число"); 
        Пока ТЗ1.ПолучитьСтроку()=1 Цикл 
    Стр = "";
    Пока ТЗ.НайтиЗначение(ТЗ1.Контрагент,Стр,"Контрагент")>0 Цикл 
                      ТЗ3.НоваяСтрока(); 

          ТЗ3.Контрагент = ТЗ1.Контрагент; 
          Если ТЗ.Контрагент = ТЗ1.Контрагент
          Тогда 
          ТЗ3.СуммаОст = ТЗ.СуммаОст; 
          КонецЕсли;
          
          ТЗ3.Сч76Н1 = ТЗ1.Сч76Н1;
          ТЗ3.Сч621 = ТЗ1.Сч621;
          ТЗ3.Оборот = ТЗ1.Оборот;
            КонецЦикла; 
        КонецЦикла;

Почемуто ТЗ3.СуммаОст = 0?
 
 
   Rovan
 
1 - 14.01.05 - 09:35
функция ТЗ.НайтиЗначение не позиционирует строку в ТЗ, поэтому
надо установить текущую строку по номеру или
обращатся к полям через № строки
   simplyUser
2 - 14.01.05 - 09:37
Кодом ТЗ.НайтиЗначение(ТЗ1.Контрагент,Стр,"Контрагент")>0 ты просто определяешь, есть ли такой контрагент. А теперь нужно стать на эту строку в ТЗ (если >0 конечно)- <ТЗ.ПолучитьстрокуПоНомеру(Стр)>. А вообще, непонятно, зачем цикл (в конце которого опять же надо бы делать Стр=""). По <НайтиЗначение> - всегда будешь попадать на одну и ту же строку в ТЗ.


Список тем форума
Рекламное место пустует  
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует