Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Из модального окна вызываю ПОДБОР, открывается НЕМОДАЛЬНОЕ окно

Ø
Я
   Haspor
08.01.05 - 13:28
и соответственно сделать подбор не получается...
Как форму для подбора открыть мобально?
Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога,ФлагСтандОбр)
  Если ИдентЭлемДиалога = "Вид" Тогда	
    СписокЗначенийВПодбор = СоздатьОбъект("СписокЗначений");
    СписокЗначенийВПодбор.ДобавитьЗначение(Тип,"Тип");
    СписокЗначенийВПодбор.ДобавитьЗначение(Объект.Вид(),"ВидОбъекта");
    
    ОткрытьПодбор("Справочник.ВидыКонтактнойИнформации","ФормаСписка",СписокЗначенийВПодбор,0);
    ФлагСтандОбр = 0;
  КонецЕсли;
КонецПроцедуры
Форма подбора процедура ПриОткрытии()
Процедура ПриОткрытии()
  Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
    ЗначениеОтбора					 		= Форма.Параметр.Получить("Тип");
    ПараметрВидОбъектаКонтактнойИнформации 	= Форма.Параметр.Получить("ВидОбъекта");
    ПараметрВидОбъектаКонтактнойИнформации 	= Перечисление.ВидыОбъектовКонтактнойИнформации.ЗначениеПоИдентификатору(ПараметрВидОбъектаКонтактнойИнформации);
    УстановитьОтбор("Тип",ЗначениеОтбора);
    РедактироватьВДиалоге(0,0);
  КонецЕсли;
КонецПроцедуры// ПриОткрытии
 
 
   Джинн
1 - 08.01.05 - 13:35
Из модального окна нельзя вызвать другое, "более модальное" окно :)
Модальное окно ОДНО по определению.
   Haspor
2 - 08.01.05 - 13:36
2(1)
Ответ неправильный.
   корум
3 - 08.01.05 - 15:08
(2) Садись, два. Учи ЖКК, однако...
   Haspor
4 - 08.01.05 - 15:31
2(3)
Вы че, двоечники...
1. Открываю модальное окно Контрагенты.
2. Из Контрагента открываю Модальное окно "Договор Контрагента"
3. Из Модального окна "Договор контрагента" открываю Модальное окно "Фирма к коротой относится договор"..
Эти все окна открыты МОДАЛЬНО...
Другое дело, что я имею доступ к одной из них в один момент времени - это правда. НО ВСЕ ОНИ ОТКРЫТЫ МОДАЛЬНО. А АКТИВНОЙ МОЖЕТ БЫТЬ ТОЛЬКО ОДНА - и это правда.
А суть сабжа такова: почему при открытии модального окна открывается обыкновенное немодальное окно которое помещается "сзади" модального окна.
   ПростойВопрос
5 - 08.01.05 - 15:37
ОткрытьПодбор - всегда открывается немодально, так что либо не пользуйся "открытьподбор" в данном случае либо пиши свой подбор - другого не дано.
   pit
6 - 08.01.05 - 15:37
Ну бывает такой прикол в 1С...
А потом юзер как дурак пытается выковырять немодальное окно из под модального... да слабо получается...
   корум
7 - 08.01.05 - 15:39
(4) почти прав, но тока почти.
Если открывать ПОДБОР, он таки не модально открывается, и судя по коду - никто и не пытался по-другому вызывать ;о)
и эта, ну её, работу... отпуск всё - таки...
   pit
8 - 08.01.05 - 15:44
(7) Я делал... Через переоткрытие формы модально...
   Haspor
9 - 08.01.05 - 15:46
2(7)
выходные - хорошо...
Но надо денежки зарабатывать...
з.ы имхо очень много отдыхать целых 2 недели. Мне уже надоело :0)



Список тем форума

Форум Территория 1С

Рекламное место пустует  
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует