Вход | Регистрация

1С:Предприятие ::

Метки:

Как найти контрагента по ИНН ?

Я
   f72pruts
 
13.01.05 - 17:38
Можно как-то реализовать. А то бывают случаи одну и туже организацию под разными названиями вводять. Так бугалтера хотять осуществить поиск по ИНН - возмжно это реализовать без изменения в коде конфигурации.
Если как объясните пожалуйста.
 
  Рекламное место пустует
   Волшебник
 
1 - 13.01.05 - 17:43
реквизит должен быть проиндексирован, тогда возможно
   Asmody
 
2 - 13.01.05 - 17:47
перевожу (1) - поставь галку "Сортировка" в свойствах реквизита ИНН в справочнике Контрагенты
   Волшебник
 
3 - 13.01.05 - 17:48
(2)+ Перед этим надо запустить Конфигуратор, наведя мышку на значок 1С:Предприятие 7.7 и щелкнув дважды с интервалом меньше секунды...
   Asmody
 
4 - 13.01.05 - 17:49
(3) забыл про кнопку "пуск" >;)) (уже флеймим или еще нет?)
   f72pruts
 
5 - 13.01.05 - 17:57
Этот метод понятен. А при выборе контрагента можно ли вставит напротив него еще и ИНН, азь?
   f72pruts
 
6 - 13.01.05 - 17:58
P.S.
Как свойство
   Волшебник
 
7 - 13.01.05 - 17:58
(5) Можно.
   f72pruts
 
8 - 13.01.05 - 18:00
А как ?
   Волшебник
 
9 - 13.01.05 - 18:00
(8) Добавить колонку ИНН в форму выбора.
   f72pruts
 
10 - 13.01.05 - 18:05
Всем огромное спасибо!
Тема закрыта!!!! :-))))))))
 
  Рекламное место пустует
   f72pruts
 
12 - 14.01.05 - 18:46
Добавить колонку ИНН.
Интересно как если этого реквизита в справочнике Контрагенты нет в помине.
Конфигурация(Комплексная). Выбор осуществляется из справочников
ЮрЛица, ФизЛица и еще одни. Но как объединит непонял.
   lemon
 
13 - 14.01.05 - 19:07
(12) текстовая колонка, в формуле "ЮрФизЛицо.ИНН"...
   f72pruts
 
15 - 14.01.05 - 19:17
Скажите пожалуйста это мы видили ЮрФизЛицо.ИНН. Только появляется название.
А как вставит в таблицу выбора Контрагента, если можно толко колонки
реквизитов - писать что ли обработчик, а?
   lemon
 
16 - 14.01.05 - 19:35
(15) вы прекрасно изъясняетесь, причем стилистика в меру гармонирует с грамматикой и пунктуацией...
вставлять можно (и нужно) пустую текстовую колонку (пикторамма "Т") или Вставить, Текст ...
   f72pruts
 
19 - 18.01.05 - 09:00
Функция ОсновноеСвойство()
        Если ЭтоГруппа() = 1 Тогда
                Возврат "";
        КонецЕсли;
        
        Если ПустоеЗначение(ТекущийЭлемент()) = 1  Тогда
                Возврат "";
        Иначе       
        Если ПустоеЗначение(ТекущийЭлемент().ЮрФизЛицо) = 1  Тогда Возврат "";  
                 Иначе
          Возврат ТекущийЭлемент().ЮрФизЛицо.ИНН;
//              Если ПустоеЗначение(ТекущийЭлемент().ОсновноеСвойство) = 1  Тогда

//                      Возврат "";
//              Иначе

//                      Возврат ТекущийЭлемент().ОсновноеСвойство.ЗначениеСвойства;
                КонецЕсли;
        КонецЕсли;
КонецФункции// ОсновноеСвойство()
   f72pruts
 
20 - 18.01.05 - 09:05
Исправил в модуле "Форма-Справочник.Контрагенты.ФормаСписка.ФормаСписка" и
"Форма-Справочник.Контрагенты.ФормаСписка.ДляВыбора", а то не получается вставит в свойство "Многострочной Части"


Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует