Вход | Регистрация

1С:Предприятие ::

Метки:

Можно ли выгрузить таблицу значений в Excel и как?

Я
   krf
 
13.01.05 - 11:23
subg
 
  Рекламное место пустует
   miki
 
1 - 13.01.05 - 11:45
Да.
По разному. Например, через СоздатьОбъект("Excel.Application")
   Волшебник
 
2 - 13.01.05 - 11:46
Можно еще вывести в отчет и сохранить его в формате XLS
   Rovan
 
3 - 13.01.05 - 11:50
(0) Выведи в печатную форму а уж оттуда в Ексел.
   miki
 
4 - 13.01.05 - 11:59
   krf
 
5 - 13.01.05 - 12:43
У меня ситуация такая:
Мне надо в цикле по операциям и проводкам:
1. Отобрать все операции, в который есть проводки по дебету 62 счета
2. Для отобраных операция:
- подсчитать сумму проводок по дебету 62 и кредиту 90
- подсчитать сумму проводок по дебету 90 и кредиту 41
3. Вывести (в виде отчета либо в файл) таблицу со следующими столбцами:
- дата операции
- содержание операции
- субконто по 62 счету
- сумма проводок (входящих в операцию) по дебету 62
- сумма проводок (входящих в операцию) по кредиту 41
Я в программировании в 1С - новичек
Как организовать цикл по операциям и проводкам, отобрать в нем нужные операции и посчитать для них нужные значения я разобрался
А вот как вывести это в файл или в виде отчета - пока понять не могу.
Я понял как можно задать значения для каждой строке в Таблице Значений, но не понимаю, как ее можно вывести в файл.
Пробовал в виде отчета, но не понимаю как задать конкретные значения в каждой ячейке строки перед тем, как вывести секцию
   NastyFrog
 
7 - 13.01.05 - 17:58
//*******************************************

Процедура Сформировать()
    Экс=СоздатьОбъект("Excel.Application");    
    ркЭ=Экс.Workbooks;
    ркЭ.Open("c:\temp\test.xls");
    рлЭ=Экс.ActiveSheet;
   //создадим и заполним ТЗ

    тблЗн=СоздатьОбъект("ТаблицаЗначений"); 
    тблЗн.НоваяКолонка("Наименование","текст");
    тблЗн.НоваяКолонка("Количество","число");  
    СчетчикЦикла = 0;
    Для СчетчикЦикла = 1 По 10 Цикл
        тблЗн.НоваяСтрока(СчетчикЦикла);
        тблЗн.Наименование="Товар " + СчетчикЦикла;
        тблЗн.Количество= СчетчикЦикла*10;
    КонецЦикла;
   // заполним ехель

    тблЗн.ВыбратьСтроки();
    нСтроки=1;
    Пока тблЗн.ПолучитьСтроку()=1 Цикл
        рлЭ.Cells(нСтроки,1).Value=тблЗн.Наименование;
        рлЭ.Cells(нСтроки,2).Value=тблЗн.Количество; 
        нСтроки=нСтроки + 1;
    КонецЦикла;
    Экс.Visible=1;
КонецПроцедуры
   miki
 
8 - 13.01.05 - 18:59
   miki
 
9 - 13.01.05 - 19:00
Бля, так и не научился, сорри.
Тест:
http://www.kuban.ru/forum_new/forum9/files/214164.html


Список тем форума
Рекламное место пустует   Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует