Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Работа 1С со строками...

Ø
Я
   IAm
07.01.05 - 13:24
Кто-нибудь может мне объяснить, почему метод
ВСтрокуСРазделителем объекта типа СписокЗначений,
содержащего 50000 значений выполняется 2 минуты на 4 пентиуме,
а составление строки при переборе значений и вовсе 3 с половиной.
Что там такое происходит, попытка выполнения того же функционала на С++
дает моментальные результаты.
 
  Рекламное место пустует
   VZ
1 - 07.01.05 - 13:36
Это анонс ВК VLtoSTR.dll ?
   IAm
2 - 07.01.05 - 13:40
1 Это анонс передачи Аншлаг?
   vS
3 - 07.01.05 - 16:22
может это потому, что 1С интерпретатор? а С++ нет?
   IAm
4 - 07.01.05 - 16:40
А разница какая? Он же один раз "интерпретирует", при загрузке формы.
   MetaEditor
5 - 07.01.05 - 19:53
да скорее всего теже проблемы что и с текстом... всё держится в памяти...
вариант с разбиением на подстроки чуть побыстрее...:
Процедура Преобразовать()
Перем Масс[1000];
СЗ=СоздатьОбъект("СписокЗначений");
Для сч=1 По 50000 Цикл// сформируем СЗ
  СЗ.ДобавитьЗначение("строка"+Строка(сч))
КонецЦикла;	
Сообщить("СЗ сформирован");
ном=1;
Для сч=1 По 50000 Цикл
Масс[ном]=Масс[ном]+Симв(34)+СЗ.ПолучитьЗначение(сч)+Симв(34)+",";
Если сч%50=0 Тогда ном=ном+1; КонецЕсли;
КонецЦикла;// склеим массив в строку
Для сч=1 По 1000 Цикл стр=стр+Строка(Масс[сч]); КонецЦикла;
Сообщить("Конец преобразования");
КонецПроцедуры// Преобразовать
   IAm
6 - 07.01.05 - 20:04
(5) Спасибо, буду знать на будущее, пока выкрутился внешней длл.
   Неудачник
7 - 07.01.05 - 21:25
VLtoSTR.dll?
   VZ
8 - 07.01.05 - 22:27
(7) Т-с-с-с-с....



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует