Вход | Регистрация

  1  2   
1С:Предприятие ::

Метки:

В Таблице Значений нельзя сортировать по колонкам?

Я
   Федорыч
 
15.03.04 - 15:26
Что больше 100-и или 1000?

Если эти значения занести в ТЗ, а затем отсортировать и сравнить на "<>", результаты будут неверными.

Готов выслать ert.
Буду признателен, если поможете найти ошибку.
 
 
   Рупор абсурда
 
1 - 15.03.04 - 15:29
(0) Мне отвечать?
   Федорыч
 
2 - 15.03.04 - 15:37
Какой вопрос?
Если по делу, буду Рад.
   Bekas
 
3 - 15.03.04 - 15:39
Рупор абсурда. Не спорь. Врет сортировка. Товарищу не докажешь, разве не видно?
   Рупор абсурда
 
4 - 15.03.04 - 15:40
(2) Ок, по делу: тыщща, раз в десять, больше сотни ...
Рад?
   Федорыч
 
5 - 15.03.04 - 15:50
Дуэль?
Готов. Куда выслать ert?
Я попался на сравнении "100-и" и "1000".
Вместо "флуда" проверь сам. Скажи где ошибка.
   Bekas
 
6 - 15.03.04 - 15:55
5: Опа! Ночной Дозор! Выйти из Сумрака!
Какая-такая дуэль? К кому обращался?
   Рупор абсурда
 
7 - 15.03.04 - 15:55
(5) Сомневаюсь, что стреляться с тобой на дуэли будет интереснее, чем флудить ...
   Антон Городецкий
8 - 15.03.04 - 15:58
Зырк...Зырк...
   Bekas
 
9 - 15.03.04 - 15:59
Стреляться можно только из-за бабы...
   Федорыч
 
10 - 15.03.04 - 16:02
Вот трепачи.
Попробуйте сами.
Перем Ответ;

//*******************************************

Процедура Сформировать()
    
    ТЗ.УдалитьСтроки();
    
    ТЗ.НоваяСтрока();
    ТЗ.Перем    = "А";
    ТЗ.Поиск    = "100-и";
    
    ТЗ.НоваяСтрока();
    ТЗ.Перем    = "Б";
    ТЗ.Поиск    = "1000";
    
    ТЗ.Сортировать("Поиск");
    
    Если ТЗ.ПолучитьЗначение(1,"Поиск") > ТЗ.ПолучитьЗначение(2,"Поиск") Тогда
        Ответ = СокрЛП(ТЗ.ПолучитьЗначение(1,"Перем"))+" > "+СокрЛП(ТЗ.ПолучитьЗначение(2,"Перем"));
    Иначе
        Ответ = СокрЛП(ТЗ.ПолучитьЗначение(2,"Перем"))+" > "+СокрЛП(ТЗ.ПолучитьЗначение(1,"Перем"));
    КонецЕсли;
    Сообщить(Ответ);
КонецПроцедуры 

//*******************************************

Процедура Сформировать2()
    
    ТЗ.УдалитьСтроки();
    
    ТЗ.НоваяСтрока();
    ТЗ.Перем    = "А";
    ТЗ.Поиск    = "100-";
    
    ТЗ.НоваяСтрока();
    ТЗ.Перем    = "Б";
    ТЗ.Поиск    = "1000";
    
    ТЗ.Сортировать("Поиск");
    
    Если ТЗ.ПолучитьЗначение(1,"Поиск") > ТЗ.ПолучитьЗначение(2,"Поиск") Тогда
        Ответ = СокрЛП(ТЗ.ПолучитьЗначение(1,"Перем"))+" > "+СокрЛП(ТЗ.ПолучитьЗначение(2,"Перем"));
    Иначе
        Ответ = СокрЛП(ТЗ.ПолучитьЗначение(2,"Перем"))+" > "+СокрЛП(ТЗ.ПолучитьЗначение(1,"Перем"));
    КонецЕсли;
    Сообщить(Ответ);
КонецПроцедуры 

//*******************************************

ТЗ    = СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Перем","Строка",50,,,10,,);
ТЗ.НоваяКолонка("Поиск","Строка",50,,,10,,);
 
  Рекламное место пустует
   Завулон
 
11 - 15.03.04 - 16:07
"Он под моей охраной" (с)
   Гесер
12 - 15.03.04 - 16:08
Хе-хе...
(11)Мало тебя подставляли?
   Рупор абсурда
 
13 - 15.03.04 - 16:08
(10) Всё правильно сортирует ...
   Bekas
 
14 - 15.03.04 - 16:10
Завулон. Ты не имеешь власти надо мной.
   Федорыч
 
15 - 15.03.04 - 16:12
Во втором примере "1000" > "100-"
И тут сортировка работает нормально.
В первом "100-и" > "1000"

А в таблице? Выведи на форму.
Какая строка раньше?
   Сумрак
16 - 15.03.04 - 16:12
Вы все в моей власти.
   327
17 - 15.03.04 - 16:20
Ну и что доказывает (10).... Незнание сравнения строк?
   327
18 - 15.03.04 - 16:21
Точнее... незнание особенностей кривой ТЗ... это есть ....
   Рупор абсурда
 
19 - 15.03.04 - 16:23
(18) ТЗ СОРТИРУЕТ ПРАВИЛЬНО!
   Bekas
 
20 - 15.03.04 - 16:27
ТЗ не сортирует. Это просто ТАБЛИЦА ЗНАЧЕНИЙ.
   327
21 - 15.03.04 - 16:36
(19) Это ты мне?  Ну дак я знаю, что правильно ....
ТоварисЧ облажался на сравнении
   Рупор абсурда
 
22 - 15.03.04 - 16:38
(21) А фигли ты тогда в (18) мой любимый объект "кривым" обозвал? ...
   Кое-кто@где-то.там
23 - 15.03.04 - 16:58
(22) "Кривой" и есть :) Смотрим:

Процедура Сформировать()
    ТЗ=СоздатьОбъект("ТаблицаЗначений"); 
    ТЗ.НоваяКолонка("К","Число",2,0,"Значение",10);
   // заполним 10 строк в порядке убывания

    ТЗ.КоличествоСтрок(10);
    Для нс=1 по 10 Цикл
        ТЗ.УстановитьЗначение(нс,"К",11-нс);
    КонецЦикла;                               
   // смотрим. Нормально.

    ТЗ.ВыбратьСтроку(,"Это ещё нормальная ТЗ");
   // Сортирнем

    ТЗ.Сортировать("");                     
   // смотрим. Вроде нормально.

    ТЗ.ВыбратьСтроку(,"Отсортированная, но до сих пор нормальная ТЗ");
   // оставим первые пять строк

    ТЗ.КоличествоСтрок(5);                       
   // угадайте, что останется?

    ТЗ.ВыбратьСтроку(,"Великолепный ГЛЮК!");
КонецПроцедуры
   Рупор абсурда
 
24 - 15.03.04 - 17:02
(23) Великолепному глюку лет 5 уже ...
А на новичка ты вроде не похож ...
   Кое-кто@где-то.там
25 - 15.03.04 - 17:03
(24) Да я так, к сведению ...
   Рупор абсурда
 
26 - 15.03.04 - 17:08
(25) Вот тебе ещё к сведению ...
Если не видел, обязательно посмотри, афуфеешь ... :))

ТЗ=СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("К");
Для Х=1 По 10 Цикл
  ТЗ.НоваяСтрока();
  ТЗ.К=Формат(Х,"ЧП");
КонецЦикла;                  
ТЗ.Сортировать("К");
ТЗ.КоличествоСтрок(8);  
ТЗ.КоличествоСтрок(4);  
ТЗ.КоличествоСтрок(2);
ТЗ.КоличествоСтрок(1);
ТЗ.ВыбратьСтроку();
   Кое-кто@где-то.там
27 - 15.03.04 - 17:11
(26) Угу, видел раньше. Прикольный эффект ;)
   Z1
28 - 15.03.04 - 17:33
(10) Получается ошибка при сравнении строк во внутр языке 1с.
Следущий код выдает
Зн_1 = "100-и";
Зн_2 = "1000";
Сообщить("Зн_1 = " + Зн_1);    
Сообщить("Зн_2 = " + Зн_2);    
   Если Зн_1 < Зн_2 Тогда 
Сообщить("Зн_1 < Зн_2 - Все в порядке");
   Иначе 
Сообщить("error Зн_1 < Зн_2 Ошибка сравнения строк!!!");
    КонецЕсли;
___________
результат :
Зн_1 = 100
Зн_2 = 1000
error Зн_1 < Зн_2 Ошибка сравнения строк!!!
   Рупор абсурда
 
29 - 15.03.04 - 17:44
(28) Теперь прочитай внимательно, что ты написал ...
   skunk
 
30 - 15.03.04 - 17:58
чего то никак не веду о чем тут спор...

100-и > 1000 > 100-      и причем тут 1С
   Z1
31 - 15.03.04 - 18:03
(30) код символа "-" равен 45
    код символа "0" равен 48
Таблицу значений из примера 10 программа на внутренем языке 1с сортирует правильно. При сравнении строк ошибка. Я просто показал что ошибка имено в сравнении
строк и не зависит от таблицы значений.
   Рупор абсурда
 
32 - 15.03.04 - 18:07
(30) 100-и < 1000
   IAm
 
33 - 15.03.04 - 18:11
Есть ещё в ТЗ при сортировке один неприятный момент.
Если второй раз подряд отсортировать по одной и той же колонке строки с одинаковыми значениями этой самой колонки меняются местами.
 
 
   Рупор абсурда
 
34 - 15.03.04 - 18:14
(33) Что-то ты недоговариваешь ...
   IAm
 
35 - 15.03.04 - 18:17
34 Искренне ваш, Львенок?
   Z1
36 - 15.03.04 - 18:18
(33) Ну это спорно считать за ошибку так реализован
алгоритм сортирвки ( хотя тоже наверное очень неприятно такое обнаружить) сравнения одинаковых строк , а вот 28 явная ошибка языка 1с.
   IAm
 
37 - 15.03.04 - 18:20
36 Я и не писал что это ошибка, но было неприятно, когда первый раз реализовывал ФИФО:
проводки документа запихивал в ТЗ, а когда потом сортировал "Материал,Дата", то они менялись местами, пока номер проводки не ввел.
   Рупор абсурда
 
38 - 15.03.04 - 18:22
(37) Первая сортировка была не по одной колонке ...
   skunk
 
39 - 15.03.04 - 18:28
(36)не одной 1С...  сам купился, за три рубля... еще одна прога сортирует их как показано в (30)

надо глянуть как другие БД отсортируют...
   skunk
 
40 - 15.03.04 - 18:31
+39 Access тоже согласен с (30) во гон...
   Рупор абсурда
 
41 - 15.03.04 - 18:31
(39) Не проверяй, глюку 100 лет в обед было ...
ИМХО, это ващще мелкософт виноват ...
   Z1
42 - 15.03.04 - 18:36
Проверил код как в (28) на C++
CString s1 = "100-и";
CString s2 = "1000";
if( s1 < s2 ) {
::MessageBox(NULL,"Ok", "Deb !!!", MB_OK);
}
else {
::MessageBox(NULL,"error !!!", "Deb !!!", MB_OK);
}
________
результат Ok.
В языке C++ сравнение строк правильное, в 1с неправильное.
   Z1
43 - 15.03.04 - 18:41
(0) Вывод для сравнения строк написать свою маленькую функцию через ВК ( или OLE server ) на С++ которая будет сравнивать строки, по скорости будет также, результат правильный.
   skunk
 
44 - 15.03.04 - 18:46
(42)фэнкс... поверю на слово...
   mike
 
45 - 15.03.04 - 20:47
для таких ситуаций
я пользуюсь своим методом : завожу в таблице  значений поле "Индекс", аналогичное Индексу Базы данных , в цикле вычисляю его и сортирую по нему. (c)Идея принадлежит ныне покойному сайту Hare.ru
   IAm
 
46 - 15.03.04 - 22:09
45 Афуенная идея. Когда я понял как сортирует 1С сия идея пришла в мою голову спустя 10 секунд. Не знал что она (с), а то б в коде копирайт поставил бы.
   Федорыч
 
47 - 16.03.04 - 10:26
Ну чтож. Подведем итоги?

Если я правилно понял, в 1с столкнулись с противоречием.
Либо сортировка ТЗ (а (спасибо skunk), и в Списке Значений тоже) работает с глюком, либо \">\" \"<\" строк работает не так.
В любом случае одно противоречит другому.

В каждой системе есть глюки. Это нормально.

Мне кажется есть несколько вариантов решения:
1. Считать это глюком и попробовать обойти любыми методами.
2. 1с интересна тем, что на эту систему работают все программеры 1с. Как в офисе так и на местах.
Может имеет смысл обратиться к \"Волшебнику\".
Либо за разъяснением, либо с просьбой повлиять на системных программистов 1с?

Что делать будем?
   BorisG
 
48 - 16.03.04 - 10:34
(47) А ты считаешь, что Волшебник в 1С работает?
Ошибаешься.
Повлиять на системных программистов 1С... ну ну...
Для этого надо не одну страницу доводов привести... и пуд соли съесть... тем более в семерке...
Проходили...
   Федорыч
 
49 - 16.03.04 - 10:59
Сможет ли помочь Волшебник решить эту задачку? Не знаю.
Но имя это имя достаточно веско.
Потому и начал этот разговор на этом сайте.
 
 
   skunk
 
50 - 16.03.04 - 11:08
(47)уж тогда Рупору спасибо, он меня просвещал на этот счет...
   BorisG
 
51 - 16.03.04 - 11:14
(49) Ну ну... Иллюзии штука, конечно, хорошая, но... извини... эта проблема волшебной палочкой не решается...
Есть единственный способ повлиять на разработчиков...
Написать на Хотлайн, чтоб проблема была зарегистрирована, получен ответ... типа "Ваше обращение зарегистрировано под номером SW....."
А потом долго - долго доказывать, что проблема ну Очень актуальна, желательно общаясь не только с Хотлайном...
Увы, но все это не один раз проходили...
Ну а разговор на сайте... так он в любом случае полезен, для того, чтобы понять степень актуальности, и получить дополнительные аргументы... в споре с 1С...
   Федорыч
 
52 - 16.03.04 - 11:22
Не понял. Зачем спорить с 1с?
Разве мы не в одном котле?
А что актуальность?
На ТЗ построен почти весь партионный учет. А отчеты?
О сравнении строк даже не говорю.

А что Волшебник молчит?
Кстати, как до него достучаться?
   BorisG
 
53 - 16.03.04 - 11:33
(52) Видно ты совсем не общался с 1С... ;-)
Мыло Волшебника внизу страницы... но вот добавить он врядли что сможет...
Я (и не только я) на этом столько копий поломал... на гораздо более актуальных вопросах...
   Федорыч
 
54 - 16.03.04 - 12:44
Верно, на таком уровне не общался.
Потому и здесь.
А спросить мнения Волшебника?
Почему бы и нет?
   Рупор абсурда
 
55 - 16.03.04 - 13:07
(54) Спроси меня ...
   Федорыч
 
56 - 16.03.04 - 13:10
(55)Прости, это не имеет смысла
   Рупор абсурда
 
57 - 16.03.04 - 13:13
(56) Потому что я - идиот? Да?
   Федорыч
 
58 - 16.03.04 - 13:19
(57)Здрасьте вам ....
Болтун? Да.
Сам все скажешь и спрашивать не надо. Тоже да.
Но глупости то зачем говорить?
   Рупор абсурда
 
59 - 16.03.04 - 13:23
(58) Здрасьте ...
Наверно, я всё же идиот ...
Иначе почему я так твёрдо уверен, что ни в одной твоей ветке, ни одной глупости я не сказал ...
   Рупор абсурда
 
60 - 16.03.04 - 13:25
(58) Тебя, наверно, тоже ник мой смущает?
Хочешь я тебе отвечу под другим?
   GrayT
 
61 - 16.03.04 - 13:37
Рупор.
Сижу твой пример (26) ковыряю - ни фига не понимаю, как это происходит? Как к этому относиться? Запомнить и все?
Можешь, хоть как то прокоментировать. Плиз.
   Рупор абсурда
 
62 - 16.03.04 - 13:43
(61) Сортировать() индексирует ТЗ, а КоличествоСтрок(Кол) (когда с установкой количества) режет строки не глядя на эту индексацию ...
Вот и выходит такая задница ...

Но глючит, в данном случае, не Сортировать(), а КоличествоСтрок() ...
   Федорыч
 
63 - 16.03.04 - 13:43
Уважаемый Рупор ...!
О глупости никто ничего не говорит.
Что проффи, то проффи. Это не мои слова. Это по ссылкам.
Но чванства и болтовни ....
Кстати ... ответь GreyT
   Рупор абсурда
 
64 - 16.03.04 - 13:46
(63) Извини, не люблю я болтать просто так ...
По делу у тебя есть что ко мне?

ЗЫ: И кто такой GreyT?
   Федорыч
 
65 - 16.03.04 - 13:48
Ты уже ответил.
А по делу см (47)
   GrayT
 
66 - 16.03.04 - 13:49
(62)Сенкс. Не могу понять как он их режет. Он ведь еще и за размер вылетает. Вечером всерьез поиграюсь. Спасибо, что подсказали - теперь, при работе с ТЗ буду внимательней.
   Рупор абсурда
 
67 - 16.03.04 - 14:10
(65) Посмотрел вопрос в (47) ...
"Что делать будем?" это ж почти "Девушка, а что вы делаете сегодня вечером?" ...
Могу рассказать, это не секрет ...
Тебе, правда, это интересно?

(66) Самое интересное, что эту индексацию можно отменить ... :))
Штатными средствами, т.е. отменить сортировку ...
Правда, нигде в доках этого нет, а значит пользовать нельзя - недокументированая фича ...
   Федорыч
 
68 - 16.03.04 - 14:20
(65)Знаешь, Рупор ...
По твоему ничего нельзя сделать?
Они диктуют правила - мы по ним играем?

Остается просто порепаться?
Тогда "Девушка". Рассказывай. Только смысла?
Ты и так это делаешь в каждой теме.

Закрываем тему?
   BorisG
 
69 - 16.03.04 - 14:35
(68) какой ты упрямый... Я же все сказал...
Для того, чтобы "провести" не очень значимый вопрос в 1С, усилий надо не меньше, чем в Госдуме ;-)
Нужно время, нервы и терпение...
Я это все не один раз проходил..., посему занимаюсь этим, когда есть соответствующий настрой... ради спрортивного интереса... либо когда проблема совсем уж серьезная...
   BorisG
 
70 - 16.03.04 - 14:38
+69 Ну почему же закрывать?
Напиши на Хотлайн, потом ответ сюда отдельной веткой, вместе будем ответ сочинять ;-)
Я серьезно, переписка с Хотлайн - занятие весьма увлекательное...
Чем не Открытое решение? ;-)
   ally
 
71 - 16.03.04 - 14:50
Федорыч, по правилам нашего форума ветка не закрывается по просьбе автора.
   Рупор абсурда
 
73 - 16.03.04 - 15:35
(71) Эх, ally, ally ..., я тебя люблю ..., а ты ...
   ally
 
74 - 16.03.04 - 15:39
(73) Тоже хочешь попросить закрыть ветку?
   Рупор абсурда
 
75 - 16.03.04 - 15:40
(74) А модераторы могут банить сами себя?
   ally
 
76 - 16.03.04 - 15:43
(75)Думаю да
   Рупор абсурда
 
77 - 16.03.04 - 16:06
"Думаю да" - сказала ally и пропала куда-то с форума на полгода ...
   skunk
 
78 - 16.03.04 - 16:18
(77)у нее где-то сейчас работа кончается... домой идет... жди вечера
   ally
 
79 - 17.03.04 - 05:05
А точнее утра :-)
   327
80 - 17.03.04 - 06:16
(68) Ну до чего ты наивен.... Аж смешно...

Не волнуйся... 1С мониторит этот форум... как и все остальные ... и при необходимости ее реакция следует через 10-15 минут...

В твоем вопросе им нас....ть на тебя (сорри, но по другому не скажешь)... Это твои проблемы...

Еще раз - не будь наивен... Есть ошибки, которые не исправляются уже 2-3 года ... И ничего... Борис правильно говорит....
   Z1
81 - 17.03.04 - 08:19
(0) А чем тебе не нравиться (43) ?
Шам шашечки или ехать?
pit ведь прав.
У тебя несколько вариантов :
1. Переписать свой алгоритм без сравнения строк используя отсрортированную ТЗ
2. Написать свою функцию сравнения строк на ВК.
Немного подумал и понял что если эту функцию хорошо написать то она будет даже немного быстрее работать чем стандартное 1с сравнение строк.
3. Написать свою функцию сравнения строк на языке 1с.
4. Долго и мучительно добиваться исправления ошибки. Но даже если ее и исправят в следущем релизе, то
"старый глюк(известный) лучше новых двух(неизвестных)."
   Федорыч
 
83 - 17.03.04 - 09:18
Идея написать функцию сравнения на ВК хороша.
Но так можноно дойти до абсурда.
1с использовать как оболочку, а все обработки перенести например на ВК или, например, на SQL.
Кстати последнее проверял. Работает. И неплохо работает.
Но ... при этом теряешь существенный плюс 1с.
Десяток ребят в центре 1с адаптируют наше "законодательство" под программый язык. И делают это пусть и с задержкой, но неплохо.
А делать это самому ?!!!! Я еще не сумасшедший.
   Федорыч
 
84 - 17.03.04 - 09:23
(81) Кстати о новых глюках.
Нам, прикладникам, приходится исправлять своих "петухов". Почему таким же программистам как мы, или почти таким же, это не сделать?
Или пусть хоть где нибудь объяснят что так и было задумано.
По крайней мере не будем тратить море времени и глотать чужие сопли. (прошу простить, по другому не скажешь)
   Z1
85 - 17.03.04 - 09:35
(83) "а все обработки перенести например на ВК или, например, на SQL. Кстати последнее проверял. Работает. И неплохо работает"
Можно ли попобробней об этом ?
   Федорыч
 
86 - 17.03.04 - 09:40
(83) Подробнее очем?
ВК, как понял, ты и сам пишешь.
1c - оболчка а SQL - движок? Это?
   Den
87 - 18.03.04 - 14:06
Да, ребята... Интереснейшую тему превратили в треп...
Хотите еще одну мулю подкину?

К=10;
Пока К<>0 Цикл
 ТЗ.ПолучитьСтрокуПоНомеру(К);
...
...
...
 К=К-1;
КонецЦикла

Прикол в том, что восемь проходов из первых все будет нормально, на девятом получим первую строку и на десятом тоже первую. Замечено в 7.7.017. Очень долго мучился, пока понял в чем прикол...
   Федорыч
 
88 - 18.03.04 - 14:09
(87)Еще лучше.
Не замечал. И в чем же дело?
   Кое-кто@где-то.там
89 - 18.03.04 - 14:24
(87) Не могу увидеть эту мульку ...
Что я не так делаю?!

Процедура Сформировать()
    ТЗ=СоздатьОбъект("ТаблицаЗначений"); 
    ТЗ.НоваяКолонка("К","Число",10,0);
    Для нс=1 по 10 Цикл
        ТЗ.НоваяСтрока();
        ТЗ.К=нс;
    КонецЦикла;    
    
    К=10; 
    Пока К<>0 Цикл 
        ТЗ.ПолучитьСтрокуПоНомеру(К); 
        Сообщить(""+К+" "+ТЗ.К);
        К=К-1; 
    КонецЦикла 
КонецПроцедуры
   Рупор абсурда
 
90 - 18.03.04 - 14:36
(89) Не переживай! Я ещё больший чайник ...
У меня и с сортировкой всё ок ...
   Федорыч
 
91 - 18.03.04 - 14:41
Рупор !
О какой сортировке речь?
   Рупор абсурда
 
92 - 18.03.04 - 14:44
(91) О сортировке по колонкам в Таблице Значений ...
   Федорыч
 
93 - 18.03.04 - 15:13
(87)(89) Сортировка?
Покажи где. Прости не вижу.
   Рупор абсурда
 
94 - 18.03.04 - 15:16
(93) См. (0)
   Федорыч
 
95 - 18.03.04 - 15:22
Похоже Den (87) нарвался на глюк 17 движка, если это не "петух".
   Рупор абсурда
 
96 - 18.03.04 - 15:31
(95) ... или не движка ...
   Федорыч
 
97 - 18.03.04 - 15:45
Рупор! Я уже понял, что ТЗ твоя любимица.
Тебе неинтересен ее храктер? Что она еще может выкинуть?
   Рупор абсурда
 
98 - 18.03.04 - 15:56
(97) Хочешь, чтоб я сразу взял и всё рассказал?
   Рупор абсурда
 
99 - 18.03.04 - 16:00
(98)+ Я должен сперва помучить, поиздеваться ...

ЗЫ: Кто сотый пост займёт - тот и идиот!
   Кое-кто@где-то.там
100 - 18.03.04 - 16:02
(99) а пофиг :)
На этом форуме кто-нить кроме меня смог "сотку" сорвать? ;)

  1  2   

Список тем форума
 
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует