Вход | Регистрация

1С:Предприятие ::

Метки:

Строка состояния

Я
   press
12.03.04 - 09:58
Делаю загрузку из dbf-ки.
...
ПриемНаРаботу.Провести();  
Если Счетчик = Цел(Файл.КоличествоЗаписей()/100) Тогда
    Процент = Процент + 1;
    Если Процент>100 Тогда
        Процент = 100;
    КонецЕсли;
    Счетчик = 0;
КонецЕсли;
Состояние("Выполняется обработка "+Процент+"%. Загружено сотрудников "+к);  
...
Мелькающее сообщение о проведении в строке состояние весь кайф ломает. Можно ли его как-нибудь внутри обработки убрать?
 
 
   press
1 - 12.03.04 - 13:30
up
   kadr
 
2 - 12.03.04 - 13:31
Ну если очень раздражает, то можно убрать вывод сообщения о проведении из процедуры обработки... А как иначе, я не знаю...
   press
3 - 12.03.04 - 13:34
Вот и я не знаю. Может кто знает?
   Рупор абсурда
 
4 - 12.03.04 - 13:35
(2) Оччч интересно! Рассказывай!
   GrayT
 
5 - 12.03.04 - 13:35
Я, если честно, вообще не понял чего ты в (0) добиваешься. Весь цикл покажи. И КоличествоЗаписей у тебя в цикле определяеться?
   press
6 - 12.03.04 - 13:44
(5)Я просто хочу чтобы у меня в строке состояния отображался процент выполнения обработки. Однако, из-за того что в цикле я создаю и провожу документ, в строке состояние мелькает что-попало. Может быть можно как-нибудь отменить сообщение о проведение в строке состояния.
   Рупор абсурда
 
7 - 12.03.04 - 13:56
(6) Штатными средствами нельзя!
Положи свой "градусник" на форму ...
   press
8 - 12.03.04 - 14:02
Точно!Спасибо, Рупор Абсурдович.
   kadr
 
9 - 12.03.04 - 14:03
(7) Звезду Рупору Абсудр Абсуродовичу! (с) Екатерина II
   press
10 - 12.03.04 - 14:06
(9) Я всеми руками ЗА!
 
  Рекламное место пустует
   It is me
 
11 - 12.03.04 - 14:39
Ну я тоже за, а что толку?
   GoldMax1
 
12 - 13.03.04 - 12:26
Подскажите пожалуйста как сделать градусник средствами 1С.

Главное чтобы при этом выполняемая задача не тормозилась
   Львенок
 
13 - 13.03.04 - 14:38
Ну я делал примерно в таком духе:

На форму реквизит типа "текст", в формулу ему слово Градусник, вокруг него рамку группы без названия.
В модуле в начале:
Перем Градусник;

В процедуре, где он ползти должен, что-то вроде:

Полоса="|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||";//Подобрать экспериментально число черточек так, чтобы точно заполняли пространство занимаетмое нашим реквизитом типа "текст" на форме.
ДлПолосы=СтрДлина(Полоса);

Для К=1 По МаксЗначение Цикл
 //...

  Процент=МаксЗначение*ДлПолосы/К;
  Градусник=Лев(Полоса,Процент);
 //...

КонецЦикла;

P.S.: Только как опробованная идея. Синтаксис не проверял, в исходном виде может не заработать как надо.
___
Искренне Ваш, Львенок.
   Львенок
 
14 - 13.03.04 - 14:41
+(13). Вот уже одну ошибку нашел. На самом деле должно быть:
 Процент=К*ДлПолосы/МаксЗначение// Вот тут была ошибка. 

 Градусник=Лев(Полоса,Процент);
   Львенок
 
15 - 13.03.04 - 15:16
Хотя нет. Так тоже не вполне работает. Накидал в конфигураторе правильный работающий вариант (кстати таже красота определенная в нем есть), думаю куда .ert выложить?
___
Искренне Ваш, Львенок.
   Львенок
 
16 - 13.03.04 - 15:25
Вот это я нафлудил в одну ээээээ... лицо. В общем, если кому интересно, ползунок (a.k.a. progress bar)стандартными средствами 1С лежит (до понедельника) тут: http://user.rol.ru/~tjs1/polzun.ert
___
Искренне Ваш, Львенок.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует