Вход | Регистрация

1С:Предприятие ::

Метки:

Проблема при выборе документов

Я
   skunk
 
07.03.04 - 10:03
ТиС 929

Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() > 0 Цикл
  Если Док.Проведен() = 1 Тогда
    Вид = Док.Вид();
    Если Вид = "РеализацияРозница" Тогда
      Сообщить(Док);
    КонецЕсли;
  КонецЕсли;
КонецЦикла;

Один документ почему то и каким то боком не попадает, видимых отличий нет. В журнале присутствует. Проведен. Открываем, проводим(иногда несколько раз, от 1 до 3). Встает.

Как енто победить.
 
  Рекламное место пустует
   Кое-кто@где-то.там
1 - 07.03.04 - 10:31
Здесь точно весь код приведен?
Выборку нигде не сбиваешь?
Переиндексация?
Тестирование и Исправление?
..
Вообще, этот код правильный и должен работать на 100%
   skunk
 
2 - 07.03.04 - 10:44
ошибка конечно не на этом возникла... но и это того, таже проблема... удаления условия проверки проведения документа, проблему решает... судя повсему 1С почему-то решает, что этот документ не проведен...
   skunk
 
3 - 07.03.04 - 10:45
тестирование и исправление проблему не решают... нет ошибок, а она есть...
   Львенок
 
4 - 07.03.04 - 11:13
А если оно же попытаться сделать запросом, отличия есть?
___
Искренне Ваш, Львенок.
   skunk
 
5 - 07.03.04 - 11:32
(4)запрос все эврибади... вообще уже ни фиха не понимаю
   skunk
 
6 - 07.03.04 - 16:24
+ убитие всех индексов... тоже проблемы не решает...

походу я первый кто на эту мину наступил, и как ее саперить ни кто незнает... жаль... будем исследовать методом научного тыка, пока не надоест..
   327
7 - 07.03.04 - 19:03
Заочно тут сказать что либо сложно .....
Какая компонента, релиз, конфа ?
   skunk
 
8 - 07.03.04 - 19:10
(7)компонента - оперативный учет
  релиз - возникла на 17, проверялось на 20 и 21
  конфа - сильно переделаная ТиС 929
   327
9 - 07.03.04 - 20:42
Посмотри, а без проверки проведения документ всегда попадает в выборку?

Если без условия всегда попадает, а с условием нет - тогда проверь, а если ли движения у этого дока? И стоит ли при этом отметка проведения в журнале .....
   skunk
 
10 - 07.03.04 - 20:48
(9)Попадает. В журнале отметка стоит. Движение у дока есть. Запросом он тоже цепляется.
 
  Рекламное место пустует
   327
11 - 07.03.04 - 22:21
Попробуй сделать Выгрузку-Загрузку - это хорошо чистит базу...

Вообще нечто подобное я встречал на бухии.... На ТиС .... Даже и не знаю что сказать
   skunk
 
12 - 08.03.04 - 00:01
(11)Спасибо, пит за помощь. Только осталось не понятно почему оно так получилось, абы это устранить, и в последствии не допустить.
   Darkman
 
13 - 08.03.04 - 00:04
Было похожее со справочником. Устанавливаещь ПорядокКодов() - при обходе обно количество реквизитов у элемента. ПорядокНаименований() - другое. выгрузка-хагрузка помогла. Эксперементальным пцтем установил что внутренни
   skunk
 
14 - 08.03.04 - 00:13
(13)а тоже причина неясна
   Darkman
 
15 - 08.03.04 - 00:25
кусок поста недописался. проблемы была во внутреннем идентификаторе. что конкретно уже не помню. или он был "нестандартным" или отсутствовал (NULL) (последнее врядоли конечно...). в общем тестирование и исправление про него молчало.только выгрузка-загрузка помогла. на будущее написал процедуру проверки. сортировки по коду, наименованию, с подсчетом кол-ва реквизитов через метаданные. долговато .. но надежно.
   skunk
 
16 - 08.03.04 - 00:36
(15)Спасибо. Вот только для доков врядли поможет, или использовать обратный порядок. Надо попробовать


Список тем форума
  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует