Вход | Регистрация

1С:Предприятие ::

Метки:

Вывод в ТЗ

Я
   SVG
 
05.03.04 - 04:42
Подскажите пожалуста начинающему, загружаю файл DBF в ТЗ, как сделать чтобы выгружались в ТЗ только те записи которые имеют значение поля=200 !
 
  Рекламное место пустует
   SnarkHunter
 
1 - 05.03.04 - 05:05
Проверяй в цикле нужное поле и, в зависимости от результат проверки, выгружай/не выгружай в ТЗ...
   SERKOLOD
 
2 - 05.03.04 - 11:45
Что то вроде этого:
    Перем Длина; 
    ДБФ = СоздатьОбъект("XBase");
    ТЗ  = СоздатьОбъект("ТаблицаЗначений");
    ДБФ.ОткрытьФайл("бла-бла.dbf");
    Если ДБФ.Открыта() = 1 Тогда
        ДБФ.Переиндексировать();
        ДБФ.Первая();
        
        Для Ном=1 по ДБФ.КоличествоЗаписей() Цикл
            ............
            ДБФ.ОписаниеПоля(,,,Длина,);
            Если Длина = 200 Тогда
                
                ТЗ.НоваяСтрока();
                
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
   SERKOLOD
 
3 - 05.03.04 - 11:46
Или 200 - это не длина, а значение?
   SVG
 
4 - 05.03.04 - 12:55
200 - это значение поля
   SnarkHunter
 
5 - 05.03.04 - 12:57
(2,3)Не взлетит...
   3V
 
6 - 05.03.04 - 14:07
(4) ну принцип-то остается тем же, в цикле выбираешь строки дбф-ки если значение равно 200 тогда ТЗ.НоваяСтрока, иначе Продолжить...


Список тем форума
Рекламное место пустует  
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует