Вход | Регистрация

1С:Предприятие ::

Метки:

Цикл по операции

Я
   Platon
 
04.03.04 - 10:15
Здравствуйте !
Когда я делаю цикл внутри операции то у меня 1с подвисает
Проблема вот в чём:
Документ на каждую строку делает по две проводки, из первой надо взять всю информацию а из второй только сумму
В этом варианте 1с подвисает

Для А=1 По Опер.КоличествоПроводок() Цикл
Опер.ПолучитьПроводкуПоНомеру(А*2);
ТЗ.СумОткл=Опер.Сумма;
Если Опер.ПолучитьПроводкуПоНомеру(А*2-1)=1 Тогда
...
ТЗ.Сум=Опер.Сумма;
КонецЕсли;

Подскажите как правильно сделать чтобы в цикле брались по две проводки
 
 
   SnarkHunter
 
1 - 04.03.04 - 10:24
Прикольно... Наступит момент, когда у тебя А станет равным Опер.КоличествоПроводок()/2+1...
   BorisG
 
2 - 04.03.04 - 10:28
Да... Очень плохо, когда основам программирования совсем не учили...
   Кое-кто@где-то.там
3 - 04.03.04 - 10:30
О=СоздатьОбъект("Операция");
    О.НайтиОперацию(ВыбОперация);
    О.ВыбратьПроводки();
    Пока О.ПолучитьПроводку()=1 Цикл 
        НомерПроводки=О.НомерПроводки();
        Если (НомерПроводки%1)=1 тогда
            Сообщить("Первая ("+НомерПроводки+") "+О.Сумма);
        Иначе
            Сообщить("Вторая ("+НомерПроводки+") "+О.Сумма);
        КонецЕсли;    
    КонецЦикла;
   327
4 - 04.03.04 - 11:45
Мдя ..... Большой Мдяяяяяяяя.........
   Platon
 
5 - 04.03.04 - 12:02
(2)Да в моём городке никто программированию и не учит
покрайней мере 1с, приходится самому доходить с вашей помощью
   IAm
 
6 - 04.03.04 - 13:27
2 Причем здесь основы программирования. Математике учат родители в 5-6 лет, в крайнем случае в школе в 7-8.
   BorisG
 
7 - 04.03.04 - 13:38
(6) Не согласен, циклы сейчас в школе в старших классах проходят ;-)
   IAm
 
8 - 04.03.04 - 13:43
7 На уроках анатомии?
   GrayT
 
9 - 04.03.04 - 13:47
Не придерайтесь. Кое-кто явно математику учил, но... НомерПроводки%1
   Кое-кто@где-то.там
10 - 04.03.04 - 14:00
мдя ... и в самом ключевом моменте ...
Надо будет не только Волшебника не только Синтакс-контроль, но и среду исполнения сюда приделать.
(0) Конечно же, 
...
Если (НомерПроводки%2)=1 тогда 
...
 
  Рекламное место пустует
   SnarkHunter
 
11 - 04.03.04 - 14:03
А кое у кого явные проблемы с "правильнописанием"... Оно хорошее, но почему-то хромает... (с)В-П
   Кое-кто@где-то.там
12 - 04.03.04 - 14:05
   GrayT
 
13 - 04.03.04 - 14:14
Грешен, каюсь :)
   Platon
 
14 - 04.03.04 - 14:18
Когда я учился в школе там даже учителя информатики небыло, а программировать (т.е пытатся) я начал только пару - тройку месяцев назад так. что не судите строго :)
   SnarkHunter
 
15 - 04.03.04 - 14:19
Когда ты учился в школе?
   Platon
 
16 - 04.03.04 - 14:21
Когда я учился в школе там даже учителя информатики небыло, а программировать (т.е пытатся) я начал только пару - тройку месяцев назад так. что не судите строго :)
   SnarkHunter
 
17 - 04.03.04 - 14:22
Когда ты учился в школе?
   Platon
 
18 - 04.03.04 - 14:24
(15)Закончил в 1993
   skunk
 
19 - 04.03.04 - 19:51
в 93 не было информатики... страно...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует