Вход | Регистрация

1С:Предприятие ::

Метки:

группы справочников

Я
   Demokratizator
 
03.03.04 - 18:58
Добрый день.
Есть справочник в котором находятся две одинаковые группы(по названию), но на разном уровне( одна не содержит другую). При переборе справочника
Спр = СоздатьОбъект("Справочник.Товары");     
Спр.ВыборГруппы(1);
Спр.ПорядокНаименований();
Спр.ВыбратьЭлементы(1); 
Пока Спр.ПолучитьЭлемент(1) = 1 Цикл
    Если Спр.Наименование = "Видео" Тогда        Сообщить(Спр);                     Сообщить(Спр.Родитель);
    КонецЕсли;
КонецЦикла;
Он находит только одну группу которая в себя включает непосредственно товар.
Другая группа содержит подгруппы.
а еадо что-бы находила вторую группу?
Как это сделать?
Спасибо!
 
  Рекламное место пустует
   Кое-кто@где-то.там
1 - 03.03.04 - 19:02
ВыборГруппы тут не нужен и вообще - юзай Запрос...
   Кое-кто@где-то.там
2 - 03.03.04 - 19:08
Спр = СоздатьОбъект("Справочник.Товары");     
Спр.ВыбратьЭлементы(0);
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если СокрЛП(Спр.Наименование) = "Видео" Тогда        
...
КонецЕсли;
КонецЦикла;
   Рупор абсурда
 
3 - 03.03.04 - 19:09
(2) Хороший запрос!
   Рупор абсурда
 
4 - 03.03.04 - 19:15
:))
Я прям слышу, как Кое-кто@где-то.там запрос пишет ...
   Рупор абсурда
 
5 - 03.03.04 - 19:16
(4)+ Долго чё-то не писал, наверно, давно запросов ...
   buh worm
6 - 03.03.04 - 19:26
2(0) А по коду не судьба?
   327
7 - 03.03.04 - 19:58
(6) а теперь представь себе.... что дятел юзер изменил код .... и ты получишь хАроший подарок....

(0) Ученье - свет.... а неученье - канава.... копать отсюда и до обеда ....
   КККК
8 - 03.03.04 - 20:33
(7) а если дятел юзер изменит наименование?
   Львенок
 
9 - 03.03.04 - 21:53
(8) А кто же тогда будет медвежонком? (с) Сергей Козлов
___
Искренне Ваш, Львенок.
   327
10 - 03.03.04 - 22:20
(8) из той же оперы.... Ни наименование, ни код нельзя брать за основу для позиционирования на нужный элемент без выбора элемента.... Можно брать только неизменяемый признак....

И такой признак есть.... внутренний идентификатор элемента .....
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует  
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует