Вход | Регистрация

1С:Предприятие ::

Метки:

Удаление истории переодического реквизита в справочнике.

Я
   AlexABel
 
03.03.04 - 12:07
Здравствуйте!
Как можно программно удалить из истории переодического реквизита запись на определенную дату.

В справочнике для работы с переодическими реквизитами используются только методы ПОЛУЧИТЬ и УСТАНОВИТЬ.
 
  Рекламное место пустует
   SnarkHunter
 
1 - 03.03.04 - 12:08
Объект Периодический
   AlexABel
 
2 - 03.03.04 - 12:12
У реквизита справочника в свойствах стоит флажок возле "Переодический" и у "Изменяется Документами".
   Рупор абсурда
 
3 - 03.03.04 - 12:13
(2) В (1) был не вопрос, а ответ ...
   AlexABel
 
4 - 03.03.04 - 13:02
Спасибо.
Но вот еще один вопрос на эту тему
Процедура ОбработкаУдаленияПроведения();
    
пПериод=СоздатьОбъект(\\\"Периодический\\\");
спрЭмитент=СоздатьОбъект(\\\"Справочник.Эмитенты\\\");
    спрЭмитент.НайтиПоКоду(кодЕДРПОУ);
    пПериод.ИспользоватьОбъект(\\\"Колво\\\",КолВо);
    пПериод.ОбратныйПорядок();
    пПериод.ВыбратьЗначения();
    Пока пПериод.ПолучитьЗначение()=1 Цикл
    Если пПериод.ДатаЗнач=ДатаДок Тогда
        пПериод.Удалить();
    КонецЕсли;
    КонецЦикла;    
    
КонецПроцедуры

В справочнике \\\"Эмитенты\\\" реквизит \\\"Колво\\\" периодический
А в работе появляется ошибка
пПериод.ИспользоватьОбъект(\\\"Колво\\\",КолВо);
{Документ.ДоговорЦБ.Модуль Документа(27)}: Колво не является константой или периодическим параметром!

Почему?
   Рупор абсурда
 
5 - 03.03.04 - 13:22
(4) А что такое КолВо?
   SnarkHunter
 
6 - 03.03.04 - 13:22
пПериод.ИспользоватьОбъект("Колво",спрЭмитент.ТекущийЭлемент())
   AlexABel
 
7 - 03.03.04 - 13:27
Для (5) КолВо переменная содержащая числовые данные
(6) Спасибо. Сработало.
Тема закрыта.
   Рупор абсурда
 
8 - 03.03.04 - 13:34
(7) И сильно она периодическая у тебя?
Эта "переменная содержащая числовые данные"?
   SnarkHunter
 
9 - 03.03.04 - 14:06
(8)Тебе же сказали - вопрос закрыт... Этому новичку я помог... :-)
   Рупор абсурда
 
10 - 03.03.04 - 14:42
(9) Лезешь везде с флудом своим, только мешаешь нормальным пацанам помогать новичкам ...
 
 
   327
11 - 03.03.04 - 15:08
ПерДические реквизиты удаляют только в больнице ...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует