Вход | Регистрация


1С:Предприятие ::

Метки:

Язык запросов

Я
   Nelson
 
02.03.04 - 16:36
Может, кто подскажет, что не так????:

Запрос=СоздатьОбъект("Запрос");
Запрос=Запрос.Выполнить("
|Период с {НТП} по {КТП};
|Сот=ЖурналРасчетов.Зарплата.Объект;
|РПер=ЖурналРасчетов.Зарплата.ПериодРегистрации;
|Группировка РПер;
|Группировка Сот без групп;
|");
    
Если Запрос=0 Тогда   
   Возврат;
КонецЕсли;

Пока Запрос.Группировка("РПер")=1 Цикл
       ......
Выдает ошибку:
{Отчет...}: Значение не представляет агрегатный объект (Группировка)
 
  Рекламное место пустует
   Рупор абсурда
 
1 - 02.03.04 - 16:39
:))
   afk
2 - 02.03.04 - 16:46
хе-хе-хе... девушка, на момент "Пока Запрос.Группировка( " чему у вас равна переменная Запрос?

стремление использовать как можно меньше переменных - очень мило...
   Рупор абсурда
 
3 - 02.03.04 - 16:48
(1)+ Сори, я тут чтобы помогать ...
Забываю иногда и смеюсь ...
Сори ...

Метод Выполнить() объекта "Запрос" возвращает 0 или 1, в зависимости от того выполнился запрос или нет ...
   afk
4 - 02.03.04 - 16:50
Рупор, она это знает!! .. там же дальше проверка
   Nelson
 
5 - 02.03.04 - 16:55
Запрос=1
   Рупор абсурда
 
6 - 02.03.04 - 16:56
(4) Она? Она не мужчина? ...
   Nelson
 
7 - 02.03.04 - 16:58
Так, может, мужчины мне помогут?
   Рупор абсурда
 
8 - 02.03.04 - 17:00
(7) Чтоб покороче, вот так напиши:

Если Запрос.Выполнить(" 
|Период с {НТП} по {КТП}; 
|Сот=ЖурналРасчетов.Зарплата.Объект; 
|РПер=ЖурналРасчетов.Зарплата.ПериодРегистрации; 
|Группировка РПер; 
|Группировка Сот без групп; 
|") =0 Тогда   
  Возврат; 
КонецЕсли;
   afk
8 - 02.03.04 - 17:00
девушка, и чего вы от единицы хотите в "Пока Запрос.Группировка(" ??!
   Рупор абсурда
 
9 - 02.03.04 - 17:02
(7) Чтоб покороче, вот так напиши:

Если Запрос.Выполнить(" 
|Период с {НТП} по {КТП}; 
|Сот=ЖурналРасчетов.Зарплата.Объект; 
|РПер=ЖурналРасчетов.Зарплата.ПериодРегистрации; 
|Группировка РПер; 
|Группировка Сот без групп; 
|")=0 Тогда   
  Возврат; 
КонецЕсли;
   Nelson
 
10 - 02.03.04 - 17:06
(8) Много чего:-) Это важно?
 
  Рекламное место пустует
   Nelson
 
11 - 02.03.04 - 17:12
(9) Рупору спасибо, проскочило. Но непонятно...
   afk
12 - 02.03.04 - 17:15
хе-хе-хе... а что вы МОЖЕТЕ получить от простой единички??!!
   Рупор абсурда
 
13 - 02.03.04 - 17:26
(11) Кстати, круглые скобочки в запросах - это пережиток прошлого ...
   Nelson
 
14 - 02.03.04 - 17:44
Боже, как я отстала:))) В каком хоть месте эти кругленькие скобочки? И что взамен них?
   Рупор абсурда
 
15 - 02.03.04 - 17:47
(14) Не кругленькие, я ошибся ...
Фигурненькие! ...
Просто убери их и всё ...
   Nelson
 
16 - 02.03.04 - 17:52
ОК. Просто, когда я пишу отчеты, то копирую куски из других программ, а не набираю весь текст. Иначе леплю орфографические ошибки.
   Рупор абсурда
 
17 - 02.03.04 - 17:54
(16) Из какой программы ты скопировала (0)?
   Nelson
 
18 - 02.03.04 - 18:05
Из своих же. Я, естественно, блочок сократила. Но конструкция работает. Правда, это из старой 35-ой ЗПиК. Может, в этом дело? В языке что-то изменилось? Документация, по-моему, идентичная (недавно купили сетевую ЗПиК).
   ally
 
19 - 02.03.04 - 18:10
Nelson, оставайся такой-же трогательной... Правда, а то огрубеешь тут с ними
   Nelson
 
20 - 02.03.04 - 18:17
Ну мне положено. Как-никак, слабый пол.
   ally
 
21 - 02.03.04 - 18:20
Я тоже, еслив че ;-)
   Рупор абсурда
 
22 - 02.03.04 - 18:20
(19) Молодец, Элли! Другой бы просто обозвал нас грубыми свиньями ...
А ты ..., а ты ...   Ну, короче ..., это хорошо! :))
______________
Искренне Ваш, поросёнок.
   gr13
 
23 - 02.03.04 - 18:48
(22) началось...
   Рупор абсурда
 
24 - 02.03.04 - 18:51
(23) Хм ... А я как бы на этом закончить уже хотел ...
Можно?
   gr13
 
25 - 02.03.04 - 18:52
(24) это радует
   Рупор абсурда
 
26 - 02.03.04 - 18:58
(25) Если хочешь, можешь обидеть меня просто так, без причины ...
   gr13
 
27 - 02.03.04 - 19:11
(26) честно сказать- не хочу, домой собираюсь, а тебя потом успокаивай...
   Рупор абсурда
 
28 - 02.03.04 - 19:26
(27) Я привык ..., так что, если что, не стесняйся ...
   gr13
 
29 - 02.03.04 - 19:28
(28) не виря я тебя не обижал, не было такого. Хотя иногда стоило бы пожурить, да меня не было
   Рупор абсурда
 
30 - 02.03.04 - 19:39
(29) Никогда не стоило!
   gr13
 
31 - 02.03.04 - 19:42
(30) давай не будем спорить? ты же знаешь: даже на голом курсанте можно найти до 7 недостатков (с)
   Рупор абсурда
 
32 - 02.03.04 - 19:43
(31) Я не курсант и не голый, но самое главное, у меня нет недостатков ...
   gr13
 
33 - 02.03.04 - 19:52
(32) никто не совершенен, Рупор, никто...
 
  Рекламное место пустует
   Рупор абсурда
 
34 - 02.03.04 - 20:01
(33) Угу, особенно эксперты здешние
   gr13
 
35 - 02.03.04 - 20:05
(34) может еще пальцем покажешь?
   Рупор абсурда
 
36 - 02.03.04 - 20:08
(35) Покажу! Только сперва скажи, за что ты вчера мою ветку "Хумор" завалил?
   ally
 
37 - 02.03.04 - 20:14
(36)Хумор я завалила, Рупор.
   Рупор абсурда
 
38 - 02.03.04 - 20:15
(35) Извини, не покажу!
(37) За что?



Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует