Вход | Регистрация


1С:Предприятие ::

Метки:

Вопрос специально для Рупор абсурда

Я
   kadr
 
02.03.04 - 14:01
Многоуважаемый Рупор абсурда! Подскажите пожалуйста почему при выполнении нижеприведенной обработки не все реквизиты заполняются (причем нельзя сказать однозначно какие)

Сотрудники = СоздатьОбъект("Справочник.Сотрудники");
    Документы  = СоздатьОбъект("Документ.ПриказОПриемеНаРаботу");
    Документы.ВыбратьДокументы();
    Сотрудники.ВыбратьЭлементы();
    
    Пока Сотрудники.ПолучитьЭлемент() = 1 Цикл
        Если Сотрудники.ТекущийЭлемент().ЭтоГруппа() = 0 Тогда
            Документы.ВыбратьДокументы();
            Пока Документы.ПолучитьДокумент() = 1 Цикл
                Если Документы.ТекущийДокумент().Сотрудник.Наименование = Сотрудники.ТекущийЭлемент().Наименование Тогда
                    Оклад               = Сотрудники.ТекущийЭлемент().Оклад.Получить(ТекущаяДата());
                    Ставка              = Сотрудники.ТекущийЭлемент().Ставка.Получить(ТекущаяДата());
                    ПроцентЕжемесПремии = Сотрудники.ТекущийЭлемент().ПроцентЕжемесПремии.Получить(ТекущаяДата());
                    ФормаТруда          = Сотрудники.ТекущийЭлемент().ФормаТруда.Получить(ТекущаяДата());
                    Должность           = Сотрудники.ТекущийЭлемент().Должность.Получить(ТекущаяДата());
                    Подразделение       = Сотрудники.ТекущийЭлемент().Подразделение.Получить(ТекущаяДата());
                    ГрафикРаботы        = Сотрудники.ТекущийЭлемент().ГрафикРаботы.Получить(ТекущаяДата());
                    Документы.ТекущийДокумент().Оклад               = Оклад;
                    Документы.ТекущийДокумент().Ставка              = Ставка;
                    Документы.ТекущийДокумент().ПроцентЕжемесПремии = ПроцентЕжемесПремии;
                    Документы.ТекущийДокумент().ФормаТруда          = ФормаТруда;
                    Документы.ТекущийДокумент().Должность           = Должность;
                    Документы.ТекущийДокумент().Подразделение       = Подразделение;
                    Документы.ТекущийДокумент().ГрафикРаботы        = ГрафикРаботы;
                    Документы.Записать();
                    Документы.Провести();
                    Состояние(Сотрудники.ТекущийЭлемент().Наименование);
                    Прервать;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
 
 
   SnarkHunter
 
1 - 02.03.04 - 14:03
ТекущийДокумент() - лишнее...
Да и позиционирования на документ нету...
Ключница водку делала... (с)
   kadr
 
2 - 02.03.04 - 14:04
(1) Як это нету? А как же ПолучитьДокумент?
   kadr
 
3 - 02.03.04 - 14:04
+2 Ведь некоторые реквизиты заполняются...
   mos-ad
 
4 - 02.03.04 - 14:06
а все переодические реквизиты присутствуют в справочнике сотрудникики?
   Рупор абсурда
 
5 - 02.03.04 - 14:06
(0) Это развод? Или это ты серьёзно?
   SnarkHunter
 
6 - 02.03.04 - 14:07
(2)Срочно на курсы изучения матчасти...
   mos-ad
 
7 - 02.03.04 - 14:08
+4
Оклад, Ставка и т.д. какой тип?
   kadr
 
8 - 02.03.04 - 14:09
(5) Серьезно
(6) Какой-какой части?
   Рупор абсурда
 
9 - 02.03.04 - 14:10
(8) Мой тебе совет: Бросай программирование пока не поздно ...
Не твоё это дело! ... :((
   kadr
 
10 - 02.03.04 - 14:11
(7) На вообще они все разные и описаны в конфигураторе
 
  Рекламное место пустует
   SnarkHunter
 
11 - 02.03.04 - 14:11
Ну ты кадр... 25-й...
   kadr
 
12 - 02.03.04 - 14:12
(9) Да я бы бросил... Так ведь нельзя... Вот и приходится извращаться
   mos-ad
 
13 - 02.03.04 - 14:12
:) прикольно
   kadr
 
14 - 02.03.04 - 14:12
(Всем) Хорош прикалываться!
   Композитор
 
15 - 02.03.04 - 14:12
Уважаемый Рупор абсурда! Судя по сабжу, на Вас ходят, как раньше ходили на Стрельцова. Это стоит звезд.
   SnarkHunter
 
16 - 02.03.04 - 14:14
Эту бы ветку к Camino в коллекцию...
   Рупор абсурда
 
17 - 02.03.04 - 14:14
(15) А кто такой Стрельцов?
   kadr
 
18 - 02.03.04 - 14:15
Ну вот... опять воду поналили только :(((
   SnarkHunter
 
19 - 02.03.04 - 14:16
Читай (1)... Там 75% ответа...
   Рупор абсурда
 
20 - 02.03.04 - 14:16
(18) А надо было написать тебе обработку?
   Рупор абсурда
 
21 - 02.03.04 - 14:16
(19) Меньше ...
   SnarkHunter
 
22 - 02.03.04 - 14:18
(21)Согласен... 74%...
   kadr
 
23 - 02.03.04 - 14:19
(20) Я думаю что надо. У меня данные датированы 12 января, а мне надо расчет зарплаты сделать за январь месяц. Так я перекидывают данные в приказ о приеме на работу, который имеет более раннюю дату. Или есть другой способ?
   kadr
 
24 - 02.03.04 - 14:21
(19) И все таки я не пойму почему нет позиционирования... Я в отладчике отслеживаю переменную документ и он показывает текущий документ, вроде... :((
   Композитор
 
25 - 02.03.04 - 14:21
(17) Он у футболистов в таком же авторитете, как Моцарт у нас, у композиторов.
   SnarkHunter
 
26 - 02.03.04 - 14:22
(24)Вот тут-то и проявляется волшебство 1С...
   kadr
 
27 - 02.03.04 - 14:23
(26) Злые вы... Ну давайте колитесь в чем косяк!
   SnarkHunter
 
28 - 02.03.04 - 14:24
Читай (1)...
Маячок: есть метод НайтиДокумент...
   kadr
 
29 - 03.03.04 - 06:53
А можно еще маячок? :)
   FAM
 
30 - 03.03.04 - 09:23
Документы.ТекущийДокумент().Оклад ...
+(1) Спасут отца русской демократии
   It is me
 
31 - 03.03.04 - 09:56
Док=СоздатьОбъект("Документ");
Док.НайтиДокумент(Документы.ТекущийДокумент());
Док.Оклад        = Оклад;
Док.Записать();
Док.Провести();
//Это уже целый Фаросский маяк, смотри внимательнее, //может заметишь :))
   fez
 
32 - 03.03.04 - 14:15
(27) Косяк в том, что при записи документа сбивается позиционирование в выборке.
И в твоем случае лучше создавать два объекта "Документ.ПриказОПриемеНаРаботу": один для выборки, второй для записи.

Ну и ТекущийДокумент()/ТекущийЭлемент() правда всюду выкини. А то смотреть страшно.

Кстати, конструкция
Сотрудники.ТекущийЭлемент().Оклад.Получить(ТекущаяДата())
может не работать именно из-за наличия лишней точки - .Получить() не работает больше, чем через три точки, см. сюда: http://1c.alterplast.ru/faq/ref.html , первый вопрос
   SnarkHunter
 
33 - 03.03.04 - 14:17
 
  Рекламное место пустует



Список тем форума
  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует