Вход | Регистрация


1С:Предприятие ::

Метки:

замена значения в ТЗ

Я
   mala
 
02.03.04 - 10:17
Помогите!
Есть ТЗ.Одно из значений необходимо заменить на другие.Есть такой метод - Установить значение(строка,колонка,значение).С колонкой и значением все ясно,а вот строка- я не знаю.Мне надо перебрать все ТЗ и в каждой строке заменить значение на другое.HELP!
 
  Рекламное место пустует
   shura
 
1 - 02.03.04 - 10:18
Таб.ВыбратьСтроки();
Пока Таб.ПолучитьСтроку=1 Цикл
    Таб.Рекв1=Таб.Рекв2*0.2;
    Таб.Рекв2=Значение1;
КонецЦикла;
   mala
 
2 - 02.03.04 - 10:23
В общем ясно,но потом я опять выбираю строки,а там старое значение.Или обязательно надо выгружать в новТЗ?
   mala
 
3 - 02.03.04 - 10:34
ПОМОГИТЕ!!!
   SnarkHunter
 
4 - 02.03.04 - 10:38
Покажи свой кусок кода, где все это происходит...
   mala
 
5 - 02.03.04 - 10:56
Пока ТЗ.ПолучитьСтроку()=1 Цикл
        н = н+1;
        Если ТЗ.Сеч <=18.00 Тогда
   ///    ТЗ.УстановитьЗначение("Сеч","до 18");

        ТЗ.Сеч    = "18 и меньше";
        КонецЕсли;
и т.д.
КонецЦикла;
ТЗ.ВыбратьСтроку();
и тут опять появляются старые значения.
Что сделать чтобы вместо старых значений например:10,12,16,18
появилось новое значение в строках "18 и меньше"
   SnarkHunter
 
6 - 02.03.04 - 10:57
Условие
Если ТЗ.Сеч <=18.00 Тогда
никогда не выполняется...
   mala
 
7 - 02.03.04 - 10:59
Почему?И что мне делать?Мне надо.
   SnarkHunter
 
8 - 02.03.04 - 11:02
Значения в колонке Сеч какого типа? Строковые?
   mala
 
9 - 02.03.04 - 11:07
Нет.Число.И как мне быть?
   Рупор абсурда
 
10 - 02.03.04 - 11:08
ТЗ.Сортировать("Сеч");
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл 
 Если ТЗ.Сеч > 18 Тогда Прервать КонецЕсли;
 ТЗ.Сеч = "18 и меньше"; 
КонецЦикла;
 
  Рекламное место пустует
   Композитор
 
11 - 02.03.04 - 11:09
(9) Добавить поле (колонку).
   shura
 
12 - 02.03.04 - 11:11
(7) Посмотри в отладчике, какие значения возвращаются.
И вообще, покажи кусок кода, где колонки определяешь.
   mala
 
13 - 02.03.04 - 11:14
Ура!!!По поводу добавить колонку что-то тяму не хватило.
Спасибо большое!!!А как предложил Рупор абсурда здорово,
но не подходит т.к. там сортировка по пяти параметрам и придется много сравнивать.Но он или она этого же не знали.Спасибо большое.Попробую сделать.
   SnarkHunter
 
14 - 02.03.04 - 11:14
(9)ИМХО ошибаешься...
   mala
 
15 - 02.03.04 - 11:15
В чем?
   Рупор абсурда
 
16 - 02.03.04 - 11:17
(13) А пересортировать потом как надо?
   SnarkHunter
 
17 - 02.03.04 - 11:17
В том, что число...
   mala
 
18 - 02.03.04 - 11:17
Есть документ.За определенный период выбираю запросом и формирую ТЗ
   SnarkHunter
 
19 - 02.03.04 - 11:18
Ну как всегда... Гланды, автоген...
   Рупор абсурда
 
20 - 02.03.04 - 11:18
(18) И что попадает в колонку "Сеч"?
   mala
 
21 - 02.03.04 - 11:18
А в документе этот реквизит - число
   Рупор абсурда
 
22 - 02.03.04 - 11:19
(21) Тогда можно просто поменять тип колонки ...
   mala
 
23 - 02.03.04 - 11:21
Я уже не знаю.Видать знаний не хватает.Подскажите пожайлуста.
   mala
 
24 - 02.03.04 - 11:25
SnarkHunter объясни пожайлуста причем Гланды, автоген
Я вообще что-то не так делаю?
   SnarkHunter
 
25 - 02.03.04 - 11:25
(23)Для того, чтобы подсказать, надо иметь хотя бы контуры конечной цели... Выхватив кусок кода из контекста конечную цель понять трудно...
   IAm
 
26 - 02.03.04 - 11:27
Я бы такие ветки срубал бы. Это уровень форума.
   Рупор абсурда
 
27 - 02.03.04 - 11:29
(24) Не обращай внимания ... Он всегда так чайников пугает ...



Список тем форума
Рекламное место пустует  
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует