Вход | Регистрация

1С:Предприятие ::

Метки:

Можно ли принудительно выйти из конструкции?

Я
   SemT
 
09.12.04 - 17:36
Могу ли я сделать проверку внутри ниже следующей конструкции и в определенном случае выйти из этой конструкции.
(тоже саме в некоторых языках делает "break")

Пока Запрос2.Группировка("Покупатель")=1 Цикл
   Пока Запрос2.Группировка("ДатаДок")=1 Цикл
      <Выполняются всякие действия и проверки>
      Таб.ВывестиСекцию("Строка_1");    
    КонецЦикла;
КонецЦикла;
 
 
   Asmody
 
1 - 09.12.04 - 17:36
Прервать;
   Ёжик в тумане
 
2 - 09.12.04 - 17:40
Попытка
  Пока Запрос2.Группировка("Покупатель")=1 Цикл 
    Пока Запрос2.Группировка("ДатаДок")=1 Цикл 
     <Выполняются всякие действия и проверки>
     
      Если КакаяТоПроверка()=1 Тогда
       //выходим!

        Нечно=СоздатьОбъект("ПолнаяЛажа");
      КонецЕсли;
      
      Таб.ВывестиСекцию("Строка_1");     
    КонецЦикла; 
  КонецЦикла;
Исключение
 //вот и вышли;

КонецПопытки;
   Бивень
 
3 - 09.12.04 - 17:42
(2) Сам придумал?
   GrayT
 
4 - 09.12.04 - 17:44
(2)Извращенец!
   SemT
 
5 - 09.12.04 - 17:45
(1) Спасибо! Сделал.
(2) ИМХО (1) способ проще. Но все равно спасибо.
   Ёжик в тумане
 
6 - 09.12.04 - 17:46
(3,4) Всегда так делаю, когда мне весело. %)
   Еще способ
7 - 09.12.04 - 17:48
...короче чем в (1) - ты наверное будешь удивлен, но "break" ))
   Бивень
 
8 - 09.12.04 - 17:51
SemT, GrayT, вы что однофамильцы?
   SemT
 
9 - 09.12.04 - 18:05
Мы братья по несчастью. :)
   Бивень
 
10 - 09.12.04 - 18:05
(9) Бог обидел?
 
 
   GrayT
 
11 - 09.12.04 - 18:11
(9)А какое у тебя несчастье? У меня одно уже есть....
   Бивень
 
12 - 09.12.04 - 18:23
(11) Член маленький?
   GrayT
 
13 - 09.12.04 - 18:29
(12)Нет, там все нормально. Банный лист в виде выроста из верхней челюсти. Прицепенился....


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует