Вход | Регистрация

1С:Предприятие ::

Метки:Встроенный язык

Как с наиболее эффективно разбить строку на подстроки?

Я
   YuRA
 
08.12.04 - 21:07
Всем привет. Я еще новичок в мире 1С, потому не обессудьте, если вопрос покажется глупым. Итак, повторяю сабж: как разбить строку на подстроки? Для примера, в php (я на нем много работал, потому он мне ближе) есть функция explode. передаешь ей параметрами строку, разделитель и получаешь на выходе массив. Если что-нить подобное в 1Cv8. А если нет, как это дело наиболее эффективно реализовать?
 
 
   Волшебник
 
1 - 08.12.04 - 22:03
Разделитель = " ";
ОстатокСтроки = ИсходнаяСтрока;
Слова = Новый СписокЗначений;

Пока ОстатокСтроки <> "" Цикл
    
   ПозРазд = Найти(ОстатокСтроки,Разделитель);
   Если ПозРазд > 0 Тогда
       ОчередноеСлово = Лев(ОстатокСтроки,ПозРазд-1);
       Слова.Добавить(ОчередноеСлово);
       ОстатокСтроки = Сред(ОстатокСтроки,ПозРазд+1);
   Иначе//последнее слово

       Слова.Добавить(ОстатокСтроки);
       ОстатокСтроки = ""; 
   КонецЕсли;

КонецЦикла;

    
    Для Каждого зн Из Слова Цикл
        Сообщить(зн.Значение);
    КонецЦикла;


Список тем форума
Рекламное место пустует   Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует