Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:Запросы и построители

Подскажите с БУХ Запросом

Ø
Я
   VitAL
02.12.04 - 21:24
БухИт.ВыполнитьЗапрос(, ТекущийДокумент(), Сч,,,,,);
БухИт.ВыбратьВалюты(,,,,);
Пока БухИт.ПолучитьВалюту(,) = 1 Цикл
 ...
 ...
КонецЦикла;
Выбирает только одну валюту, хотя по карточке счета их там немеряно. Конфа комплексная, релиз 21. В чем грабли?
 
 
   Птица
1 - 02.12.04 - 21:32
Найди 10 отличий:
//*******************************************
//{{БУХГАЛТЕРСКИЙ ЗАПРОС(Сформировать)//Данный фрагмент построен конструктором.
//При повторном использовании конструктора, внесенные вручную изменения будут потеряны!!!//{{ Схема номер 1
Процедура Сформировать()
  Таб = СоздатьОбъект("Таблица");
  Таб.ИсходнаяТаблица("Сформировать");
  Ит = СоздатьОбъект("БухгалтерскиеИтоги");
  Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, ВыбСчет,,, 1,, "СВ");
  Таб.ВывестиСекцию("Шапка");
  Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
  Ит.ВыбратьВалюты();
  Пока Ит.ПолучитьВалюту() = 1 Цикл
    Таб.ВывестиСекцию("Валюта");
  КонецЦикла;
  Таб.ВывестиСекцию("Подвал");
  Таб.ТолькоПросмотр(1);
  Таб.Показать("Сформировать","");
КонецПроцедуры//}}БУХГАЛТЕРСКИЙ ЗАПРОС
(с)конструктор бух.запросов
   pit
2 - 02.12.04 - 22:07
Немеряно - это сколько?
У меня всего 2 валюты бакс и евро...
.
P.S. последний параметр в выполнить запрос посмотри
   Птица
3 - 02.12.04 - 22:10
(2)ты знал, ты знал! :)
   VitAL
4 - 02.12.04 - 22:37
Немеряно, это 1, 2, много. А вообще 6. Кстати трабл был в разделители учета, ступилз сам. Всем спасибо.
   стыдно
5 - 03.12.04 - 01:40
(4) че, серьезно, прям так и в разделителе?



Список тем форума

Форум Территория 1С

Рекламное место пустует  
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует