Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Пиктограммамы в табл ЧАСТИ документа?

Ø
Я
   swinole
02.12.04 - 18:13
Ну допусти в табл части есть не реквизит а текстовая переменная, недоступная для записи. в ее свойствах стоит флажок "Показывать пиктограммы". как сделать так что на форме отразились пиктограммы
в случае с табл значений достаточно присвоить этой переменно число от 1 до шести, а вот как табл части документа....
 
  Рекламное место пустует
   Дед Иван
1 - 02.12.04 - 18:15
Два раза жмешь на табл часть , выбираешь там картинку для нее ! И в Формуле текстовой переменной присваиваешь число пиктограммки !
   DeiMos
2 - 02.12.04 - 18:15
Галочка в табличной части документа
 
Делаем:
1.Реквизит табл.части "Флаг" - тип "число"
2.Функция Галка()
пикт=1;
Если Флаг=1 Тогда
Пикт=2;
КонецЕсли;
Возврат Пикт;
КонецФункции
3.Вставляем текст в таб.часть документа вешаем функцию п.2, назн.идент "Галк"
4.Указываем показывать пиктограммы
5.Выбираем картинку на табл.часть
6.Процедура ПриНачалеРедактированияСтроки()
Если Форма.ТекущаяКолонка()="Галк" Тогда
Если Флаг=1 Тогда
Флаг=0
Иначе
Флаг=1;
КонецЕсли;
Галка();
КонецЕсли;
КонецПроцедуры
Все//
   swinole
3 - 02.12.04 - 18:28
Как с одной пиктограмкой работать понятно, а как если хочеться больше одной...
   Муму после всплытия
4 - 02.12.04 - 18:32
(3)
"в случае с табл значений достаточно присвоить этой переменно число от 1 до шести"......................... что за магическое число "6"??
   Uho
5 - 02.12.04 - 18:32
Картинка должна быть формата .bmp, содержать все пиктограммы для этой таблицы значений и состоять из последовательности пиктограмм размером 16х15 пикселей. (Из описания ВыводитьПиктограммы())
   swinole
6 - 02.12.04 - 18:34
Всем спасибо - разобрался
(4) 6 - это у меня всего 6 пиктограмм было...



Список тем форума

Форум Территория 1С

 
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует